X
Tap here to go to the mobile version of the site.

Support Forum

"open link in new tab" option is broken

Posted

Hello! The checkbox for the above option is NOT CHECKED thus should Firefox not jump to the newly opened tab but it does. Checking/unchecking doesn't help, the option seems to be broken.

Any tips on how to figure out what i wrong?

Hello! The checkbox for the above option is NOT CHECKED thus should Firefox not jump to the newly opened tab but it does. Checking/unchecking doesn't help, the option seems to be broken. Any tips on how to figure out what i wrong?

Chosen solution

Hello richalfj,

Hopefully I get this right : you want links to open in a new tab, but in the background ....

If so, would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar browser.tabs.load

Look for the preference browser.tabs.loadInBackground

and set its value to true

Maybe you'd like to change the values of the other two preferences as well (?)

After you've changed a value (or values), close and restart Firefox.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

McCoy
  • Top 10 Contributor
520 solutions 4884 answers

Chosen Solution

Hello richalfj,

Hopefully I get this right : you want links to open in a new tab, but in the background ....

If so, would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar browser.tabs.load

Look for the preference browser.tabs.loadInBackground

and set its value to true

Maybe you'd like to change the values of the other two preferences as well (?)

After you've changed a value (or values), close and restart Firefox.

Hello richalfj, Hopefully I get this right : you want links to open in a new tab, but in the background .... If so, would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''browser.tabs.load''' Look for the preference '''browser.tabs.loadInBackground''' and set its value to '''true''' Maybe you'd like to change the values of the other two preferences as well (?) After you've changed a value (or values), close and restart Firefox.
Was this helpful to you? 1
Quote

Question owner

Hello and thanks!

The setting you referred to was already set to "true". That's when I realized it was my bookmarks that switched immediately when opening those in a new tab. Changed that value instead and now it's working the way I want! Thanks! :)

Hello and thanks! The setting you referred to was already set to "true". That's when I realized it was my bookmarks that switched immediately when opening those in a new tab. Changed that value instead and now it's working the way I want! Thanks! :)
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
520 solutions 4884 answers

I'm glad you got things working the way you wanted to - well done  !

I'm glad you got things working the way you wanted to - well done !
Was this helpful to you? 0
Quote
needsleep 0 solutions 5 answers

I have the same problem. My browser.tabs.loadInBackground was already set to true.

I open new links I find on a page (not bookmarked links) in new tabs. I'm on an older PC and things take a while to load, so I'd prefer to load new tabs in the background and continue reading current tab.

what's the next troubleshooting step?

I have the same problem. My browser.tabs.loadInBackground was already set to true. I open new links I find on a page (not bookmarked links) in new tabs. I'm on an older PC and things take a while to load, so I'd prefer to load new tabs in the background and continue reading current tab. what's the next troubleshooting step?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
520 solutions 4884 answers

Hello needsleep,

Assuming that your OS is Windows, would you please go to :

3-bar menu => Options => General => under "Tabs"

uncheck : "When you open a link in a new tab, switch to it immediately"

Then reload the page or close and restart Firefox.

Does that make a difference  ?

Hello needsleep, Assuming that your OS is Windows, would you please go to : 3-bar menu => Options => General => under "Tabs" '''un'''check : "When you open a link in a new tab, switch to it immediately" Then reload the page or close and restart Firefox. Does that make a difference ?
Was this helpful to you? 0
Quote
needsleep 0 solutions 5 answers

Yes I am using Windows (sorry about not mentioning that). Windows 7 pro, 64-bit.

That option was already unchecked. This is what my post is about - this option, when unchecked, should not shift focus to the tab where the new link is being opened. Instead, it should open the tab in the background and allow me to continue reading on the original tab.

Yes I am using Windows (sorry about not mentioning that). Windows 7 pro, 64-bit. That option was already unchecked. This is what my post is about - this option, when unchecked, should not shift focus to the tab where the new link is being opened. Instead, it should open the tab in the background and allow me to continue reading on the original tab.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
520 solutions 4884 answers

Helpful Reply

This is weird - the value of that preference is set to true and yet .... You didn't have to change that value, did you  ? It already was set to true  ? Otherwise I would ask you if you closed and restarted Firefox after you changed the value ....

A complete stab in the dark, but would you check the value of this preference on the "about:config" page, please :

browser.tabs.loadDivertedInBackground

If that makes no difference either, then change the value back (and don't forget to close and restart Firefox after each change)

This is weird - the value of that preference is set to true and yet .... You didn't have to change that value, did you ? It already was set to true ? Otherwise I would ask you if you closed and restarted Firefox after you changed the value .... A complete stab in the dark, but would you check the value of this preference on the "about:config" page, please : '''browser.tabs.loadDivertedInBackground''' If that makes no difference either, then change the value back (and don't forget to close and restart Firefox after each change)
Was this helpful to you? 1
Quote
needsleep 0 solutions 5 answers

No I did not have to remove the check mark for "When you open a link in a new tab, switch to it immediately". When I observed the value of browser.tabs.loadInBackground, it was showing status=default, value=true.

Since I did not change anything, I did not close/restart.

When I looked at browser.tabs.loadDivertedInBackground, it showed status=default, value=false This is the initial value for me. Changing it: status=modified, value=true

After restarting firefox, it was my turn to be surprised.

Before testing the new value, I wanted to confirm it was still the same value I had changed it to after the restart. It was not! browser.tabs.loadDivertedInBackground had reverted to status=default, value=false.

I couldn't believe it, so I tested it a second time. And this time it held: status=modified, value=true. I then tested the browser and it works as intended: I can "open in new tab" and not be interrupted reading the current tab.

Not satisfied it would stay changed, however, I tested it 2 more times and it did not waver: status=modified, value=true, both times.

A big thank you for delivering me from this annoyance. And fun working with you, McCoy.

No I did not have to remove the check mark for "When you open a link in a new tab, switch to it immediately". When I observed the value of browser.tabs.loadInBackground, it was showing status=default, value=true. Since I did not change anything, I did not close/restart. When I looked at browser.tabs.loadDivertedInBackground, it showed status=default, value=false This is the initial value for me. Changing it: status=modified, value=true After restarting firefox, it was my turn to be surprised. Before testing the new value, I wanted to confirm it was still the same value I had changed it to after the restart. It was not! browser.tabs.loadDivertedInBackground had reverted to status=default, value=false. I couldn't believe it, so I tested it a second time. And this time it held: status=modified, value=true. I then tested the browser and it works as intended: I can "open in new tab" and not be interrupted reading the current tab. Not satisfied it would stay changed, however, I tested it 2 more times and it did not waver: status=modified, value=true, both times. A big thank you for delivering me from this annoyance. And fun working with you, McCoy.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
520 solutions 4884 answers

needsleep said

A big thank you for delivering me from this annoyance.
And fun working with you, McCoy.

The pleasure is all mine ......

Now, you go get some sleep  !

''needsleep [[#answer-1223199|said]]'' <blockquote> A big thank you for delivering me from this annoyance.<BR> And fun working with you, McCoy. </blockquote> The pleasure is all mine ...... Now, you go get some sleep !
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.