X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Need to stop Firefox from asking for master password on startup

Posted

I am using Firefox Developer Edition 68.0b1. Upon starting Firefox, I am prompted to enter my master password before any pages load. This is a security risk as it keeps the password vault open for the entire session, rather than specifically when it is needed. The prompt occurs no matter what page I start up to; my search engine, restored tabs from a previous session, or even just a blank homepage. I have already tried disabling all my addons. I do not use Sync. Rolling back to 67.0b9 fixes the problem, but does not allow me to carry over any of my saved data as I am forced to create a new profile before the browser will allow itself to start. I need to know what new feature has been added in the most recent version that requires the master password on startup so that I can remove it, or find another web browser that does not have it.

I am using Firefox Developer Edition 68.0b1. Upon starting Firefox, I am prompted to enter my master password before any pages load. This is a security risk as it keeps the password vault open for the entire session, rather than specifically when it is needed. The prompt occurs no matter what page I start up to; my search engine, restored tabs from a previous session, or even just a blank homepage. I have already tried disabling all my addons. I do not use Sync. Rolling back to 67.0b9 fixes the problem, but does not allow me to carry over any of my saved data as I am forced to create a new profile before the browser will allow itself to start. I need to know what new feature has been added in the most recent version that requires the master password on startup so that I can remove it, or find another web browser that does not have it.

Chosen solution

Hello alabastrine,

This may be "a souvenir" from the "disabled add-ons problem" a few weeks ago …. If your extensions are working, then you could try to remove "hotfix-update-xpi-signing-intermediate-bug" from "about:studies".

If you didn't participate in the Firefox studies, then maybe you could check to see if there is a "hotfix" related extension in 3-bar menu => Add-ons => Extensions.

If you're extensions are (no longer) disabled, then the hotfix extension can be removed. But as you mention that the same thing happens with add-ons disabled, I doubt if this applies to your situation.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

McCoy
  • Top 10 Contributor
396 solutions 3431 answers

Chosen Solution

Hello alabastrine,

This may be "a souvenir" from the "disabled add-ons problem" a few weeks ago …. If your extensions are working, then you could try to remove "hotfix-update-xpi-signing-intermediate-bug" from "about:studies".

If you didn't participate in the Firefox studies, then maybe you could check to see if there is a "hotfix" related extension in 3-bar menu => Add-ons => Extensions.

If you're extensions are (no longer) disabled, then the hotfix extension can be removed. But as you mention that the same thing happens with add-ons disabled, I doubt if this applies to your situation.

Hello alabastrine, This may be "a souvenir" from the "disabled add-ons problem" a few weeks ago …. If your extensions are working, then you could try to remove "hotfix-update-xpi-signing-intermediate-bug" from "about:studies". If you didn't participate in the Firefox studies, then maybe you could check to see if there is a "hotfix" related extension in 3-bar menu => Add-ons => Extensions. If you're extensions are (no longer) disabled, then the hotfix extension can be removed. But as you mention that the same thing happens with add-ons disabled, I doubt if this applies to your situation.
Was this helpful to you? 1
Quote

Question owner

McCoy,

This solved the problem! Thanks for the incredibly quick and effective response.

McCoy, This solved the problem! Thanks for the incredibly quick and effective response.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
396 solutions 3431 answers

alabastrine said

McCoy, This solved the problem! Thanks for the incredibly quick and effective response.

My pleasure - I'm glad everything is back to normal (well done !)

''alabastrine [[#answer-1222923|said]]'' <blockquote> McCoy, This solved the problem! Thanks for the incredibly quick and effective response. </blockquote> My pleasure - I'm glad everything is back to normal (well done !)
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.