X
Tap here to go to the mobile version of the site.

Support Forum

If you click on a link with ctrl + left mouse button a new tab is opened and Firefox automatically follows this tab, this is wrong and has changed since the

Posted

If you click on a link with ctrl + left mouse button a new tab is opened and Firefox automatically follows this tab, this is wrong and has changed since the last update. The correct behavior would be: With ctrl + left click on a link -> new tab will open, but Firefox will remain on the old tab.

If you click on a link with ctrl + left mouse button a new tab is opened and Firefox automatically follows this tab, this is wrong and has changed since the last update. The correct behavior would be: With ctrl + left click on a link -> new tab will open, but Firefox will remain on the old tab.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8441 solutions 68898 answers

Helpful Reply

Firefox has different behaviors depending on how/why a new tab was opened. Could you check these settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste inback and pause while the list is filtered

(3) Double-click the following preferences to switch the value from false to true as desired:

  • browser.tabs.loadInBackground - when you right-click > Open Link in New Tab, or Ctrl+click, or middle-click a regular link, not pre-targeted to open in a new window (default = true)
  • browser.tabs.loadDivertedInBackground - when a link was coded to launch in a new window and Firefox switched it to a new tab instead, regardless of how you clicked it (default = false) <= I think this is the one you want to change to true
  • browser.tabs.loadBookmarksInBackground - when you direct a bookmark to a new tab (e.g., using right-click > Open in New Tab, or Ctrl+click, or middle-click a bookmark) (default = false)

Can you get it working the way you like?

Firefox has different behaviors depending on how/why a new tab was opened. Could you check these settings: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''inback''' and pause while the list is filtered (3) Double-click the following preferences to switch the value from false to true as desired: * '''browser.tabs.loadInBackground''' - when you right-click > Open Link in New Tab, or Ctrl+click, or middle-click a regular link, not pre-targeted to open in a new window (default = true) * '''browser.tabs.load<u>Diverted</u>InBackground''' - when a link was coded to launch in a new window and Firefox switched it to a new tab instead, regardless of how you clicked it (default = false) '''<= I think this is the one you want to change to true''' * '''browser.tabs.load<u>Bookmarks</u>InBackground''' - when you direct a bookmark to a new tab (e.g., using right-click > Open in New Tab, or Ctrl+click, or middle-click a bookmark) (default = false) Can you get it working the way you like?
Was this helpful to you? 1
Quote

Question owner

It works, many thanks !!!

It works, many thanks !!!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.