X
Tap here to go to the mobile version of the site.

Support Forum

Right click "open in new tab", the tab opens but then immediately closes.

Posted

This does not occur on all websites, but it does happen on many websites. While I was researching in Mozilla for an answer, it did happen. If there is a link in a story, I right-click it, a drop-down appears, I select "Open in New Tab". The Tab does open. I can even see the "title" of the new tab, then, in about 1 second, the tab closes. Firefox did NOT do this on my computer until, about two weeks ago. Very frustrating. Thanks for the help.

This does not occur on all websites, but it does happen on many websites. While I was researching in Mozilla for an answer, it did happen. If there is a link in a story, I right-click it, a drop-down appears, I select "Open in New Tab". The Tab does open. I can even see the "title" of the new tab, then, in about 1 second, the tab closes. Firefox did NOT do this on my computer until, about two weeks ago. Very frustrating. Thanks for the help.

Chosen solution

Hi glen6431, that is very odd. Could you possibly have an add-on that has an overly aggressive "popup blocker"? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything popup-related, suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

You also could test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8427 solutions 68762 answers

Chosen Solution

Hi glen6431, that is very odd. Could you possibly have an add-on that has an overly aggressive "popup blocker"? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything popup-related, suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

You also could test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi glen6431, that is very odd. Could you possibly have an add-on that has an overly aggressive "popup blocker"? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything popup-related, suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement? You also could test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you? 1
Quote

Question owner

Thanks jscher2000 -- Your info about a pop-up blocker led me to where I was able to resolve the matter. Thanks again!

Thanks jscher2000 -- Your info about a pop-up blocker led me to where I was able to resolve the matter. Thanks again!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8427 solutions 68762 answers

Thanks for reporting back. If you want to "name and blame," feel free, it might help someone else.

Thanks for reporting back. If you want to "name and blame," feel free, it might help someone else.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.