X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

How to I re-enable my add-ons?

Posted

Firefox has taken it upon itself to protect me by disabling add-ons I've been using for a long time. One of them was my speed dial with all the links I visit regularly. I didn't ask for this protection, and I'm not happy with it. I tried going through the process suggested on Mozilla support, but wasn't successful.

Any suggestions on how to get my add-ons back?

Firefox has taken it upon itself to protect me by disabling add-ons I've been using for a long time. One of them was my speed dial with all the links I visit regularly. I didn't ask for this protection, and I'm not happy with it. I tried going through the process suggested on Mozilla support, but wasn't successful. Any suggestions on how to get my add-ons back?

Chosen solution

Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. For most users, studies are automatically enabled, but you can check on the Options/Preferences page as follows:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type stud and Firefox should filter to the "Firefox Data Collection and Use" section. Here, make sure you have a check in the box for "Allow Firefox to install and run studies". (First screenshot attached.) If you prefer to turn it back off after the patch comes through, that's fine.

So far, I have received two studies related to this, which you can see if you click the View Firefox studies link next to the above preference (or paste about:studies into the address bar and press Enter to load it). (Second screenshot attached.)

If you receive the patches and your extensions remain disabled, check whether they now show an Enable button.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Helpful Reply

The Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.)

I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

The Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

Question owner

So this is actually more of a glitch than an intentional change they just made?

So this is actually more of a glitch than an intentional change they just made?
jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Helpful Reply

Oh, this is definitely not intentional.

Oh, this is definitely not intentional.

Question owner

Well ok, then. I was getting quite angry. Now I feel better. Thank you.

Well ok, then. I was getting quite angry. Now I feel better. Thank you.
metalman630 0 solutions 27 answers

Have you tried this yet? Go look at the crappy new ones...every time I try to add one "DOWNLOAD FAILED, CHECK YOUR CONNECTION". So, I go to work, my FF gets broken after about 10 minutes like this one...SAME THING. I can't download new themes or extensions on TWO PC's now.

SO, I go about uninstalling, download 65.0.2. Pull the internet (if you don't, FF will almost instantly UPDATE FF before you get to the "ask me" thing) and install. Guess what. 66.0.3 has apparently ETERNALLY broken ALL MY items. Google up how to override. I find something. BAAAAAA! Wrong answer, 66.0.3 REALLY HAS BROKEN EVERYTHING and you can't go back! Sure, i saw the page ..."it's still customizable"...BUT I CAN'T CUSTOMIZE IT!!!

Sounds like someone DIDN'T BETA this new version. HIGHLY SUGGEST you put out a new version that puts us ALL BACK TO WHERE WE WERE and beta this software!!!

Have you tried this yet? Go look at the crappy new ones...every time I try to add one "DOWNLOAD FAILED, CHECK YOUR CONNECTION". So, I go to work, my FF gets broken after about 10 minutes like this one...SAME THING. I can't download new themes or extensions on TWO PC's now. SO, I go about uninstalling, download 65.0.2. Pull the internet (if you don't, FF will almost instantly UPDATE FF before you get to the "ask me" thing) and install. Guess what. 66.0.3 has apparently ETERNALLY broken ALL MY items. Google up how to override. I find something. BAAAAAA! Wrong answer, 66.0.3 REALLY HAS BROKEN EVERYTHING and you can't go back! Sure, i saw the page ..."it's still customizable"...BUT I CAN'T CUSTOMIZE IT!!! Sounds like someone DIDN'T BETA this new version. HIGHLY SUGGEST you put out a new version that puts us ALL BACK TO WHERE WE WERE and beta this software!!!
jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Hi metalman630, there are a lot of threads on this and you do not need to post in all of them. This is not a problem with a particular version of Firefox; all versions of Firefox are affected.

Hi metalman630, there are a lot of threads on this and you do not need to post in all of them. This is not a problem with a particular version of Firefox; all versions of Firefox are affected.
metalman630 0 solutions 27 answers

I have stewed about this, obviously for hours. I stopped posting before you even replied...BUT I have to post a reply. Why? Because YOUR POST caused me to use IE. It's bad enough that FF has dinged all of us, but your post pointed, I guess, made me take it personally.

Yes. Yes, I DO need to post in multiple postings. Reasons? 1) It makes ME feel better. Why? 2) To post and let someone else know they are not ALONE. Psychologically it make us BOTH feel better as well as others who READ the posts. That is a "unseen" REASON for COMMUNITY is it NOT?

I have stewed about this, obviously for hours. I stopped posting before you even replied...BUT I have to post a reply. Why? Because YOUR POST caused me to use IE. It's bad enough that FF has dinged all of us, but your post pointed, I guess, made me take it personally. Yes. Yes, I DO need to post in multiple postings. Reasons? 1) It makes ME feel better. Why? 2) To post and let someone else know they are not ALONE. Psychologically it make us BOTH feel better as well as others who READ the posts. That is a "unseen" REASON for COMMUNITY is it NOT?
jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Hi metalman630, I understand the value of sympathy posts, but you had a lot of unrelated stuff about your updates in there that could confuse people with this problem. Anyway, it's after midnight, so, goodnight.

Hi metalman630, I understand the value of sympathy posts, but you had a lot of unrelated stuff about your updates in there that could confuse people with this problem. Anyway, it's after midnight, so, goodnight.

Question owner

Thanks for your replies. I appreciate your help. It does make me feel a bit better knowing it wasn't an intentional update, and that other people are just as frustrated as I am.

I wish the general forum page was a little easier to find. When I went through FF support to try to find a solution to the problem I clicked through all the menu items narrowing down my search to add-ons, asked my question to get an article and I think 2 or 3 thread under it that didn't really match my problem.

You posting that there are a lot of threads on this issue prompted me to start looking for an actual forum, which I finally found as a small sub-menu item under contributer tools. If I'd known all those other threads existed I wouldn't have started another one. Maybe they should make the forums option it's own link at the top?

Thanks for your replies. I appreciate your help. It does make me feel a bit better knowing it wasn't an intentional update, and that other people are just as frustrated as I am. I wish the general forum page was a little easier to find. When I went through FF support to try to find a solution to the problem I clicked through all the menu items narrowing down my search to add-ons, asked my question to get an article and I think 2 or 3 thread under it that didn't really match my problem. You posting that there are a lot of threads on this issue prompted me to start looking for an actual forum, which I finally found as a small sub-menu item under contributer tools. If I'd known all those other threads existed I wouldn't have started another one. Maybe they should make the forums option it's own link at the top?
Moses
  • Moderator
459 solutions 3607 answers

@marklayne

For future reference, issues like this are very likelyy to be noticed first at reddit.com/r/firefox , the users there are very active. New people basically flooded with submissions after 10 minutes within noticing their add-ons were affected.

@marklayne For future reference, issues like this are very likelyy to be noticed first at reddit.com/r/firefox , the users there are very active. New people basically flooded with submissions after 10 minutes within noticing their add-ons were affected.
jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Chosen Solution

Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. For most users, studies are automatically enabled, but you can check on the Options/Preferences page as follows:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type stud and Firefox should filter to the "Firefox Data Collection and Use" section. Here, make sure you have a check in the box for "Allow Firefox to install and run studies". (First screenshot attached.) If you prefer to turn it back off after the patch comes through, that's fine.

So far, I have received two studies related to this, which you can see if you click the View Firefox studies link next to the above preference (or paste about:studies into the address bar and press Enter to load it). (Second screenshot attached.)

If you receive the patches and your extensions remain disabled, check whether they now show an Enable button.

Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. For most users, studies are automatically enabled, but you can check on the Options/Preferences page as follows: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''stud'' and Firefox should filter to the "Firefox Data Collection and Use" section. Here, make sure you have a check in the box for "Allow Firefox to install and run studies". (First screenshot attached.) If you prefer to turn it back off after the patch comes through, that's fine. So far, I have received two studies related to this, which you can see if you click the '''View Firefox studies''' link next to the above preference (or paste '''about:studies''' into the address bar and press Enter to load it). (Second screenshot attached.) If you receive the patches and your extensions remain disabled, check whether they now show an Enable button.

Question owner

Thank you both for the advice. I'll keep my eye out for the fix.

Thank you both for the advice. I'll keep my eye out for the fix.