X
Tap here to go to the mobile version of the site.

Support Forum

Firefox ignores my setting for NOT to check default browser.

Posted

Firefox is completely IGNORING my settings for NOT asking about default browser.

The box is UNCHECKED, and every time I open firefox, it asks if it should be made the default browser, ignoring my setting. See attached screenshot for proof of what my current options boxes look like in settings.

I have tried checking the box, closing firefox, reopening it, and unchecking the box. Firefox saves the condition of the option BUT always asks anyway every time a new window is open, regardless of the setting being on or off.

I need the default to be Chrome for work, but need to use firefox to check site compatibility. It is vital that Firefox does NOT set itself up as the default browser in my use case.

Firefox is completely IGNORING my settings for NOT asking about default browser. The box is UNCHECKED, and every time I open firefox, it asks if it should be made the default browser, ignoring my setting. See attached screenshot for proof of what my current options boxes look like in settings. I have tried checking the box, closing firefox, reopening it, and unchecking the box. Firefox saves the condition of the option BUT always asks anyway every time a new window is open, regardless of the setting being on or off. I need the default to be Chrome for work, but need to use firefox to check site compatibility. It is vital that Firefox does NOT set itself up as the default browser in my use case.

Additional System Details

Installed Plug-ins

  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.201.2 for Mozilla browsers
  • RingCentral launcher plugin - 3.5.0
  • Plugin for Wacom tablets.

Application

  • Firefox 47.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
  • Support URL: https://support.mozilla.org/1/firefox/47.0.2/WINNT/en-US/

Extensions

  • Firefox Hello 1.3.2 (loop@mozilla.org)
  • Mozilla Partner Defaults 1.0.1 (partnerdefaults@mozilla.com)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0.2 (firefox@getpocket.com)
  • Websense Helper 1.0 (websensehelper@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 530
  • adapterDescription2: NVIDIA GeForce GTX 960M
  • adapterDeviceID: 0x191b
  • adapterDeviceID2: 0x139b
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2: C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_8fb2a2c0b6aabcdc\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_8fb2a2c0b6aabcdc\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_8fb2a2c0b6aabcdc\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_8fb2a2c0b6aabcdc\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_8fb2a2c0b6aabcdc\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_8fb2a2c0b6aabcdc\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_8fb2a2c0b6aabcdc\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_8fb2a2c0b6aabcdc\nvldumd.dll
  • adapterRAM: Unknown
  • adapterRAM2: 4095
  • adapterSubsysID: 103b1025
  • adapterSubsysID2: 103b1025
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.17134.376
  • driverDate: 11-11-2016
  • driverDate2: 4-17-2019
  • driverVersion: 21.20.16.4550
  • driverVersion2: 26.21.14.3039
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 530 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Question owner

Uploading image properly this time, last time it didn't stick.

Uploading image properly this time, last time it didn't stick.
FredMcD
  • Top 10 Contributor
4269 solutions 59882 answers

You are running a very, Very old version of Firefox. Is this what you want?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

You are running a very, Very old version of Firefox. Is this what you want? https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, '''like''' Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.