X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 63.0 for MAC recommends Intel x86 processor, but mine is Intel Core i7 so will that work on my computer?

Posted

My MacBook Pro (mid 2012) is version 10.11.6, and my Firefox version is 58.0.1. I'm told that my Firefox is "critically out of date" and needs to be updated. When I checked the requirements, it recommends Intel x86 processor, but my MAC has Intel Core i7 processor. Will the Firefox 63.0 version run on my computer, should I keep my 58.0.1 version, or is there something in between that I should try to find and install? Thanks

My MacBook Pro (mid 2012) is version 10.11.6, and my Firefox version is 58.0.1. I'm told that my Firefox is "critically out of date" and needs to be updated. When I checked the requirements, it recommends Intel x86 processor, but my MAC has Intel Core i7 processor. Will the Firefox 63.0 version run on my computer, should I keep my 58.0.1 version, or is there something in between that I should try to find and install? Thanks

Chosen solution

Hi BannerGirl, Firefox should work on all Intel-based Macs running MacOS X 10.9 and higher. They all contain the classic "x86" instruction set.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Chosen Solution

Hi BannerGirl, Firefox should work on all Intel-based Macs running MacOS X 10.9 and higher. They all contain the classic "x86" instruction set.

Hi BannerGirl, Firefox should work on all Intel-based Macs running MacOS X 10.9 and higher. They all contain the classic "x86" instruction set.
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Helpful Reply

Also, the current version is up to Firefox 66 now but it's possible you will get updated in two stages if 63 already downloaded and is waiting in the wings.

Also, the current version is up to Firefox 66 now but it's possible you will get updated in two stages if 63 already downloaded and is waiting in the wings.
Was this helpful to you? 1
Quote
James
  • Moderator
1593 solutions 11223 answers

The system requirements pages for the old Fx 58.0.1 and the current Fx 66.0.3 is the same apart from mention of Mac OS 10.14.

https://www.mozilla.org/firefox/58.0.1/system-requirements/ https://www.mozilla.org/firefox/66.0.3/system-requirements/

The system requirements pages for the old Fx 58.0.1 and the current Fx 66.0.3 is the same apart from mention of Mac OS 10.14. https://www.mozilla.org/firefox/58.0.1/system-requirements/ https://www.mozilla.org/firefox/66.0.3/system-requirements/
Was this helpful to you? 1
Quote

Question owner

Clearly I don't understand how computers work. Thanks for the explanations.

Clearly I don't understand how computers work. Thanks for the explanations.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.