X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Mozilla says "Your system doesn't meet the requirements to run Firefox" but when I check the requirements, my system meets all. What gives?

Posted

Requirements: Mac OS X 10.6 - check - 10.6.8 Macintosh computer with an Intel x86 processor - check - 2.66 GHz Intel Core 2 Duo 512 MB of RAM - check - 2 Gb 200 MB hard drive space - check - 130.81Gb free

Is there some kind of hidden requirement I don't know about?

Chosen solution

ok, when i look closer it seems like your useragent is overwritten by some sort of toolbar or adware. please refer to this article in order to reset the user-agent settings in firefox, then it should work: Websites say that Firefox is outdated or incompatible even though it's the latest version

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Facebook Video Calling by Skype
  • Shockwave Flash 10.3 r183
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.1.1.94
  • iPhoto6
  • Logitech Harmony Browser Plug-In 1.0.0.1
  • AVX Multimedia Engine
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Simplifies the uploading of photo files.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 FBSMTWB

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

hello jashton34, did you write your question from the system affected? because its useragent (the information the browser sends to websites to identify its version and system where it's running) says it's on Mac OS X 10.5...

Question owner

Thanks madperson, Yes, I did write my question from the same system, but I'm running 10.6, I promise. The system came with 10.5 installed but I upgraded to 10.6 a while ago. Here's a copy and past from my system profiler, and I've attached a screen shot of my About This Mac.

System Software Overview:

 System Version:	Mac OS X 10.6.8 (10K549)
 Kernel Version:	Darwin 10.8.0
 Boot Volume:	Macintosh HD
 Boot Mode:	Normal
 Computer Name:	Jeff Ashton's Computer (2)
 User Name:	Jeff Ashton (jeffashton)
 Secure Virtual Memory:	Not Enabled
 64-bit Kernel and Extensions:	No
 Time since boot:	15 days 14 minutes

The useragent is clearly a liar, do you know if there's any way to fix that?

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

Chosen Solution

ok, when i look closer it seems like your useragent is overwritten by some sort of toolbar or adware. please refer to this article in order to reset the user-agent settings in firefox, then it should work: Websites say that Firefox is outdated or incompatible even though it's the latest version

Modified by philipp

Question owner

That fixed it. You're a Rockstar, madperson, thanks!

viturbo 0 solutions 7 answers

Hello! I have the same problem, I tryed to follow the steps to fix it myself but I couldnt reset 3 elements that where showew in the search, it was not possible, I would really apreciate your help!

Thank you

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

hello viturbo, without more information its difficult to know what might be going wrong...

when the preferences concerning the user-agent in about:config were not shown in bold that means they were already set to their default & can't be reset. please go to help > troubleshooting information, copy the whole contents of this page & paste them here into a forum reply, this might give us some further clues. thank you

viturbo 0 solutions 7 answers

Extensiones





             Nombre
           
           	
             Versión
           
           	
             Activada
           


             ID
           
         


       Cuevana Stream	2.0.2	true	{a3a5c777-f583-4fef-9380-ab4add1bc2a8}

Chat Undetected 0.86.37 true crossriderapp14917@crossrider.com ProxTube - Unblock YouTube 1.4.3 false ich@maltegoetz.de





       Preferencias modificadas
     




           Nombre



           Valor
         
       


       accessibility.typeaheadfind.flashBar	0

browser.places.importBookmarksHTML false browser.places.smartBookmarksVersion 4 browser.startup.homepage www.google.com browser.startup.homepage_override.buildID 20121024073032 browser.startup.homepage_override.mstone rv:1.9.2.22 browser.tabs.loadInBackground false browser.tabs.warnOnClose false extensions.lastAppVersion 3.6.22 network.cookie.prefsMigrated true places.database.lastMaintenance 1358110179 places.history.expiration.transient_current_max_pages 26844 places.history.expiration.transient_optimal_database_size 42949672 places.last_vacuum 1358260053 print.macosx.pagesetup-2 PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO… print.print_bgcolor false print.print_bgimages false print.print_command print.print_downloadfonts false print.print_evenpages true print.print_in_color true print.print_margin_bottom 0.5 print.print_margin_left 0.5 print.print_margin_right 0.5 print.print_margin_top 0.5 print.print_oddpages true print.print_orientation 0 print.print_pagedelay 500 print.print_paper_data 0 print.print_paper_height 11.00 print.print_paper_size_type 1 print.print_paper_size_unit 0 print.print_paper_width 8.50 print.print_printer print.print_reversed false print.print_scaling 1.00 print.print_shrink_to_fit true print.print_to_file false print.print_unwriteable_margin_bottom 57 print.print_unwriteable_margin_left 25 print.print_unwriteable_margin_right 25 print.print_unwriteable_margin_top 25 privacy.cpd.downloads false privacy.cpd.formdata false privacy.cpd.history false privacy.cpd.sessions false privacy.sanitize.migrateFx3Prefs true privacy.sanitize.timeSpan 0 security.warn_viewing_mixed false

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

& what kind of user-agent information is shown on that page? for jashton34, the question owner, it looked like this for example: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 FBSMTWB

viturbo 0 solutions 7 answers

Hello!, thanks for your help, I dont know if its this what you mean.. I had to click a link because in the page was any info like that..

Compiler Version Compiler flags gcc-4.0 -arch ppc gcc version 4.0.1 (Apple Inc. build 5484) -I/usr/X11/include -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -Wno-long-long -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fpascal-strings -fno-common -pthread -DNO_X11 -DNDEBUG -DTRIMMED -O3 g++-4.0 -arch ppc gcc version 4.0.1 (Apple Inc. build 5484) -I/usr/X11/include -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -pthread -DNO_X11 -DNDEBUG -DTRIMMED -O3

viturbo 0 solutions 7 answers

Also trying to install google chrome is not possible because that my system doesnt match...but before I could do it... if this helps too

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

what OS are you on? mozilla & google don't support systems below os x 10.6 or on the powerpc architecture in their modern browser products anylonger...

viturbo 0 solutions 7 answers

Oh... I have 10.5.8 what can I do then¿?

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

is your device intel based? in this case you could upgrade to 10.6 and the browsers should still work - for more information please see Firefox no longer works with Mac OS X 10.5, http://store.apple.com/us/product/MC573Z/A/mac-os-x-106-snow-leopard or contact apple's support.

viturbo 0 solutions 7 answers

Yes, its intel based. but how can I upgrade to 10.6?

viturbo 0 solutions 7 answers

Yes, its intel based. but how can I upgrade to 10.6?

James
  • Top 25 Contributor
  • Moderator
437 solutions 3156 answers

You can call 1-800-MY-APPLE and order a dvd for $20 if you are in USA unless you can get one in Apple stores by chance.


Mac OS X v10.6 Snow Leopard - Technical Specifications