X
Tap here to go to the mobile version of the site.

Support Forum

Asian characters showing up on Google searches.

Posted

Enclosing a screen shot. When I do a search Foxfire goes to Google and the results often show up with lots of Chinese or Japanese characters. This is annoying - how do I get rid of this?

Enclosing a screen shot. When I do a search Foxfire goes to Google and the results often show up with lots of Chinese or Japanese characters. This is annoying - how do I get rid of this?

Chosen solution

Thanks for reporting back, and sorry I didn't think to mention that earlier. I first switched from English to Japanese, so of course I already knew what the buttons said.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • Firefox 66.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0
  • Support URL: https://support.mozilla.org/1/firefox/66.0.2/Darwin/en-US/

Extensions

  • HTTPS Everywhere 2019.1.31 (https-everywhere-eff@eff.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x67ef
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 1024, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 1024, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • lowEndMachine: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • targetFrameRate: 60
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_texture_compression_rgtc EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: ATI Technologies Inc. -- AMD Radeon Pro 555 OpenGL Engine
  • webgl1Version: 4.1 ATI-2.8.38
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_compression_rgtc EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: ATI Technologies Inc. -- AMD Radeon Pro 555 OpenGL Engine
  • webgl2Version: 4.1 ATI-2.8.38
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

Unfortunately, your screenshot didn't upload successfully. Could you attach it to a reply? https://support.mozilla.org/questions/1255823#question-reply

Unfortunately, your screenshot didn't upload successfully. Could you attach it to a reply? https://support.mozilla.org/questions/1255823#question-reply
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17350 solutions 156825 answers

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. *https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
Was this helpful to you?
Quote

Question owner

Ok, will try again. It's a PNG file from my Mac desktop. When I click on the desktop icon it opens in Preview...if that helps. Also, the Asian characters don't seem to appear in all websites , just some.

Ok, will try again. It's a PNG file from my Mac desktop. When I click on the desktop icon it opens in Preview...if that helps. Also, the Asian characters don't seem to appear in all websites , just some.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

Actually, I think that's Japanese.

Could you check your Langage preference for Google search results here:

https://www.google.com/preferences#languages

Actually, I think that's Japanese. Could you check your Langage preference for Google search results here: https://www.google.com/preferences#languages
Was this helpful to you?
Quote

Question owner

Thanks for responding again. I am uploading a second prn file showing the screen I get when I click on the link you suggested. I can change the radio button to English, but every time I close the window, go back to Foxfire and do another Google search, then then check preferences again the radio button has reverted back to the Japanese. Further thoughts?

Thanks for responding again. I am uploading a second prn file showing the screen I get when I click on the link you suggested. I can change the radio button to English, but every time I close the window, go back to Foxfire and do another Google search, then then check preferences again the radio button has reverted back to the Japanese. Further thoughts?
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

I assume you clicked the blue button that is equivalent to "Save". That should set a cookie that is applied on every subsequent Google visit until the cookie is cleared.

I suppose it could be overridden by a link that tells Google you want results in Japanese, such as

https://www.google.com/search?q=firefox&hl=ja

If you start a fresh search from Firefox's address bar or the new tab page search box, does your results page URL include that (amongst many other parameters)?

I assume you clicked the blue button that is equivalent to "Save". That should set a cookie that is applied on every subsequent Google visit until the cookie is cleared. I suppose it could be overridden by a link that tells Google you want results in Japanese, such as [https://www.google.com/search?q=firefox&hl=ja https://www.google.com/search?q=firefox&'''hl=ja'''] If you start a fresh search from Firefox's address bar or the new tab page search box, does your results page URL include that (amongst many other parameters)?
Was this helpful to you?
Quote

Question owner

PROBLEM SOLVED - THANK YOU SO MUCH! I didn't realize the blue button was a "Save" button because it was in Japanese too. Tried the same search I've been using as a test and...no Japanese anywhere! Problem probably arose from a Japanese visitor who I think used this computer a few times.

THANKS AGAIN FOR YOUR HELP!
PROBLEM SOLVED - THANK YOU SO MUCH! I didn't realize the blue button was a "Save" button because it was in Japanese too. Tried the same search I've been using as a test and...no Japanese anywhere! Problem probably arose from a Japanese visitor who I think used this computer a few times. THANKS AGAIN FOR YOUR HELP!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

Chosen Solution

Thanks for reporting back, and sorry I didn't think to mention that earlier. I first switched from English to Japanese, so of course I already knew what the buttons said.

Thanks for reporting back, and sorry I didn't think to mention that earlier. I first switched from English to Japanese, so of course I already knew what the buttons said.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.