X
Tap here to go to the mobile version of the site.

Support Forum

Restore previous session though unchecked always tries to restore previous session on startup. It's annoying!

Posted

Restore previous session though unchecked always tries to restore previous session on startup. It's annoying! That's it in a nutshell. Though the box is unchecked by default, the application still attempts to do a restore which delays my startup of Firefox. How do I get around this? Is there a patch?

Restore previous session though unchecked always tries to restore previous session on startup. It's annoying! That's it in a nutshell. Though the box is unchecked by default, the application still attempts to do a restore which delays my startup of Firefox. How do I get around this? Is there a patch?

Chosen solution

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:preferences page.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Possibly Firefox is not exiting completely (you may need to allow more time) before Windows shuts down. Firefox integrates with a new feature of Windows 10 to restore itself in that situation. It can be turned off, although in that case, Firefox might do a crash recovery on startup. See: Firefox starts automatically when I restart Windows.

Possibly Firefox is not exiting completely (you may need to allow more time) before Windows shuts down. Firefox integrates with a new feature of Windows 10 to restore itself in that situation. It can be turned off, although in that case, Firefox might do a crash recovery on startup. See: [[Firefox starts automatically when I restart Windows]].
Was this helpful to you? 0
Quote

Question owner

Thanks for the comeback but that's not the problem. I've ended my Firefox session, usually, an hour before exiting the OS.

Thanks for the comeback but that's not the problem. I've ended my Firefox session, usually, an hour before exiting the OS.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Could you check for a user.js file in your profile folder? This file could contain a "just restore the session this once" command, but since Firefox doesn't delete the file after running it, that will happen at every session. There is a section of this article on how to track down a user.js file: How to fix preferences that won't save.

Also, there's a preference that can help distinguish between a regular restore and a crash recovery.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionstore.max_resumed_crashes preference to display a small dialog and change the value from 1 to 0 (that's a zero) then click OK

After that, when Firefox starts up and believes there was a crash, instead of trying 1 automatic recovery, it will show a screen asking if you want to recover your earlier session.

Could you check for a '''user.js''' file in your profile folder? This file could contain a "just restore the session this once" command, but since Firefox doesn't delete the file after running it, that will happen at every session. There is a section of this article on how to track down a user.js file: [[How to fix preferences that won't save]]. Also, there's a preference that can help distinguish between a regular restore and a crash recovery. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''sess''' and pause while the list is filtered (3) Double-click the '''browser.sessionstore.max_resumed_crashes''' preference to display a small dialog and change the value from 1 to 0 (that's a zero) then click OK After that, when Firefox starts up and believes there was a crash, instead of trying 1 automatic recovery, it will show a screen asking if you want to recover your earlier session.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157402 answers

Chosen Solution

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:preferences page.

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar. *"3-bar" menu button -> Exit (Power button) *Windows: File -> Exit *Mac: Firefox -> Quit Firefox *Linux: File -> Quit You can check if you have a <b>user.js</b> file in the Firefox profile folder that sets the <b>browser.sessionstore.resume_session_once</b> pref to true. *http://kb.mozillazine.org/browser.sessionstore.resume_session_once You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:preferences</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Modified by cor-el

Was this helpful to you? 1
Quote

Question owner

Thanks everyone. I no longer have a 'restore problem. Thank you all.

Thanks everyone. I no longer have a 'restore problem. Thank you all.
Was this helpful to you?
Quote
tess_wood 0 solutions 1 answers

I have this problem too, and going file>exit is not an acceptable workaround for me. Is there another way to force Firefox to follow the checked boxes?

I have this problem too, and going file>exit is not an acceptable workaround for me. Is there another way to force Firefox to follow the checked boxes?
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hi tess_wood, are you saying that your Firefox is performing a crash recovery and you do not want it to?

What do you want Firefox to do:

(A) When a crash is detected, show a list of tabs Firefox could restore but let you bypass that and start a new session

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionstore.max_resumed_crashes preference to display a small dialog and change the value from 1 to 0 (that's a zero) then click OK

(B) When a crash is detected, ignore it and always start a new session

You could try the following, I haven't tested this myself so let me know if it works:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionstore.resume_from_crash preference to switch the value from true to false

Hi tess_wood, are you saying that your Firefox is performing a crash recovery and you do not want it to? What do you want Firefox to do: '''(A) When a crash is detected, show a list of tabs Firefox could restore but let you bypass that and start a new session''' (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''sess''' and pause while the list is filtered (3) Double-click the '''browser.sessionstore.max_resumed_crashes''' preference to display a small dialog and change the value from 1 to 0 (that's a zero) then click OK '''(B) When a crash is detected, ignore it and always start a new session''' You could try the following, I haven't tested this myself so let me know if it works: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''sess''' and pause while the list is filtered (3) Double-click the '''browser.sessionstore.resume_from_crash''' preference to switch the value from true to false

Modified by jscher2000

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157402 answers

Hi tess_wood

Quote: file>exit is not an acceptable workaround for me

Does this workaround at least work to prevent getting the previous sesion?

How are you closing Firefox normally? If you force Firefox to close then you will always get the crash recovery window or Firefox reopens the previous session.


Did you check that you do not have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true?

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Hi tess_wood Quote: ''file>exit is not an acceptable workaround for me'' Does this workaround at least work to prevent getting the previous sesion? How are you closing Firefox normally? If you force Firefox to close then you will always get the crash recovery window or Firefox reopens the previous session. ---- Did you check that you do not have a <b>user.js</b> file in the Firefox profile folder that sets the <b>browser.sessionstore.resume_session_once</b> pref to true? *http://kb.mozillazine.org/browser.sessionstore.resume_session_once You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.