X
Tap here to go to the mobile version of the site.

Support Forum

How do i fix incorrect characters in Firefox Tab, Search, Options, etc?

Posted

Firefox shows weird behaviour when entering/displaying specific characters (e.g. "9" or ":") in search bar, tab bar, about:support, etc. The characters are displayed correctly on websites. I have already tried Safe Mode and Default settings.

OS: Xubuntu 18.04.2 LTS

Edit: sorry, thought i already attached a screenshot It appears in the Firefox Interface , e.g if i enter "9", the output is "--". The character ":" is not shown. Everything else seems to be fine.

Firefox shows weird behaviour when entering/displaying specific characters (e.g. "9" or ":") in search bar, tab bar, about:support, etc. The characters are displayed correctly on websites. I have already tried Safe Mode and Default settings. OS: Xubuntu 18.04.2 LTS Edit: sorry, thought i already attached a screenshot It appears in the Firefox Interface , e.g if i enter "9", the output is "--". The character ":" is not shown. Everything else seems to be fine.
Attached screenshots

Modified by lionbyte

Chosen solution

I would assume that a '9' is not two dashes, but merely a longer 2em dash (⸺).

This sounds like a weird font issue where a font is used that doesn't include these glyphs or the font is corrupted. Maybe check the Linux system settings and try a different default font.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [ ] "Allow pages to choose their own fonts, instead of my selections above"
Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

None

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

WestEnd
  • Top 25 Contributor
60 solutions 5377 answers

Need screenshot of the error and what that is happening at?

Need screenshot of the error and what that is happening at?
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157436 answers

Chosen Solution

I would assume that a '9' is not two dashes, but merely a longer 2em dash (⸺).

This sounds like a weird font issue where a font is used that doesn't include these glyphs or the font is corrupted. Maybe check the Linux system settings and try a different default font.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [ ] "Allow pages to choose their own fonts, instead of my selections above"
I would assume that a '9' is not two dashes, but merely a longer 2em dash (⸺). *https://en.wikipedia.org/wiki/Dash This sounds like a weird font issue where a font is used that doesn't include these glyphs or the font is corrupted. Maybe check the Linux system settings and try a different default font. You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 You can try different default fonts and temporarily disable website fonts to test the selected default font. *Options/Preferences -> General: Fonts & Colors -> Advanced<br>[ ] "Allow pages to choose their own fonts, instead of my selections above"
Was this helpful to you? 1
Quote

Question owner

cor-el said

This sounds like a weird font issue where a font is used that doesn't include these glyphs or the font is corrupted. Maybe check the Linux system settings and try a different default font.

Thank you very much. This solved my issue.

''cor-el [[#answer-1211905|said]]'' <blockquote> This sounds like a weird font issue where a font is used that doesn't include these glyphs or the font is corrupted. Maybe check the Linux system settings and try a different default font. </blockquote> Thank you very much. This solved my issue.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157436 answers

Can you tell us what font caused this as this can help others?

Can you tell us what font caused this as this can help others?
Was this helpful to you?
Quote
dee 0 solutions 5 answers

I'm having this problem too: 9 becomes --, and : doesn't work at all. But only on certain websites (archiveofourown.org) with certain fonts they use. It randomly started happening just the other day and I haven't changed any settings or done any updates. It also happens on Chrome, but no other browsers.

I did what you said @cor-el and I couldn't see any corrupt fonts. But when I turn off "Allow websites to use their own fonts" option, it fixes the problem. Except I don't want to have that off permanently.

What is happening? And more importantly, how do I fix it?

Please.

I'm having this problem too: 9 becomes --, and : doesn't work at all. But only on certain websites (archiveofourown.org) with certain fonts they use. It randomly started happening just the other day and I haven't changed any settings or done any updates. It also happens on Chrome, but no other browsers. I did what you said @cor-el and I couldn't see any corrupt fonts. But when I turn off "Allow websites to use their own fonts" option, it fixes the problem. Except I don't want to have that off permanently. What is happening? And more importantly, how do I fix it? Please.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157436 answers

Helpful Reply

I see this font list if I check the Inspector: font:100%/1.125 'Lucida Grande','Lucida Sans Unicode','GNU Unifont',Verdana,Helvetica,sans-serif;

What font is Firefox actually using in your case if you check this on the Font tab?

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

I see this font list if I check the Inspector: font:100%/1.125 'Lucida Grande','Lucida Sans Unicode','GNU Unifont',Verdana,Helvetica,sans-serif; What font is Firefox actually using in your case if you check this on the Font tab? You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.
Was this helpful to you? 1
Quote
dee 0 solutions 5 answers

It's saying Lucida Grande in the Fonts tab.

It's saying Lucida Grande in the Fonts tab.
Was this helpful to you?
Quote
dee 0 solutions 5 answers

Anyway, I just uninstalled that font and everything went back to normal. Which is a shame since I didn't want to lose it. Oh well. A small price to pay. I still have two other Lucida fonts so that's okay.

Anyway, I just uninstalled that font and everything went back to normal. Which is a shame since I didn't want to lose it. Oh well. A small price to pay. I still have two other Lucida fonts so that's okay.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.