Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Text on random websites replaced with "đ" characters

  • 2 replies
  • 1 has this problem
  • 72 views
  • Last reply by Martin23230

more options

This is weird - completely random websites are being filled with Vietnamese Unicode "đ" characters. It's only an odd few sites: I first noticed it on https://arxiv.org/ (see image 1 below or https://i.imgur.com/UYnVYOO.png). I couldn't see it again so I assumed it was a problem with ArXiv, no other website seemed to be affected. Wikipedia, Google, news sites - all seemed to be fine.

Today though I randomly came across two more: this one http://www.ferrolic.com/inquiries/ (see image 2 https://i.imgur.com/aphP4qL.png for what it looks like to me) and then any forum post made with phpBB (e.g. https://reactos.org/forum/viewtopic.php?f=2&t=18113 looks like image 3 or https://i.imgur.com/nP0PPXp.png).

Any help or ideas? It's so completely random, I haven't come across any other sites - if anyone can find the link between them that would probably help. It's also notably only certain text boxes as shown in the forum link.

Edit: here's another one, which randomly I discovered while serching for help with this post: https://forum.joomla.org/viewtopic.php?t=302052&start=30 (image 4)

This is weird - completely random websites are being filled with Vietnamese Unicode "đ" characters. It's only an odd few sites: I first noticed it on https://arxiv.org/ (see image 1 below or https://i.imgur.com/UYnVYOO.png). I couldn't see it again so I assumed it was a problem with ArXiv, no other website seemed to be affected. Wikipedia, Google, news sites - all seemed to be fine. Today though I randomly came across two more: this one http://www.ferrolic.com/inquiries/ (see image 2 https://i.imgur.com/aphP4qL.png for what it looks like to me) and then any forum post made with phpBB (e.g. https://reactos.org/forum/viewtopic.php?f=2&t=18113 looks like image 3 or https://i.imgur.com/nP0PPXp.png). Any help or ideas? It's so completely random, I haven't come across any other sites - if anyone can find the link between them that would probably help. It's also notably only certain text boxes as shown in the forum link. Edit: here's another one, which randomly I discovered while serching for help with this post: https://forum.joomla.org/viewtopic.php?t=302052&start=30 (image 4)
Attached screenshots

Modified by Martin23230

Chosen solution

Oh yes the websites are fine, it's an issue with my Firefox. Language is set to English (United Kingdom) but I tried a few others and it's always the same issue. Even setting the language to Vietnamese didn't change anything.

One other thing I should mention, going into Reader view does return the correct text. So maybe it's a specific font issue?

EDIT: Ok, so deselecting the "Allow pages to choose their own fonts, instead of your selections above" option in Options fixes it. It must be something to do with the fonts on my system then.

EDIT 2: Yes, it's the Lucida Grande font for some reason (https://i.imgur.com/Np3Fn14.png). It seems fine if I use it in other applications though.

EDIT 3: OK, reinstalling the system Lucida Grande font and restarting Firefox seems to have fixed it. Weird given that the pages displayed fine in other browsers on the same system, but at least it's working now.

Read this answer in context 👍 0

All Replies (2)

more options

Clicking on the link comes up without problem on my side? Do you have some language setup changed?

more options

Chosen Solution

Oh yes the websites are fine, it's an issue with my Firefox. Language is set to English (United Kingdom) but I tried a few others and it's always the same issue. Even setting the language to Vietnamese didn't change anything.

One other thing I should mention, going into Reader view does return the correct text. So maybe it's a specific font issue?

EDIT: Ok, so deselecting the "Allow pages to choose their own fonts, instead of your selections above" option in Options fixes it. It must be something to do with the fonts on my system then.

EDIT 2: Yes, it's the Lucida Grande font for some reason (https://i.imgur.com/Np3Fn14.png). It seems fine if I use it in other applications though.

EDIT 3: OK, reinstalling the system Lucida Grande font and restarting Firefox seems to have fixed it. Weird given that the pages displayed fine in other browsers on the same system, but at least it's working now.

Modified by Martin23230