X
Tap here to go to the mobile version of the site.

Support Forum

How do I get around "Warning: Potential Security Risk Ahead" errors when I KNOW the website is safe?

Posted

How do I get around the error message, "Warning: Potential Security Risk Ahead" when I know the website is safe? I need to access it for school. The advanced option is not allowing me to proceed. Please help!

How do I get around the error message, "Warning: Potential Security Risk Ahead" when I know the website is safe? I need to access it for school. The advanced option is not allowing me to proceed. Please help!
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17278 solutions 156180 answers

This warning usually means that there is something wrong with the certificate?

Does the error page give any detail about what is wrong?

You may have to add or remove a www. prefix in case of domain issues. If there is a redirect then maybe try the http:// protocol to see if that brings you to the correct page.

This warning usually means that there is something wrong with the certificate? Does the error page give any detail about what is wrong? You may have to add or remove a www. prefix in case of domain issues. If there is a redirect then maybe try the http:// protocol to see if that brings you to the correct page.
Was this helpful to you? 0
Quote

Question owner

I'm just following the url when I google the name of the website. I tried removing the "www" but it didn't make any difference. I've been to the website before, and there's nothing wrong with it. It's just an artist's website. It says something about a bad certificate, but I don't really understand what I can do about it.

I'm just following the url when I google the name of the website. I tried removing the "www" but it didn't make any difference. I've been to the website before, and there's nothing wrong with it. It's just an artist's website. It says something about a bad certificate, but I don't really understand what I can do about it.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17278 solutions 156180 answers

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?
Was this helpful to you? 0
Quote

Question owner

This is the link I'm trying to access: http://www.shawncossart.com/

This is the link I'm trying to access: http://www.shawncossart.com/
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8516 solutions 69591 answers

You shouldn't get that error with an HTTP address, only with an HTTPS address.

Do you use the HTTPS Everywhere extension, or a similar add-on that tries to upgrade HTTP addresses to HTTPS addresses?

You shouldn't get that error with an HTTP address, only with an HTTPS address. Do you use the HTTPS Everywhere extension, or a similar add-on that tries to upgrade HTTP addresses to HTTPS addresses?
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17278 solutions 156180 answers

Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for www.shawncossart.com. The certificate is only valid for the following names: shortener.secureserver.net, www.shortener.secureserver.net

So as posted above you shouldn't access this website via a secure HTTPS connection.

Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for www.shawncossart.com. The certificate is only valid for the following names: shortener.secureserver.net, www.shortener.secureserver.net So as posted above you shouldn't access this website via a secure HTTPS connection.
Was this helpful to you? 0
Quote
Pj
  • Top 25 Contributor
42 solutions 868 answers

I got there with HTTP, but with HTTPS, I got:


~Pj

I got there with HTTP, but with HTTPS, I got: ~Pj
Was this helpful to you?
Quote

Question owner

I have no idea what you're talking about. All I did was click on the link. I've been there before, and it's fine. I can't find a way around it now.

I have no idea what you're talking about. All I did was click on the link. I've been there before, and it's fine. I can't find a way around it now.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8516 solutions 69591 answers

Hi palettemuse, you posted a link that starts with http://

With http:// Firefox would not try to make a secure connection.

When you get the error, has the address changed to start with https:// (note the S in there)?

If so, the question would be why is that happening? One possibility is an extension (add-on) like HTTPS Everywhere.

Hi palettemuse, you posted a link that starts with http:// With http:// Firefox would not try to make a secure connection. When you get the error, has the address changed to start with https:// (note the S in there)? If so, the question would be why is that happening? One possibility is an extension (add-on) like HTTPS Everywhere.
Was this helpful to you?
Quote
Pj
  • Top 25 Contributor
42 solutions 868 answers

palettemuse said

All I did was click on the link. I've been there before, and it's fine.

This is the non-Secure site:

http(No 's')://www.shawncossart.com

This is the 'bogus Secure' site:

https://www.shawncossart.com


Go to Main Menu > Add-ons > Extensions.

Do you have HTTPS Everywhere or some similar Extension that's trying force sites from HTTP to HTTPS?



~Pj

''palettemuse [[#answer-1210648|said]]'' <blockquote> All I did was click on the link. I've been there before, and it's fine. </blockquote> This is the non-Secure site: [http://www.shawncossart.com http(No 's')://www.shawncossart.com] This is the 'bogus Secure' site: [https://www.shawncossart.com http'''<u>s</u>'''://www.shawncossart.com] Go to '''Main Menu > Add-ons > Extensions'''. Do you have '''HTTPS Everywhere''' or some similar Extension that's trying force sites from HTTP to HTTPS? ~Pj

Modified by Pj

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17278 solutions 156180 answers

This can also be a problem with the SiteSecurityServiceState.txt file in the profile folder.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

This can also be a problem with the SiteSecurityServiceState.txt file in the profile folder. You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Was this helpful to you?
Quote

Question owner

There's no http OR https listed in the url at all. There's no way to remove the s because it's not there.

There's no http OR https listed in the url at all. There's no way to remove the s because it's not there.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8516 solutions 69591 answers

Firefox hides http:// but shouldn't hide https://

I just realized the page is a frame. The framed page is at:

http://shawn-coss.squarespace.com/

Can you load that one directly?

Firefox hides http:// but shouldn't hide https:// I just realized the page is a frame. The framed page is at: http://shawn-coss.squarespace.com/ Can you load that one directly?
Was this helpful to you?
Quote

Question owner

Yes, I can load that one. How did you know to do that? That url didn't come up in any of my searches.

At this point, the assignment is over, and I had to use internet explorer to access it. It's ridiculous firefox is censoring these websites that are perfectly accessible through other browsers.

Yes, I can load that one. How did you know to do that? That url didn't come up in any of my searches. At this point, the assignment is over, and I had to use internet explorer to access it. It's ridiculous firefox is censoring these websites that are perfectly accessible through other browsers.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8516 solutions 69591 answers

palettemuse said

Yes, I can load that one. How did you know to do that? That url didn't come up in any of my searches.

The error message referred to a shortener, so I assumed there was a redirect. Obviously the main address doesn't redirect, so I checked for a frame. Right-click the page, find "This Frame" then click one of the top two options

It's ridiculous firefox is censoring these websites that are perfectly accessible through other browsers.

Everyone else who posted in this thread could access the page in Firefox with no problem, so there seems to be some unique setting or add-on affecting your installation of Firefox.

If you have time to investigate further now, what extensions do you have? You can copy/paste a list from the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down past "Application Basics" and "Firefox Features" to "Extensions". Then you can select and copy the table that follows (not the entire page, please, that's too much information) using either Ctrl+c or right-click > Copy and then paste it into a reply. It will be messy, but we're used it.

''palettemuse [[#answer-1210929|said]]'' <blockquote> Yes, I can load that one. How did you know to do that? That url didn't come up in any of my searches.</blockquote> The error message referred to a shortener, so I assumed there was a redirect. Obviously the main address doesn't redirect, so I checked for a frame. Right-click the page, find "This Frame" then click one of the top two options <blockquote>It's ridiculous firefox is censoring these websites that are perfectly accessible through other browsers. </blockquote> Everyone else who posted in this thread could access the page in Firefox with no problem, so there seems to be some unique setting or add-on affecting your installation of Firefox. If you have time to investigate further now, what extensions do you have? You can copy/paste a list from the Troubleshooting Information page. Either: * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter Scroll down past "Application Basics" and "Firefox Features" to "Extensions". Then you can select and copy the table that follows (not the entire page, please, that's too much information) using either Ctrl+c or right-click > Copy and then paste it into a reply. It will be messy, but we're used it.
Was this helpful to you?
Quote

Question owner

I don't have any extensions. It started happening the last time firefox updated, so I assume it's something with the latest update. I don't know how the average person is supposed to know to look for a frame.

I don't have any extensions. It started happening the last time firefox updated, so I assume it's something with the latest update. I don't know how the average person is supposed to know to look for a frame.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8516 solutions 69591 answers

palettemuse said

I don't have any extensions. It started happening the last time firefox updated, so I assume it's something with the latest update. I don't know how the average person is supposed to know to look for a frame.

You shouldn't need to look for a frame, because the frame doesn't use a secure address. The mystery is why your Firefox tried to use HTTPS in this scenario.

If it happens on another site, let's work on it again. In the meantime, you could try cor-el's suggestion to remove the SiteSecurityServiceState.txt file and see whether that helps going forward. https://support.mozilla.org/questions/1254924#answer-1210685

''palettemuse [[#answer-1210952|said]]'' <blockquote> I don't have any extensions. It started happening the last time firefox updated, so I assume it's something with the latest update. I don't know how the average person is supposed to know to look for a frame. </blockquote> You shouldn't need to look for a frame, because the frame doesn't use a secure address. The mystery is why your Firefox tried to use HTTPS in this scenario. If it happens on another site, let's work on it again. In the meantime, you could try cor-el's suggestion to remove the SiteSecurityServiceState.txt file and see whether that helps going forward. https://support.mozilla.org/questions/1254924#answer-1210685
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.