Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox update made Word go crazy

more options

My Office365 browser version of Word (which I have no choice but to use for work) is too crazy to use since the latest Firefox update. It works fine in Chrome and even runs in my preferred language, whereas it is in English on FF. When using it, there are line breaks that I cannot get rid of, and two spaces between each word, among other infuriating problems. Help would be appreciated!

Chosen solution

And for what it's worth, my automatic update to 66.0.2 didn't insert that list, but exiting Firefox and starting it up again DID update it. Much easier than my earlier suggestion!

Read this answer in context 👍 1

All Replies (6)

more options
more options

My browser is up to date but the problem persists.

more options

Hi alexanderelliott, what is the URL of your Word online site? Can you compare the host name** with the value of the following preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste hack and pause while the list is filtered

What do you have listed for the value of the dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode preference? If it's long, you can right-click > Copy Value and paste that is bolded and paste that somewhere convenient.

The value is in the process of being updated to:

*.collabserv.com,*.gov.online.office365.us,*.officeapps-df.live.com,*.officeapps.live.com,*.online.office.de,*.partner.officewebapps.cn,*.scniris.com

However, if you do not have that list, or your Word server is not covered by that list, you can add the additional servers by hand.

** The host name in the address bar may not be the relevant one. See the next reply.

Modified by jscher2000

more options

Sorry, let me amend the earlier post. The address bar shows me this:

https://companydomain-my.sharepoint.com/etc.etc.

but the document is in a frame and when I right-click > This Frame > View Frame Info I see this:

https://word-edit.officeapps.live.com/we/wordeditorframe.aspx

So *.officeapps.live.com covers mine.

more options

Chosen Solution

And for what it's worth, my automatic update to 66.0.2 didn't insert that list, but exiting Firefox and starting it up again DID update it. Much easier than my earlier suggestion!

more options

Thank you to both of you for the help! I think it is working properly again now. I am grateful :)