X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 66 (macOS) reverting to playing YouTube videos automatically

Posted

I finally some months ago had managed to stop Firefox 63 (plus 64 and 65) from playing videos (i. e. on YouTube) automatically. In the course of finding the solution for this I had been told here in the forum that "no autoplay" would become the default in a future version of Firefox.

One or two days ago I then read that Firefox 66 would finally do this. Great. However, after updating to Firefox 66 videos on YouTube play again (unlike in my Firefox 65 with modified settings) automatically and with sound - blissfully ignoring the setting "Block websites from automatically playing sound" in the Firefox preferences.

With all due respect: Is this a joke? It was possible before to disable autoplay, now not anymore - what's the progress here? What is good about disabling the disabling of autoplay? And, no, youtube.com is not in my exceptions list (nothing is).

How can this be fixed?

I finally some months ago had managed to stop Firefox 63 (plus 64 and 65) from playing videos (i. e. on YouTube) automatically. In the course of finding the solution for this I had been told here in the forum that "no autoplay" would become the default in a future version of Firefox. One or two days ago I then read that Firefox 66 would finally do this. Great. However, after updating to Firefox 66 videos on YouTube play again (unlike in my Firefox 65 with modified settings) automatically and with sound - blissfully ignoring the setting "Block websites from automatically playing sound" in the Firefox preferences. With all due respect: Is this a joke? It was possible before to disable autoplay, now not anymore - what's the progress here? What is good about disabling the disabling of autoplay? And, no, youtube.com is not in my exceptions list (nothing is). How can this be fixed?

Modified by resucami2

Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

Could you try the setting shown in the attached screenshot, which is, on the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the Permissions section and check the box for "Block websites from automatically playing sound"

Then try YouTube again.

Could you try the setting shown in the attached screenshot, which is, on the Options page: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the left column, click '''Privacy & Security''' On the right side, scroll down to the '''Permissions''' section and check the box for "Block websites from automatically playing sound" Then try YouTube again.
Was this helpful to you? 0
Quote

Question owner

"Block websites from automatically playing sound" is checked (as already written in my original post.

"Block websites from automatically playing sound" is checked (as already written in my original post.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17412 solutions 157274 answers

Blocking autoplay on YouTube still works for me with media.autoplay.default = 1 (i.e. what I get with a checkmark in Options/Preferences).

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Blocking autoplay on YouTube still works for me with media.autoplay.default = 1 (i.e. what I get with a checkmark in Options/Preferences). Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

resucami2 said

"Block websites from automatically playing sound" is checked (as already written in my original post.

Hmm, works for me. To be clear, it works on initial page load of a watch URL (such as https://www.youtube.com/watch?v=u0431tculpg). It doesn't stop videos from auto-playing during internal navigation when YouTube changes the page contents without a full new page load.

''resucami2 [[#answer-1206765|said]]'' <blockquote> "Block websites from automatically playing sound" is checked (as already written in my original post. </blockquote> Hmm, works for me. To be clear, it works on initial page load of a watch URL (such as [https://www.youtube.com/watch?v=u0431tculpg]). It doesn't stop videos from auto-playing during internal navigation when YouTube changes the page contents without a full new page load.
Was this helpful to you?
Quote

Question owner

Thanks for your replies. I switched back to Firefox 65.0.2 and have no problems with autoplay anymore. I also disabled automatic updates and will again try a newer Firefox version in a couple of months.

After following the suggestions here some videos (with audio) on Youtube did not start automatically anymore, but some others (with audio) still did. I have no idea why and I don't think I will suffer when continuing to use Firefox 65.0.2 for some time.

It remains the question why Mozilla - and that not for the first time - disabled a working method to disable video autoplay (apparently also others have the same issue). From my viewpoint that is not an improvement - but what do I know, I'm just a simple user.

Thanks for your replies. I switched back to Firefox 65.0.2 and have no problems with autoplay anymore. I also disabled automatic updates and will again try a newer Firefox version in a couple of months. After following the suggestions here some videos (with audio) on Youtube did not start automatically anymore, but some others (with audio) still did. I have no idea why and I don't think I will suffer when continuing to use Firefox 65.0.2 for some time. It remains the question why Mozilla - and that not for the first time - disabled a working method to disable video autoplay (apparently also others have the same issue). From my viewpoint that is not an improvement - but what do I know, I'm just a simple user.

Modified by resucami2

Was this helpful to you?
Quote
WestEnd
  • Top 25 Contributor
60 solutions 5366 answers

hmm...I'll have to check my settings but I don't recall YT auto playing unless I have the box in YT enabled but I loo those settings to see as well.

hmm...I'll have to check my settings but I don't recall YT auto playing unless I have the box in YT enabled but I loo those settings to see as well.
Was this helpful to you? 0
Quote

Question owner

I have the Youtube "Autoplay" function disabled; this has no influence on some videos (with audio) starting automatically and others (with audio) not when using Firefox 66.

An example for a video (with audio) that did start automatically with Firefox 66 is this: https://www.youtube.com/watch?v=nsg9nQ03CdE.

Another example for a video (with audio) that did start automatically with Firefox 66 is this: https://www.youtube.com/watch?v=55Wety3Ut80

An example for a video (with audio) that did not start automatically with Firefox 66 is this: https://www.youtube.com/watch?v=cBKwvEizKZU.

I have the Youtube "Autoplay" function disabled; this has no influence on some videos (with audio) starting automatically and others (with audio) not when using Firefox 66. An example for a video (with audio) that did start automatically with Firefox 66 is this: https://www.youtube.com/watch?v=nsg9nQ03CdE. Another example for a video (with audio) that did start automatically with Firefox 66 is this: https://www.youtube.com/watch?v=55Wety3Ut80 An example for a video (with audio) that did not start automatically with Firefox 66 is this: https://www.youtube.com/watch?v=cBKwvEizKZU.

Modified by resucami2

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17412 solutions 157274 answers

None of the three YouTube videos you posted auto start for me. Although I see some flashing like ads are trying to play and are skipped automatically. I tested this in a clean profile without any Content Blocking extensions.

None of the three YouTube videos you posted auto start for me. Although I see some flashing like ads are trying to play and are skipped automatically. I tested this in a clean profile without any Content Blocking extensions.
Was this helpful to you?
Quote
koooper 4 solutions 8 answers

To make the "stop autoplay" work again use these settings:

media.autoplay.default: 1 media.autoplay.enabled.user-gestures-needed: false media.autoplay.allow-muted: false

Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.

To make the "stop autoplay" work again use these settings: media.autoplay.default: '''1''' media.autoplay.enabled.user-gestures-needed: '''false''' media.autoplay.allow-muted: '''false''' Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.