Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't associate Firefox with html files Windows 7

  • 13 replies
  • 2 have this problem
  • 9 views
  • Last reply by FredMcD

more options

I can't open html files with Firefox. They open with Windows Media Player instead. When I try choose Firefox to open the html file, Firefox is not listed in the RECOMMENDED PROGRAMS or OTHER PROGRAMS list (see image), and when I BROWSE for it, and select the Firefox.exe, nothing happens.

In SET YOUR DEFAULT PROGRAMS, Firefox has a Windows Media Player icon and says FIREFOX MICROSOFT WINDOWS (see image).

In ASSOCIATE A FILE TYPE OR PROTOCOL WITH A PROGRAM (see image), when I select CHANGE PROGRAM I am unable to associate Firefox with html files.

I have tried deleting the Firefox entry from REGISTRY EDITOR:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications

I have also tried uninstalling Firefox, and then deleting the folder:

C:\Program Files\Mozilla Firefox

And then restarting my PC and installing the latest Firefox as administrator.

Attached screenshots

Modified by Keylonta

All Replies (13)

more options

Please describe how you are trying to open those files.

more options

Try using File > Open File ... from the Menu Bar in Firefox.

Or use { Ctrl + O }.

more options

In Firefox I can open html files by dragging them in or using the File > Open File option.

I want to associate Firefox with html files so I can double click on them to open them in Firefox, and also try and fix the other issues mentioned above.

more options

Using Windows File Explorer, locate an HTML file. Right-click and select Properties. On the General tab, press Change.

more options

FredMcD said

Using Windows File Explorer, locate an HTML file. Right-click and select Properties. On the General tab, press Change.

I've tried that, see the first paragraph of my question, and the first screenshot.

"When I try choose Firefox to open the html file, Firefox is not listed in the RECOMMENDED PROGRAMS or OTHER PROGRAMS list (see image), and when I BROWSE for it, and select the Firefox.exe, nothing happens."

Modified by Keylonta

more options

I don't see a screenshot of the file properties?

more options

WestEnd said

I don't see a screenshot of the file properties?

I didn't include a screenshot of the General tab of the html files Properties . I just took a screenshot of the window that appears when you press Change on the General tab. See first screenshot.

Modified by Keylonta

more options

Here is a screenshot of the html files Properties.

Modified by Keylonta

more options

On that first screenshot, on the bottom, press Browse.

more options

FredMcD said

On that first screenshot, on the bottom, press Browse.

"and when I BROWSE for it, and select the Firefox.exe, nothing happens."

more options

You pressed 'Open' after making the choice?

more options

FredMcD said

You pressed 'Open' after making the choice?

Yes.

more options