X
Tap here to go to the mobile version of the site.

Support Forum

Szyfrowanie .

Posted

Jak dodać do Waszej przeglądarki obsługę szyfrowania TLS 1.1 1.2 i 1.3 ? .

Jak dodać do Waszej przeglądarki obsługę szyfrowania TLS 1.1 1.2 i 1.3 ? .
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

More Information

TyDraniu
  • Top 25 Contributor
302 solutions 1686 answers

Nie trzeba dodawać, Firefox na dzień dzisiejszy obsługuje TLS 1.0 do 1.3

Nie trzeba dodawać, Firefox na dzień dzisiejszy obsługuje TLS 1.0 do 1.3
Was this helpful to you? 0
Quote

Question owner

W załączniku scren .

W załączniku scren .
Was this helpful to you?
Quote

Question owner

np scren w załączniku .

np scren w załączniku .
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
302 solutions 1686 answers
  1. Którą masz wersję Firefoksa?
  2. Wpisz about:config w pasku adresu i sprawdź security.tls.version.min oraz security.tls.version.max. Powinno być 1 i 4
# Którą masz wersję Firefoksa? # Wpisz ''about:config'' w pasku adresu i sprawdź '''security.tls.version.min''' oraz '''security.tls.version.max'''. Powinno być 1 i 4
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17352 solutions 156837 answers

See also:

The website uses in the current Firefox release for me TLS 1.3 and TLS_AES_128_GCM_SHA256. You may have security software that doesn't support cipher suites compatible with the server.

You can check your browser.

See also: *https://www.ssllabs.com/ssltest/analyze.html?d=www.fxmag.pl The website uses in the current Firefox release for me TLS 1.3 and TLS_AES_128_GCM_SHA256. You may have security software that doesn't support cipher suites compatible with the server. You can check your browser. *https://www.ssllabs.com/ssltest/viewMyClient.html
Was this helpful to you? 0
Quote

Question owner

TyDraniu said

  1. Którą masz wersję Firefoksa? # Wpisz about: config w pasku adresu i sprawdź 'security.tls.version.min' oraz 'security.tls.version.max' . Powinno być 1 i 4


Niestety zmiana tych parametrów w zakresie od 1 do 4 nic nie pomaga wersja 3.6.26

''TyDraniu [[#answer-1206017|said]]'' <blockquote> # Którą masz wersję Firefoksa? # Wpisz '' about: config '' w pasku adresu i sprawdź '' 'security.tls.version.min' '' oraz '' 'security.tls.version.max' ''. Powinno być 1 i 4 </blockquote> Niestety zmiana tych parametrów w zakresie od 1 do 4 nic nie pomaga wersja 3.6.26
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
302 solutions 1686 answers

To się w tej dekadzie nie aktualizowałeś, co? Dziwię się, że cokolwiek w ogóle działa na tej wersji. My już nie wspieramy takich numerów.

To się w tej dekadzie nie aktualizowałeś, co? Dziwię się, że cokolwiek w ogóle działa na tej wersji. My już nie wspieramy takich numerów.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17352 solutions 156837 answers

On Windows XP you can use Firefox 52.9.0 ESR and the website works with this version.

  • Connection Encrypted (TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, 128 bit keys, TLS 1.2)
On Windows XP you can use Firefox 52.9.0 ESR and the website works with this version. *Connection Encrypted (TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, 128 bit keys, TLS 1.2) *https://download-origin.cdn.mozilla.net/pub/firefox/releases/52.9.0esr/win32-sha1/en-US/
Was this helpful to you? 0
Quote

Question owner

TyDraniu said

To się w tej dekadzie nie aktualizowałeś, co? Dziwię się, że cokolwiek w ogóle działa na tej wersji. My już nie wspieramy takich numerów.


A jak do tej przeglądarki dodać te protokoły ??? 1.1 lub 1.2 ?

''TyDraniu [[#answer-1206611|said]]'' <blockquote> To się w tej dekadzie nie aktualizowałeś, co? Dziwię się, że cokolwiek w ogóle działa na tej wersji. My już nie wspieramy takich numerów. </blockquote> A jak do tej przeglądarki dodać te protokoły ??? 1.1 lub 1.2 ?
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
302 solutions 1686 answers

Zaktualizować przeglądarkę z adresu, który podał wyżej cor-el.

Zaktualizować przeglądarkę z adresu, który podał wyżej cor-el.
Was this helpful to you? 0
Quote

Question owner

TyDraniu said

Zaktualizować przeglądarkę z adresu, który podał wyżej cor-el.

Ale same protokoły chyba można by było przekopiować z innej przeglądarki i wrzucić je do tej ? .

''TyDraniu [[#answer-1207777|said]]'' <blockquote> Zaktualizować przeglądarkę z adresu, który podał wyżej cor-el. </blockquote> Ale same protokoły chyba można by było przekopiować z innej przeglądarki i wrzucić je do tej ? .
Was this helpful to you?
Quote

Question owner

TyDraniu said

To się w tej dekadzie nie aktualizowałeś, co? Dziwię się, że cokolwiek w ogóle działa na tej wersji. My już nie wspieramy takich numerów.

Ale mógł byś napisać jak wgrać te protokoły do przeglądarki ? .

''TyDraniu [[#answer-1206611|said]]'' <blockquote> To się w tej dekadzie nie aktualizowałeś, co? Dziwię się, że cokolwiek w ogóle działa na tej wersji. My już nie wspieramy takich numerów. </blockquote> Ale mógł byś napisać jak wgrać te protokoły do przeglądarki ? .
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17352 solutions 156837 answers

It is not possible to add support for newer TSL 1.x protocols other than updating Firefox. This TLS support would have to be added to the source code and recompiled.

What is against using Firefox 52?


TLS 1.1 is actually skipped and TLS 1.2 was enabled in Firefox 27. Bug 1310516 - Enable TLS 1.3 by default [52] Bug 861266 - Implement TLS 1.2 (RFC 5246) in Gecko (Firefox, Thunderbird), on by default [27] Bug 733647 - Implement TLS 1.1 (RFC 4346) in Gecko (Firefox, Thunderbird), on by default [27]

It is not possible to add support for newer TSL 1.x protocols other than updating Firefox. This TLS support would have to be added to the source code and recompiled. What is against using Firefox 52? ----- TLS 1.1 is actually skipped and TLS 1.2 was enabled in Firefox 27. Bug 1310516 - Enable TLS 1.3 by default [52] Bug 861266 - Implement TLS 1.2 (RFC 5246) in Gecko (Firefox, Thunderbird), on by default [27] Bug 733647 - Implement TLS 1.1 (RFC 4346) in Gecko (Firefox, Thunderbird), on by default [27]
Was this helpful to you?
Quote

Question owner

kor said

Co jest przeciwne użyciu Firefoksa 52?


Kiedyś zaktualizowałem do wersji 4 ale po pierwsze tak muliła że ciężko było cokolwiek zrobić a po drugie zrobiła się tak samo jak przeglądarka gogle więc wróciłem do wersji 3 po drodze tracąc połowę zakładek haseł i historii i od tej pory wyłączyłem aktualizacje tutaj . A ile by trwało dodanie takiego szyfrowania do przeglądarki ? i kompilacja wszystkiego ? nie dało by się tego wrzucić w formie pliku do foldera systemowego przeglądarki bez zmiany kodu przeglądarki żeby przeglądarka to wczytała ? .

''kor [[#answer-1208302|said]]'' <blockquote> Co jest przeciwne użyciu Firefoksa 52? </blockquote> Kiedyś zaktualizowałem do wersji 4 ale po pierwsze tak muliła że ciężko było cokolwiek zrobić a po drugie zrobiła się tak samo jak przeglądarka gogle więc wróciłem do wersji 3 po drodze tracąc połowę zakładek haseł i historii i od tej pory wyłączyłem aktualizacje tutaj . A ile by trwało dodanie takiego szyfrowania do przeglądarki ? i kompilacja wszystkiego ? nie dało by się tego wrzucić w formie pliku do foldera systemowego przeglądarki bez zmiany kodu przeglądarki żeby przeglądarka to wczytała ? .
Was this helpful to you?
Quote

Question owner

kor said

TLS 1.1 jest faktycznie pomijany,

A dało by się go aktywować żeby nie był pomijany ? .

''kor [[#answer-1208302|said]]'' <blockquote> TLS 1.1 jest faktycznie pomijany, </blockquote> A dało by się go aktywować żeby nie był pomijany ? .
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
302 solutions 1686 answers

To może zapoznaj się z tą stroną: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS

Ja osobiście nie mam pojęcia, jak z tego skorzystać.

To może zapoznaj się z tą stroną: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS Ja osobiście nie mam pojęcia, jak z tego skorzystać.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17352 solutions 156837 answers

To have support for TLS 1.1 and 1.2 you need Firefox 27 or later (TLS 1.1 was skipped and went directly from 1.0 to 1.2). For Firefox 1.3 you need Firefox 52 (ESR), but enabling TLS 1.3 by default has been postponed for a lot of Firefox versions (59 and older; enabled in 60) and there can still be issues with some servers. I'm not aware of a way to add this to Firefox 3.6 versions.

(I can't read Polish, so I need to use the Google Translate service)

To have support for TLS 1.1 and 1.2 you need Firefox 27 or later (TLS 1.1 was skipped and went directly from 1.0 to 1.2). For Firefox 1.3 you need Firefox 52 (ESR), but enabling TLS 1.3 by default has been postponed for a lot of Firefox versions (59 and older; enabled in 60) and there can still be issues with some servers. I'm not aware of a way to add this to Firefox 3.6 versions. ''(I can't read Polish, so I need to use the Google Translate service)''
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.