X
Tap here to go to the mobile version of the site.

Support Forum

Firefox is not playing most of my videos

Posted

I have been running Mozilla that comes default with Ubuntu 18.04 for the last one and a half months but not been able to play most videos and gifs. Youtube runs properly but Amazon Prime does not. I tried restarting in the safe mode and still couldn't get it to work. I only added an ad-blocker add on and disabling this did not help too.

I browse reddit and one thing I noticed is that gfycat gifs play fine but rest of them just don't play. They just show a picture of the first frame, no error messages as such.

I have been running Mozilla that comes default with Ubuntu 18.04 for the last one and a half months but not been able to play most videos and gifs. Youtube runs properly but Amazon Prime does not. I tried restarting in the safe mode and still couldn't get it to work. I only added an ad-blocker add on and disabling this did not help too. I browse reddit and one thing I noticed is that gfycat gifs play fine but rest of them just don't play. They just show a picture of the first frame, no error messages as such.

Chosen solution

With the various flavors of Ubuntu you may also find the FFmpeg in Ubuntu Restricted Extras for example. https://help.ubuntu.com/community/RestrictedFormats

Read this answer in context 0
Quote

Additional System Details

Application

  • Firefox 65.0.1
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
  • Support URL: https://support.mozilla.org/1/firefox/65.0.1/Linux/en-US/

Extensions

  • Adblock Plus - free ad blocker 3.4.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2)
  • adapterDeviceID: Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2)
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • contentUsesTiling: False
  • crashGuards: []
  • driverDate:
  • driverVersion: 3.0 Mesa 18.0.5
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4194 solutions 58530 answers

Please try the full installer from; Download Firefox For All languages And Systems {web link}

Please try the full installer from; '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link}
Was this helpful to you?
Quote

Question owner

I installed from the link given but still the issue is not solved. Thanks for the reply!

I installed from the link given but still the issue is not solved. Thanks for the reply!
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4194 solutions 58530 answers
https://support.mozilla.org/en-US/kb/fix-problems-images-not-show https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems https://support.mozilla.org/en-US/kb/warning-unresponsive-plugin
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156792 answers

Make sure you have installed the latest FFmpeg packages in Ubuntu. See also about:config: media.ffmpeg.enabled = true

You can open the YouTube test page to check support in Firefox for playing HTML5 media.

Make sure you have installed the latest FFmpeg packages in Ubuntu. See also about:config: media.ffmpeg.enabled = true You can open the YouTube test page to check support in Firefox for playing HTML5 media. *https://www.youtube.com/html5
Was this helpful to you?
Quote
James
  • Moderator
1593 solutions 11224 answers

Chosen Solution

With the various flavors of Ubuntu you may also find the FFmpeg in Ubuntu Restricted Extras for example. https://help.ubuntu.com/community/RestrictedFormats

With the various flavors of Ubuntu you may also find the '''FFmpeg''' in Ubuntu Restricted Extras for example. https://help.ubuntu.com/community/RestrictedFormats
Was this helpful to you?
Quote

Question owner

Installing restricted extras package solved the issue. Many Thanks for replying!

Installing restricted extras package solved the issue. Many Thanks for replying!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.