X
Tap here to go to the mobile version of the site.

Support Forum

Save Manually Entered URL But Not Entire Browsing History

Posted

I am trying to find the setting that will have Firefox save a manually entered URL in the drop-down address bar but NOT the browsing history of every single web page I visit. It used to be this way but an update or something has changed it recently to where every page I visit on a website shows up in the drop-down address bar. It is hard to find a specific URL I have entered. I know how to add a website to my Favorites but I would like to get things back to the way they were before this change.

I've looked around in the Options menu and I see where I can select the option to not save my browsing history but that also deletes my manually typed in URLs. I want to keep them. It used to do this.

Firefox Quantum 65.0.2

I am trying to find the setting that will have Firefox save a manually entered URL in the drop-down address bar but NOT the browsing history of every single web page I visit. It used to be this way but an update or something has changed it recently to where every page I visit on a website shows up in the drop-down address bar. It is hard to find a specific URL I have entered. I know how to add a website to my Favorites but I would like to get things back to the way they were before this change. I've looked around in the Options menu and I see where I can select the option to not save my browsing history but that also deletes my manually typed in URLs. I want to keep them. It used to do this. Firefox Quantum 65.0.2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

FredMcD
  • Top 10 Contributor
4224 solutions 58930 answers

You could always delete your history, or use Private Browsing.

You could always delete your history, or use Private Browsing.

Helpful Reply

Thank you for the reply. However, deleting the history also deletes any manually typed URLs that I want to keep in the drop-down list. I just tried Private Browsing and it does not save manually entered URLs, either. Also, it does not seem to save passwords when I have to log on a website each time.

Thank you for the reply. However, deleting the history also deletes any manually typed URLs that I want to keep in the drop-down list. I just tried Private Browsing and it does not save manually entered URLs, either. Also, it does not seem to save passwords when I have to log on a website each time.
FredMcD
  • Top 10 Contributor
4224 solutions 58930 answers

Bookmark those entries. They are kept separate from history.

Also look at: Type about:preferences#privacy<enter> in the address bar. At the bottom of the page, find Location Bar.

Bookmark those entries. They are kept separate from history. Also look at: Type '''about:preferences#privacy'''<enter> in the address bar. At the bottom of the page, find '''Location Bar. '''
jimtapley 0 solutions 3 answers

Is there anyway to go back to the version of Firefox that did not have this problem of adding to much data to the History drop down tab on the URL address line ? Also is there anyway to talk to someone in Firefox support that understands how to correct this problem in the most recent release ? Does Firefox have a tech support group and if so is there anyway to contact them ?

Is there anyway to go back to the version of Firefox that did not have this problem of adding to much data to the History drop down tab on the URL address line ? Also is there anyway to''' talk''' to someone in Firefox support that understands how to correct this problem in the most recent release ? Does Firefox have a tech support group and if so is there anyway to contact them ?
FredMcD
  • Top 10 Contributor
4224 solutions 58930 answers

We are the official support for Firefox.

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.


Why not just bookmark those entries?

Note: Some versions of Quantum change how the data files are set up, so they are not backward compatible.

We are the official support for Firefox. The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers. ----------- Why not just bookmark those entries? '''Note:''' Some versions of Quantum change how the data files are set up, so they are not backward compatible.
jimtapley 0 solutions 3 answers

It sounds like Firefox's approach to support is to let users try to figure out work around ways to try to solve functional problems with their new releases and then share these work arounds with other end users and hope someone can figure out a way to crutch a problem. This approach to non-support is making Microsoft Edge look a lot better that it used to.

It sounds like Firefox's approach to support is to let users try to figure out work around ways to try to solve functional problems with their new releases and then share these work arounds with other end users and hope someone can figure out a way to crutch a problem. This approach to non-support is making Microsoft Edge look a lot better that it used to.
jscher2000
  • Top 10 Contributor
8635 solutions 70623 answers

The "only show typed URLs in history suggestions" feature** was removed in Firefox 65. Apparently there were bugs in it and they were difficult to fix, so rather than leave a broken feature, it was removed. I know that's not what anyone wants to hear, because we've had posts from several users who liked that feature despite its issues, but that's the status. There is no longer any built-in way to filter the address bar drop-down to show only "typed in" history suggestions.

At the risk of creating even more clutter, you can increase the number of suggestions in the drop-down so that if there are many more matches, you may still see the one you're looking for:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.maxRichResults preference to display a dialog where you can edit the value, type another number (for example, 15), then click OK

** Previously selected by switching the browser.urlbar.suggest.history.onlyTyped preference from false to true in about:config.

The "only show typed URLs in history suggestions" feature** was removed in Firefox 65. Apparently there were bugs in it and they were difficult to fix, so rather than leave a broken feature, it was removed. I know that's not what anyone wants to hear, because we've had posts from several users who liked that feature despite its issues, but that's the status. There is no longer any built-in way to filter the address bar drop-down to show only "typed in" history suggestions. At the risk of creating even more clutter, you can increase the number of suggestions in the drop-down so that if there are many more matches, you may still see the one you're looking for: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.maxRichResults''' preference to display a dialog where you can edit the value, type another number (for example, 15), then click OK ''** Previously selected by switching the'' '''browser.urlbar.suggest.history.onlyTyped''' ''preference from false to true in about:config.

Modified by jscher2000

Question owner

Hi. I'm the OP who started the thread about this problem. It looks like Firefox has fixed the problem, at least for now, with a new update. When I now click on the URL history the only things that show are the ones that I have typed in manually, not every single web page that I have browsed.

That's how it used to be and that's the way I want it. Please do not change it again, Mozilla. If you do, then at least give us an option in the settings to change it back to this. Thanks to everyone here for your time and input.

Hi. I'm the OP who started the thread about this problem. It looks like Firefox has fixed the problem, at least for now, with a new update. When I now click on the URL history the only things that show are the ones that I have typed in manually, not every single web page that I have browsed. That's how it used to be and that's the way I want it. Please do not change it again, Mozilla. If you do, then at least give us an option in the settings to change it back to this. Thanks to everyone here for your time and input.