Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

pages/tabs that open on start up

  • 7 replies
  • 1 has this problem
  • 94 views
  • Last reply by wilwood

more options

I have checked open pages from last session but yet Firefox opens with my home page. How do I fix this to open pages/tabs of last session when closed?

Chosen solution

wilwood said

There is something that is not making this work. Yes there is that box ( Preferences/General/Startup) to check that says "restore previous session" and I have checked it. But upon new start up of Firefox, I still get only one tab open and it is home page

Any chance that you have Firefox set to clear your browsing history when Firefox closes?

If you clear browsing history, that clears your session data so there's nothing to restore when Firefox is opened again.

Read this answer in context 👍 0

All Replies (7)

more options

Check your in your settings there should be a option to choose to re-open last session in there.

more options

I had checked that box an still does not open the pages from last session. What's the trick?

more options

Well I have to go back home when done at work and look at my settings but I know I saw there was a option there to do that. But if you don't have the privacy to clear cookies and history you can always click the option restore sessions and they should come back. But this assumes you didn't open a blank homepage and closed it before clicking option to reopen previous sessions. If you don't they will be gone if you try to reopen it again.

more options

There is something that is not making this work. Yes there is that box ( Preferences/General/Startup) to check that says "restore previous session" and I have checked it. But upon new start up of Firefox, I still get only one tab open and it is home page

more options

Have your Firefox session open with whatever you want it to open with, then Options -> Home...

...under "New Windows and tabs..." select "Custom URLs."

If all other pages are loaded in tabs, all instances of Firefox (including all tabs and windows), click "Use Current Pages" button.

This will automatically open all current windows and tabs of Firefox, sans about:options.

Modified by active_schuder

more options

Chosen Solution

wilwood said

There is something that is not making this work. Yes there is that box ( Preferences/General/Startup) to check that says "restore previous session" and I have checked it. But upon new start up of Firefox, I still get only one tab open and it is home page

Any chance that you have Firefox set to clear your browsing history when Firefox closes?

If you clear browsing history, that clears your session data so there's nothing to restore when Firefox is opened again.

more options

Thanks, that is what it was.