Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do I make firefox stop autofilling "livescience.com" when I want to go to "live.com"

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by FredMcD

more options

I have a live.com email address, so everyday, when I start typing in "live," Firefox autofills "livescience.com" even though I have never gone there (on purpose) and never want to. I go to "live.com" everyday, but still, the autofill for "live" comes up with "livescience.com." I have tried every online suggestion I can find to try and make Firefox stop autofilling "livescience.com" but nothing works. This is extremely frustrating. I have cleared all history, I have tried the "select the URL and hit Shift+Delete", and I have tried "forget this site." Nothing works! I don't want to disable autofill all together. Ideally, I want Firefox to autofill the site I actually visit everyday; I want Firefox to autofill "live.com" when I type in the word "live".

All Replies (1)

more options

That would be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Delete (Mac=Shift Delete). Repeat as needed.