X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Changing display name for email account not working

Posted

The display name in the email account settings has been changed. When composing a new email the display name is showing correctly, however when the recipient receives it, it is something completely different. I'm struggling to find a solution to this one.

It must be still set somewhere as an old display name and I'm not sure where else to look.

Thanks in advanced.

The display name in the email account settings has been changed. When composing a new email the display name is showing correctly, however when the recipient receives it, it is something completely different. I'm struggling to find a solution to this one. It must be still set somewhere as an old display name and I'm not sure where else to look. Thanks in advanced.

Chosen solution

Right click on mail account name in Folder pane and select 'Settings' The 'Your Name' field is what gets displayed in the 'From' field when you click on 'Write' to compose an email. This is the one used when sending emails.

click on 'Manage Identities' button If you have more than one 'Identity' associated with a mail account, then check to see if the 'Your Name' is different for one of the identities.

If your name is in an Address Book, then you can choose to use a 'Display Name' and all received/sent emails you see will show that name instead. If no 'Display' name is entered then you will see the use of 'Me' followed by email address. This also means any recipient could also have a 'display' name set on their email client and it will use that instead of the name you sent in the 'From' field.


check what you have got stored in your preferences for various mail identities.

  • 'Menu icon' > 'Options' > 'Advanced' > 'General' tab
  • click on 'Config Editor'
  • In search type : fullName
  • mail.identity.idX.fullName = the 'Your Name' entered for an account.

Your webmail account: I've checked this on mine and can confirm it only uses the name stored in webmail when I use webmail to send email. But it might be worth checking to see what name you have got set up in the webmail account, just in case the server is modifying the name to use what you have got stored in webmail.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.96 Safari/537.36

More Information

christ1
  • Top 10 Contributor
2127 solutions 15526 answers

Tell the recipient to fix his or her address book entry.

Tell the recipient to fix his or her address book entry.
Was this helpful to you? 0
Quote

Question owner

Thanks for responding christ1.

I have checked their details in their own address book and it matches what’s in the account details.

They are not in my address book and when I sent a test email to myself it came through incorrectly.

Thanks for responding christ1. I have checked their details in their own address book and it matches what’s in the account details. They are not in my address book and when I sent a test email to myself it came through incorrectly.
Was this helpful to you? 0
Quote
pscEx 1 solutions 15 answers

Check your sent folder for the contained address of the mail. Check the mail in your provider's sent folder by using a webmailer. Compare. Then you can decide who is the bad boy. (I agree to Christ1 and think that it is not TB.)

Check the provider's "collected addresses". If there is the address of the receiver (including yourself), you can safely delete this address.

Check your sent folder for the contained address of the mail. Check the mail in your provider's sent folder by using a webmailer. Compare. Then you can decide who is the bad boy. (I agree to Christ1 and think that it is not TB.) Check the provider's "collected addresses". If there is the address of the receiver (including yourself), you can safely delete this address.

Modified by pscEx

Was this helpful to you? 0
Quote

Question owner

Well in that case you are both incorrect.

I have sent emails from this user account to addresses that have never received emails from this email address before and they still come through with the wrong Display Name.

I've now even tried recreating the email address and this hasn't fixed it either.

Does anyone have an idea of where this is set in registry?

Well in that case you are both incorrect. I have sent emails from this user account to addresses that have never received emails from this email address before and they still come through with the wrong Display Name. I've now even tried recreating the email address and this hasn't fixed it either. Does anyone have an idea of where this is set in registry?
Was this helpful to you? 0
Quote
Toad-Hall
  • Top 10 Contributor
1647 solutions 10963 answers

Chosen Solution

Right click on mail account name in Folder pane and select 'Settings' The 'Your Name' field is what gets displayed in the 'From' field when you click on 'Write' to compose an email. This is the one used when sending emails.

click on 'Manage Identities' button If you have more than one 'Identity' associated with a mail account, then check to see if the 'Your Name' is different for one of the identities.

If your name is in an Address Book, then you can choose to use a 'Display Name' and all received/sent emails you see will show that name instead. If no 'Display' name is entered then you will see the use of 'Me' followed by email address. This also means any recipient could also have a 'display' name set on their email client and it will use that instead of the name you sent in the 'From' field.


check what you have got stored in your preferences for various mail identities.

  • 'Menu icon' > 'Options' > 'Advanced' > 'General' tab
  • click on 'Config Editor'
  • In search type : fullName
  • mail.identity.idX.fullName = the 'Your Name' entered for an account.

Your webmail account: I've checked this on mine and can confirm it only uses the name stored in webmail when I use webmail to send email. But it might be worth checking to see what name you have got set up in the webmail account, just in case the server is modifying the name to use what you have got stored in webmail.

Right click on mail account name in Folder pane and select 'Settings' The 'Your Name' field is what gets displayed in the 'From' field when you click on 'Write' to compose an email. This is the one used when sending emails. click on 'Manage Identities' button If you have more than one 'Identity' associated with a mail account, then check to see if the 'Your Name' is different for one of the identities. If your name is in an Address Book, then you can choose to use a 'Display Name' and all received/sent emails you see will show that name instead. If no 'Display' name is entered then you will see the use of 'Me' followed by email address. This also means any recipient could also have a 'display' name set on their email client and it will use that instead of the name you sent in the 'From' field. check what you have got stored in your preferences for various mail identities. * 'Menu icon' > 'Options' > 'Advanced' > 'General' tab * click on 'Config Editor' * In search type : '''fullName''' * mail.identity.idX.fullName = the 'Your Name' entered for an account. Your webmail account: I've checked this on mine and can confirm it only uses the name stored in webmail when I use webmail to send email. But it might be worth checking to see what name you have got set up in the webmail account, just in case the server is modifying the name to use what you have got stored in webmail.
Was this helpful to you? 0
Quote

Question owner

I think you are correct Toad-Hall.

I think it is using their display name from their webmail.

What led me to this was setting the email up under a different user account on the same computer with the same result. Then I tried it on my computer with the same result thus meaning it almost certainly has to be picking up the display name from their email hosting service.

Unfortunately, I don't have access to change it as it locked by the their hosting provider whom I am not authorised to speak to on their behalf.

Thanks for your help though.

I think you are correct Toad-Hall. I think it is using their display name from their webmail. What led me to this was setting the email up under a different user account on the same computer with the same result. Then I tried it on my computer with the same result thus meaning it almost certainly has to be picking up the display name from their email hosting service. Unfortunately, I don't have access to change it as it locked by the their hosting provider whom I am not authorised to speak to on their behalf. Thanks for your help though.

Modified by BishBashBosh

Was this helpful to you?
Quote
harguthm 0 solutions 3 answers

I have tried the above suggestions except the one where I find the menu icon (where is that?) This problem began a week ago so it is something recent; perhaps if thunderbird did an update? My name changes from Marlene to Margaret.

I have tried the above suggestions except the one where I find the menu icon (where is that?) This problem began a week ago so it is something recent; perhaps if thunderbird did an update? My name changes from Marlene to Margaret.
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1647 solutions 10963 answers

Helpful Reply

harguthm re: menu icon (where is that?) It is located on the 'Mail Toobar'. The icon has three horizontal lines.

It suggest you check your address books. It is possible you have more than one entry eg: one in 'Personal Address Book' and another in 'Collected Addresses' etc.

Click on 'Address Book' Select 'All Address Books' Enable the 'Address Book ' column header

re: My name changes from Marlene to Margaret If the email address is identical: Click on 'Email ' column header to sort by email address. This will group email addresses, so you can see if there is more than one entry and in what address book.

Check you are using a 'Display' Name for all entries.


You say it changes the name, but is this in a new 'Write' window 'From' field when you are writing/composing new mail ?

Or is this in received emails where your email address is in the 'TO' field?

Do you have the following setting?

  • 'Menu icon' > 'Options' > 'Display' > 'Advanced' tab
  • under 'Display' section
  • select checkbox 'Show only display name for people in my address book'
  • click on 'OK'
'''harguthm''' re: ''menu icon (where is that?) '' It is located on the 'Mail Toobar'. The icon has three horizontal lines. It suggest you check your address books. It is possible you have more than one entry eg: one in 'Personal Address Book' and another in 'Collected Addresses' etc. Click on 'Address Book' Select 'All Address Books' Enable the 'Address Book ' column header re: ''My name changes from Marlene to Margaret'' If the email address is identical: Click on 'Email ' column header to sort by email address. This will group email addresses, so you can see if there is more than one entry and in what address book. Check you are using a 'Display' Name for all entries. You say it changes the name, but is this in a new 'Write' window 'From' field when you are writing/composing new mail ? Or is this in received emails where your email address is in the 'TO' field? Do you have the following setting? * 'Menu icon' > 'Options' > 'Display' > 'Advanced' tab * under 'Display' section * select checkbox 'Show only display name for people in my address book' * click on 'OK'
Was this helpful to you? 1
Quote
harguthm 0 solutions 3 answers

Thank you. I hope this solves the problem.

Thank you. I hope this solves the problem.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.