X
Tap here to go to the mobile version of the site.

Safely share files online with encrypted links that “self-destruct.” Try Firefox Send.

Give hackers a swift kick in the cookies. See if your data has been affected by a breach with Firefox Monitor. Try it now.

Access your history, passwords and open tabs wherever you are with Sync. Connect a second device.

Support Forum

accent characters (á) show %C3%A1 when copy-paste in document

Posted

I'm using Firefox Quantum, v 65.0 (64bits) in Windows 10 Pro, v. 1809.

When there is an accent in an url-address like: https://eo.wikipedia.org/wiki/Luis_Hernández_Yzal and I want to copy-paste it in an other document, the accent changes into %C3%A1, like this:

https://eo.wikipedia.org/wiki/Luis_Hern%C3%A1ndez_Yzal

It does not happen in Internet Explorer and Edge.

I'm using Firefox Quantum, v 65.0 (64bits) in Windows 10 Pro, v. 1809. When there is an accent in an url-address like: https://eo.wikipedia.org/wiki/Luis_Hernández_Yzal and I want to copy-paste it in an other document, the accent changes into %C3%A1, like this: https://eo.wikipedia.org/wiki/Luis_Hern%C3%A1ndez_Yzal It does not happen in Internet Explorer and Edge.

Modified by cor-el

Chosen solution

Try to set this pref to true on the about:config page.

  • browser.urlbar.decodeURLsOnCopy = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

WestEnd
  • Top 10 Contributor
59 solutions 4801 answers

Which document are you coping it to? What you copy and what the document does aren't the same. Since your using the documents file command and no longer firefox file manager. I copied the url to notepad and office 2016 word and have no accent issue.

Which document are you coping it to? What you copy and what the document does aren't the same. Since your using the documents file command and no longer firefox file manager. I copied the url to notepad and office 2016 word and have no accent issue.
Was this helpful to you?
Quote

Question owner

WestEnd said

Which document are you coping it to? What you copy and what the document does aren't the same. Since your using the documents file command and no longer firefox file manager. I copied the url to notepad and office 2016 word and have no accent issue.

I tried to copy it into Word 2016, Outlook from Office 365, Notepad++.

If this works for you, maybe there is a setting that I dont know. I'm not used to work with Firefox, maybe you can give me som hints?

''WestEnd [[#answer-1195112|said]]'' <blockquote> Which document are you coping it to? What you copy and what the document does aren't the same. Since your using the documents file command and no longer firefox file manager. I copied the url to notepad and office 2016 word and have no accent issue. </blockquote> I tried to copy it into Word 2016, Outlook from Office 365, Notepad++. If this works for you, maybe there is a setting that I dont know. I'm not used to work with Firefox, maybe you can give me som hints?
Was this helpful to you?
Quote
WestEnd
  • Top 10 Contributor
59 solutions 4801 answers

My firefox is default settings for the most part other then a "userChrome.css" modification to the theme and look.

My firefox is default settings for the most part other then a "userChrome.css" modification to the theme and look.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16918 solutions 152788 answers

Chosen Solution

Try to set this pref to true on the about:config page.

  • browser.urlbar.decodeURLsOnCopy = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Try to set this pref to true on the <b>about:config</b> page. *browser.urlbar.decodeURLsOnCopy = true You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you? 1
Quote

Question owner

Thank you very much!

This solution solved my problem.

Thank you very much! This solution solved my problem.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.