X
Tap here to go to the mobile version of the site.

Support Forum

How do I get rid of the dropdown bar that began appearing in Firefox 65.0?

Posted

One of the reasons I hate upgrading Firefox is that every new version brings a host of anti-features.

Starting in 65.0, whenever I am typing into the address bar, one (blue) or two (blue and black) bars drop down (depending on how much of the address I have typed) offering to either search or go to the address bar contents.

I DON'T WANT THEM!!!!!

How do I get rid of them?

One of the reasons I hate upgrading Firefox is that every new version brings a host of anti-features. Starting in 65.0, whenever I am typing into the address bar, one (blue) or two (blue and black) bars drop down (depending on how much of the address I have typed) offering to either search or go to the address bar contents. I DON'T WANT THEM!!!!! How do I get rid of them?

Chosen solution

You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page.

  • browser.urlbar.oneOffSearches = false

You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}


It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

{
"application": {
"name": "Firefox",
"version": "65.0",
"buildID": "20190124174741",
"userAgent": "Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0",
"safeMode": false,
"updateChannel": "release",
"supportURL": "https://support.mozilla.org/1/firefox/65.0/Linux/en-US/",
"numTotalWindows": 1,
"numRemoteWindows": 1,
"remoteAutoStart": true,
"currentContentProcesses": 3,
"maxContentProcesses": 4,
"autoStartStatus": 1,
"policiesStatus": 0,
"keyGoogleFound": true,
"keyMozillaFound": true
},
"securitySoftware": {
"registeredAntiVirus": "",
"registeredAntiSpyware": "",
"registeredFirewall": ""
},
"lockedPreferences": {},
"media": {
"currentAudioBackend": "remote",
"currentMaxAudioChannels": 0,
"currentPreferredSampleRate": 44100,
"audioOutputDevices": [],
"audioInputDevices": []
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 1,
"handlerUsed": false,
"instantiator": ""
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.20",
"version": "4.20"
},
"NSS": {
"minVersion": "3.41",
"version": "3.41"
},
"NSSUTIL": {
"minVersion": "3.41",
"version": "3.41"
},
"NSSSSL": {
"minVersion": "3.41",
"version": "3.41"
},
"NSSSMIME": {
"minVersion": "3.41",
"version": "3.41"
}
},
"userJS": {
"exists": false
},
"intl": {
"localeService": {
"requested": [
"en-US"
],
"available": [
"en-US"
],
"supported": [
"en-US"
],
"defaultLocale": "en-US"
},
},
"sandbox": {
"hasSeccompBPF": true,
"hasSeccompTSync": true,
"hasPrivilegedUserNamespaces": true,
"hasUserNamespaces": true,
"canSandboxContent": true,
"canSandboxMedia": true,
"syscallLog": [],
"contentSandboxLevel": 4,
"effectiveContentSandboxLevel": 4
},
"graphics": {
"numTotalWindows": 1,
"numAcceleratedWindows": 0,
"windowLayerManagerType": "Basic",
"windowLayerManagerRemote": true,
"windowUsingAdvancedLayers": false,
"numAcceleratedWindowsMessage": [
""
],
"info": {
"AzureCanvasBackend": "skia",
"AzureFallbackCanvasBackend": "none",
"AzureContentBackend": "skia",
"AzureCanvasAccelerated": 0,
"CairoUseXRender": 0,
"ApzWheelInput": 1,
"ApzDragInput": 1,
"ApzKeyboardInput": 1,
"ApzAutoscrollInput": 1
},
"featureLog": {
"features": [
{
"name": "HW_COMPOSITING",
"description": "Compositing",
"status": "blocked",
"log": [
{
"type": "default",
"status": "blocked",
"message": "Acceleration blocked by platform"
}
]
},
{
"name": "OPENGL_COMPOSITING",
"description": "OpenGL Compositing",
"status": "unavailable",
"log": [
{
"type": "default",
"status": "unavailable",
"message": "Hardware compositing is disabled"
}
]
},
{
"name": "WEBRENDER",
"description": "WebRender",
"status": "unavailable",
"log": [
{
"type": "default",
"status": "opt-in",
"message": "WebRender is an opt-in feature"
},
{
"type": "runtime",
"status": "unavailable",
"message": "Hardware compositing is disabled"
}
]
},
{
"name": "WEBRENDER_QUALIFIED",
"description": "WebRender qualified",
"status": "blocked",
"log": [
{
"type": "default",
"status": "available"
},
{
"type": "env",
"status": "blocked",
"message": "No qualified hardware"
}
]
},
{
"name": "OMTP",
"description": "Off Main Thread Painting",
"status": "available",
"log": [
{
"type": "default",
"status": "available"
}
]
}
],
"fallbacks": []
},
"crashGuards": []
},
"extensions": [],
"features": [
{
"name": "Firefox Monitor",
"version": "2.8",
"id": "fxmonitor@mozilla.org"
},
{
"name": "Firefox Screenshots",
"version": "35.0.0",
"id": "screenshots@mozilla.org"
},
{
"name": "Form Autofill",
"version": "1.0",
"id": "formautofill@mozilla.org"
},
{
"name": "Web Compat",
"version": "3.0.0",
"id": "webcompat@mozilla.org"
},
{
"name": "WebCompat Reporter",
"version": "1.1.0",
"id": "webcompat-reporter@mozilla.org"
}
],
"modifiedPreferences": {}
}

cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156057 answers

Chosen Solution

You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page.

  • browser.urlbar.oneOffSearches = false

You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}


It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page. * browser.urlbar.oneOffSearches = false You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css *https://www.userchrome.org/how-create-userchrome-css.html *https://www.userchrome.org/what-is-userchrome-css.html <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* remove all items from the urlbar drop down */ #PopupAutoCompleteRichResult {display:none !important;} </nowiki></pre> ---- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close and restart Firefox when you create or modify the userChrome.css file.
Was this helpful to you? 1
Quote

Question owner

I already had a userChrome.css file from fixing other problems that apparently can't be solved by changing settings in prefs.js (and fortunately, I don't use Windows, so I don't have to deal with its problems on top of Firefox's).

Your solution worked. Thank you SO much!

I already had a userChrome.css file from fixing other problems that apparently can't be solved by changing settings in prefs.js (and fortunately, I don't use Windows, so I don't have to deal with '''its''' problems on top of Firefox's). Your solution worked. Thank you '''SO''' much!
Was this helpful to you?
Quote
support2 0 solutions 4 answers

The browser.urlbar.oneOffSearches = false ALMOST works.

The blue bar is gone as are the suggestions but a empty white bar about ¼ the height of the blue bar still drops down. :(

The browser.urlbar.oneOffSearches = false ALMOST works. The blue bar is gone as are the suggestions but a empty white bar about ¼ the height of the blue bar still drops down. :(
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156057 answers

In Firefox 68 you can use this code to hide the urlbar results drop-down list.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar-results { display:none!important; }
In Firefox 68 you can use this code to hide the urlbar results drop-down list. <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #urlbar-results { display:none!important; } </nowiki></pre>
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.