X
Tap here to go to the mobile version of the site.

Support Forum

turn off address bar search drop down

Posted

How do I turn off that VERY annoying drop down/pop up search thing every time I type in the address bar? I want the search box next to the address bar gone as well. I know where Google is and how to get there in case I need to search. I do not need my browser trying to be Google.

How do I turn off that VERY annoying drop down/pop up search thing every time I type in the address bar? I want the search box next to the address bar gone as well. I know where Google is and how to get there in case I need to search. I do not need my browser trying to be Google.
Attached screenshots

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

Question owner

After searching for quite a while I found

  1. PopupAutoCompleteRichResult {
display: none!important;

}

worked to get rid of the annoying useless junk.

After searching for quite a while I found #PopupAutoCompleteRichResult { display: none!important; } worked to get rid of the annoying useless junk.
McCoy
  • Top 10 Contributor
494 solutions 4531 answers

Hello The Matrix,

Others may like to do it this way :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar browser.urlbar.oneOff

and look for the preference browser.urlbar.oneOffSearches

set its value to false and then close and restart Firefox.


To hide the seach bar at the end of the toolbar :

3-bar menu => Options => Search

Uncheck 'Add searchbar in toolbar'

Hello The Matrix, Others may like to do it this way : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''browser.urlbar.oneOff''' and look for the preference '''browser.urlbar.oneOffSearches ''' set its value to '''false''' and then close and restart Firefox. ------------------------------------------------------------------------------------------- To hide the seach bar at the end of the toolbar : 3-bar menu => Options => Search '''Un'''check 'Add searchbar in toolbar'

Question owner

That did not work but my solution did.

That did not work but my solution did.
McCoy
  • Top 10 Contributor
494 solutions 4531 answers

The Matrix said

That did not work but my solution did.

Good for you to have figured that out - well done  !

Would you please mark your post (the one with the correct answer) as Chosen Solution, so others with the same problem, will know  ?

''The Matrix [[#answer-1193058|said]]'' <blockquote> That did not work but my solution did. </blockquote> Good for you to have figured that out - well done ! Would you please mark your post (the one with the correct answer) as Chosen Solution, so others with the same problem, will know ?
andraste 0 solutions 2 answers

there's two things your have to turn off now to get this to go away

services.sync.prefs.sync.browser.urlbar.maxRichResults

and

browser.urlbar.maxRichResults
there's two things your have to turn off now to get this to go away services.sync.prefs.sync.browser.urlbar.maxRichResults and browser.urlbar.maxRichResults
jscher2000
  • Top 10 Contributor
8578 solutions 70134 answers

The Matrix said

How do I turn off that VERY annoying drop down/pop up search thing every time I type in the address bar?

You can set the height of the drop-down to zero rows this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.maxRichResults preference to display a dialog where you can change the value from 10 to 0 (that's a zero), then click OK

That will eliminate the "blue bar" and search/bookmark/history/open tab suggestions. To remove the search engine buttons section, see the steps in McCoy's post: https://support.mozilla.org/questions/1248449#answer-1192738

I want the search box next to the address bar gone as well.

Hmm, this extra search bar should be hidden by default. To turn it off, you can use the Search panel of the Options page. This article will get you to that setting: Add the Search bar to your Firefox toolbar.

andraste said

there's two things your have to turn off now to get this to go away:
  • services.sync.prefs.sync.browser.urlbar.maxRichResults
  • browser.urlbar.maxRichResults

You do not need to change the corresponding sync preference. That controls whether the value of the preference you changed locally in this Firefox is propagated through Sync to your other Firefoxes you connect to your same Firefox Account. Presumably you want to keep the default value of true so they match the change.

Or is the problem that other Firefoxes do not pick up this change and instead push back a non-zero value?

''The Matrix [[#question-1248449|said]]'' <blockquote> How do I turn off that VERY annoying drop down/pop up search thing every time I type in the address bar? </blockquote> You can set the height of the drop-down to zero rows this way: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.maxRichResults''' preference to display a dialog where you can change the value from 10 to '''0''' (that's a zero), then click OK That will eliminate the "blue bar" and search/bookmark/history/open tab suggestions. To remove the search engine buttons section, see the steps in McCoy's post: https://support.mozilla.org/questions/1248449#answer-1192738 <blockquote>I want the search box next to the address bar gone as well.</blockquote> Hmm, this extra search bar should be hidden by default. To turn it off, you can use the Search panel of the Options page. This article will get you to that setting: [[Add the Search bar to your Firefox toolbar]]. ''andraste [[#answer-1222759|said]]'' <blockquote> there's two things your have to turn off now to get this to go away: * services.sync.prefs.sync.browser.urlbar.maxRichResults * browser.urlbar.maxRichResults </blockquote> You do not need to change the corresponding sync preference. That controls whether the value of the preference you changed locally in this Firefox is propagated through Sync to your other Firefoxes you connect to your same Firefox Account. Presumably you want to keep the default value of true so they match the change. ''Or is the problem that other Firefoxes do not pick up this change and instead push back a non-zero value?''

Modified by jscher2000