X
Tap here to go to the mobile version of the site.

Support Forum

I've been trying to open new pages as separate windows instead of tabs. Please help.

Posted

I unchecked the appropriate boxes, closed and restarted the browser..even rebooted. So far nothing has worked to get it to work properly. What do I do?

I unchecked the appropriate boxes, closed and restarted the browser..even rebooted. So far nothing has worked to get it to work properly. What do I do?

Chosen solution

That fixed it. thank you.

Read this answer in context 0

Additional System Details

Installed Plug-ins

Kaperskey

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

Mick 6 solutions 77 answers

Hello Ashtes,

You can either pick up a tab and pull it off to make it a new window, you can also drag tabs from one window to another.

A shortcut to open a link in a new window is to hold shift + left click the link.

Hello Ashtes, You can either pick up a tab and pull it off to make it a new window, you can also drag tabs from one window to another. A shortcut to open a link in a new window is to hold shift + left click the link.

Modified by Mick

Question owner

I tried that, It didn't work. It just pulls all the tabs together.

I tried that, It didn't work. It just pulls all the tabs together.

Modified by Ashthes

jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Hi Ashthes, there are a couple different kinds of links/buttons:

Links in pages

Normally open in the same tab, but might be coded to open in a new window. Firefox will switch the "new window" links to "new tab" but you can turn that off on the Options page -- uncheck the box for "Open links in tabs instead of new windows".

For links that open in the same tab, you an direct them to a new window using either:

  • right-click > Open Link in New Window
  • Shift+click the link

Which parts of that are not working normally for you?

Built-in pages

The new tab page, the Options page, and various other pages open in new tabs and do not have an option to open in a new window.


I do have an add-on which "detaches" any new tab to its own window. This "breaks" the Customize page, so you need to disable the extension in order to use that feature.

For future reference, you can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then you can manage your extensions on the right side.

Hi Ashthes, there are a couple different kinds of links/buttons: '''Links in pages''' Normally open in the same tab, but might be coded to open in a new window. Firefox will switch the "new window" links to "new tab" but you can turn that off on the Options page -- uncheck the box for "Open links in tabs instead of new windows". For links that open in the same tab, you an direct them to a new window using either: * right-click > Open Link in New Window * Shift+click the link ''Which parts of that are not working normally for you?'' '''Built-in pages''' The new tab page, the Options page, and various other pages open in new tabs and do not have an option to open in a new window. ---- I do have an add-on which "detaches" any new tab to its own window. This "breaks" the Customize page, so you need to disable the extension in order to use that feature. * https://github.com/jscher2000/I-Hate-Tabs---SDI-extension For future reference, you can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then you can manage your extensions on the right side.

Question owner

Normally open in the same tab, but might be coded to open in a new window. Firefox will switch the "new window" links to "new tab" but you can turn that off on the Options page -- uncheck the box for "Open links in tabs instead of new windows".

For links that open in the same tab, you an direct them to a new window using either:

   right-click > Open Link in New Window
   Shift+click the link 

Did all that. It hasn't worked..and I tried your extension. It wouldn't install.

Normally open in the same tab, but might be coded to open in a new window. Firefox will switch the "new window" links to "new tab" but you can turn that off on the Options page -- uncheck the box for "Open links in tabs instead of new windows". For links that open in the same tab, you an direct them to a new window using either: right-click > Open Link in New Window Shift+click the link Did all that. It hasn't worked..and I tried your extension. It wouldn't install.
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

If you Shift+click a link, it opens in a new tab next to the current one instead of in its own window?

Is it possible you have an add-on that forces that? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything related to tabs or link, or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?


Also, sorry for giving you the Github link instead of the Add-ons site link for the "I Hate Tabs" extension:

https://addons.mozilla.org/firefox/addon/i-hate-tabs-sdi-for-firefox/

If the extension won't install from that site, hmm...

If you Shift+click a link, it opens in a new tab next to the current one instead of in its own window? Is it possible you have an add-on that forces that? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything related to tabs or link, or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement? ---- Also, sorry for giving you the Github link instead of the Add-ons site link for the "I Hate Tabs" extension: https://addons.mozilla.org/firefox/addon/i-hate-tabs-sdi-for-firefox/ If the extension won't install from that site, hmm...

Question owner

The only Add ons that I have are Kapersky and yours. I've unchecked the boxes under options that force the tabs over separate windows. So far...nothing has worked.

The only Add ons that I have are Kapersky and yours. I've unchecked the boxes under options that force the tabs over separate windows. So far...nothing has worked.

Modified by Ashthes

jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

When you use the command to create a new window, does that work? Either:

  • "3-bar" menu button > New Window
  • (menu bar) File > New Window
  • Ctrl+n

When you have two tabs in the same window, can you "detach" the second tab by dragging it down over the main toolbar and then releasing the mouse? Then it should move to its own window.

When you use the command to create a new window, does that work? Either: * "3-bar" menu button > New Window * (menu bar) File > New Window * Ctrl+n When you have two tabs in the same window, can you "detach" the second tab by dragging it down over the main toolbar and then releasing the mouse? Then it should move to its own window.

Question owner

Nope, it doesn't work. Is it possibly a setting in the computer control panel that is preventing it?

Nope, it doesn't work. Is it possibly a setting in the computer control panel that is preventing it?
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

I can't think of a system setting to prevent Firefox from moving a second or third tab on the tab bar to a new window. Just to confirm that we're talking about the same thing:


If your Firefox won't detach tabs, and you don't have any add-ons related to tabs, perhaps the program files are damaged. For that we suggest:

Clean Reinstall

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer temporarily before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

I can't think of a system setting to prevent Firefox from moving a second or third tab on the tab bar to a new window. Just to confirm that we're talking about the same thing: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-01-19-09-19-21-4f5c3e.png" width="500"> ---- If your Firefox won't detach tabs, and you don't have any add-ons related to tabs, perhaps the program files are damaged. For that we suggest: '''Clean Reinstall''' This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data. It only takes a few minutes. (A) Download a fresh installer for Firefox to a convenient location: https://www.mozilla.org/firefox/all/ (B) Exit out of Firefox (if applicable). ''If you use '''Microsoft Office''', please change your default browser to Internet Explorer temporarily before the next step.'' (C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both): C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Any improvement?

Question owner

I'm referring to the task bar..not the address bar.

I'm referring to the task bar..not the address bar.

Question owner

Here's a screenshot.

Here's a screenshot.
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Ashthes said

I'm referring to the task bar..not the address bar.

Hi Ashthes, okay, how do you want it to look?

Usually when I hover the Firefox icon on the Windows Taskbar, I get a row of thumbnail images for the first 8-11 windows before Windows switches to showing a list. Is that what you are expecting, too?

There might be a Windows setting for that. Unfortunately, I don't have Windows 7 any more.

''Ashthes [[#answer-1189871|said]]'' <blockquote> I'm referring to the task bar..not the address bar. </blockquote> Hi Ashthes, okay, how do you want it to look? Usually when I hover the Firefox icon on the Windows Taskbar, I get a row of thumbnail images for the first 8-11 windows before Windows switches to showing a list. Is that what you are expecting, too? There might be a Windows setting for that. Unfortunately, I don't have Windows 7 any more.

Question owner

No, I'm wanting to have separate windows..not everything confined to one tab.

No, I'm wanting to have separate windows..not everything confined to one tab.
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Helpful Reply

Do you mean you don't want Windows to group together all the Firefox windows on one Taskbar icon, you want to see a separate taskbar icon for each window?

right-click the Taskbar, then click Properties

Under Taskbar Appearance, for buttons, there's an option to "never combine" taskbar buttons.

See: https://www.groovypost.com/howto/microsoft/prevent-windows-7-from-combining-taskbar-application-icons/

Do you mean you don't want Windows to group together all the Firefox windows on one Taskbar icon, you want to see a separate taskbar icon for each window? right-click the Taskbar, then click Properties Under Taskbar Appearance, for buttons, there's an option to "never combine" taskbar buttons. See: https://www.groovypost.com/howto/microsoft/prevent-windows-7-from-combining-taskbar-application-icons/

Chosen Solution

That fixed it. thank you.

That fixed it. thank you.