X
Tap here to go to the mobile version of the site.

Support Forum

restore information bar prompt to allow popup window

Posted

Citibank uses Adobe Flash in conjunction with a popup window for select services. When confronted with this prompt (option bar to: always open popups for this site/never open/open current window..., I mistakenly (?) clicked the 'never' option. This has resulted in my inability to avail myself of certain services, inasmuch as I no longer see the option bar. Attempted fixes include: . confirm in about:config popup message (ShowMessage) is 'true' . adding Citibank site to blocker 'exceptions' . unchecking 'block popup windows' in permissions

My aim is to restore popup window prompting where applicable, and/or the 'Options' notification bar, blocked by me due to click of wrong option. Can you help?

Citibank uses Adobe Flash in conjunction with a popup window for select services. When confronted with this prompt (option bar to: always open popups for this site/never open/open current window..., I mistakenly (?) clicked the 'never' option. This has resulted in my inability to avail myself of certain services, inasmuch as I no longer see the option bar. Attempted fixes include: . confirm in about:config popup message (ShowMessage) is 'true' . adding Citibank site to blocker 'exceptions' . unchecking 'block popup windows' in permissions My aim is to restore popup window prompting where applicable, and/or the 'Options' notification bar, blocked by me due to click of wrong option. Can you help?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

WestEnd
  • Top 10 Contributor
60 solutions 5190 answers

Did you uninstall adobe flash and reinstall it to see if that restored it?

Did you uninstall adobe flash and reinstall it to see if that restored it?
Was this helpful to you? 0
Quote

Question owner

Thank you - no joy.  :-(

. Uninstalled . Rebooted . Installed . Accessed Citi

Same thing; popup page appears, but blank... (Content issue?)

Thank you - no joy. :-( . Uninstalled . Rebooted . Installed . Accessed Citi Same thing; popup page appears, but blank... (Content issue?)
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

Helpful Reply

Did you check the pop-up setting in "Tools -> Page Info -> Permissions" ?

You should see a special icon on the location/address bar on case pop-ups are present. If you click this icon then you should be able to select whether to show or hide the pop-up info bar.

You can find a Lego block icon at the left end of the location bar indicating that the web page uses the Flash plugin that Firefox might block. You can click this Lego block icon to allow or block Flash.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Did you check the pop-up setting in "Tools -> Page Info -> Permissions" ? You should see a special icon on the location/address bar on case pop-ups are present. If you click this icon then you should be able to select whether to show or hide the pop-up info bar. You can find a Lego block icon at the left end of the location bar indicating that the web page uses the Flash plugin that Firefox might block. You can click this Lego block icon to allow or block Flash. *https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more detail and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking ----- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Was this helpful to you? 1
Quote

Question owner

No luck...

Following steps were taken:

, Block popups set to off! Didn't help

Thanks for your HUGE post, but - I clicked through the (i)nformation button; nothing for me. The page info permissions are all set to 'user default' with the exception of Flash, which is set to 'allow'

You say: "If you click this icon then you should be able to select whether to show or hide the pop-up info bar. " I looked here, and searched my privacy settings and don't find this. Care to send me the verbiage I'm looking for?

Finally, the issue of no info bar is probably the cause of all my problems. If as you say, I can get it back? I presume I'd be set...

Again, THANK YOU!

No luck... Following steps were taken: , Block popups set to off! Didn't help Thanks for your HUGE post, but - I clicked through the (i)nformation button; nothing for me. The page info permissions are all set to 'user default' with the exception of Flash, which is set to 'allow' You say: "If you click this icon then you should be able to select whether to show or hide the pop-up info bar. " I looked here, and searched my privacy settings and don't find this. Care to send me the verbiage I'm looking for? Finally, the issue of no info bar is probably the cause of all my problems. If as you say, I can get it back? I presume I'd be set... Again, THANK YOU!
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

Did you try to open a page that would open a pop-up window?

That should give you a pop-up block icon on the location/address bar.

Did you try to open a page that would open a pop-up window? That should give you a pop-up block icon on the location/address bar. *https://support.mozilla.org/en-US/kb/pop-blocker-settings-exceptions-troubleshooting
Was this helpful to you?
Quote

Question owner

As to the article? Read and e-read 100 times already!  :-)

Firefox must offer a sample popup page with its associated message (info bar with 'options') I found when visiting a utility bill-payment site that a blank page was rendered, no infi bar, you know - just like Citibank  :-(

As to the article? Read and e-read 100 times already! :-) Firefox must offer a sample popup page with its associated message (info bar with 'options') I found when visiting a utility bill-payment site that a blank page was rendered, no infi bar, you know - just like Citibank :-(
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

I referenced the article because of the special pop-up block icon in the location/address bar. This icon is only present when the website wants to open a pop-up. If you click this icon then you can enable/disable the info bar via the drop-down menu.

I referenced the article because of the special pop-up block icon in the location/address bar. This icon is only present when the website wants to open a pop-up. If you click this icon then you can enable/disable the info bar via the drop-down menu.
Was this helpful to you?
Quote

Question owner

Gosh, last thing I want to do is frustrate you. You got no idea how grateful I am!

Anyway, I'm attaching the image of the address bar (oddly the form that pops this up has 'Run Adobe lash; in its site info/permissions. Why is the 'lego' icon even appearing???) So, can you tell me if I'm showing the right icon? If so, can you point out to me which one it is?

Gosh, last thing I want to do is frustrate you. You got no idea how grateful I am! Anyway, I'm attaching the image of the address bar (oddly the form that pops this up has 'Run Adobe lash; in its site info/permissions. Why is the 'lego' icon even appearing???) So, can you tell me if I'm showing the right icon? If so, can you point out to me which one it is?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

Sorry about the confusion.

I did some testing and the only way to restore the yellow info bar is to reset the pref toi true on the about:config page.

  • privacy.popups.showBrowserMessage = true

The Control Center 'i' icon disabled menu only shows that there are pop-ups blocked when it shows blocked pop-ups.

Sorry about the confusion. I did some testing and the only way to restore the yellow info bar is to reset the pref toi true on the <b>about:config</b> page. *privacy.popups.showBrowserMessage = true The Control Center 'i' icon disabled menu only shows that there are pop-ups blocked when it shows blocked pop-ups.

Modified by cor-el

Was this helpful to you?
Quote

Question owner

Sorry, but that option is already set (attached)

Sorry, but that option is already set (attached)
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

Are you sure you are on a page that opens a pop-up?

If that is the case then you should see the special icon that shows in my last screenshot.

What does this test page show?

Are you sure you are on a page that opens a pop-up? If that is the case then you should see the special icon that shows in my last screenshot. What does this test page show? *http://www.kephyr.com/popupkillertest/test/test1.html *http://www.kephyr.com/popupkillertest/test/test7.html *http://www.kephyr.com/popupkillertest/test/test18.html
Was this helpful to you?
Quote

Question owner

Here's feedback:

Link #1 - info bar appears and via 'options' I can open the bad popup Links 2 & 3 - same result as 1, but - and this is odd! - I appear to get *2* options to 'show', and they are exact duplicates of each other!

Here's feedback: Link #1 - info bar appears and via 'options' I can open the bad popup Links 2 & 3 - same result as 1, but - and this is odd! - I appear to get *2* options to 'show', and they are exact duplicates of each other!
Was this helpful to you?
Quote

Question owner

In case youb don't believe me, see attachment...

In case youb don't believe me, see attachment...
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

That should be as expected, so the info bar is working properly.

What is different on the page for which you initially created this question?

The screenshot shows you have extensions installed that can block content and such extensions will prevent the Firefox pop-up blocker from getting active.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked

That should be as expected, so the info bar is working properly. What is different on the page for which you initially created this question? The screenshot shows you have extensions installed that can block content and such extensions will prevent the Firefox pop-up blocker from getting active. ---- If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more detail and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking
Was this helpful to you?
Quote

Question owner

Thank you very much, way too much to test on one foot. I figure tom'w morning to start with the 'web-dev' stuff and in turn spare me having to validate/disable plugins etc, Funny though - looked at Adblock and couldn't find a version update checker or tool (!)

P.S. I take it you're okay with the double-stuff in my previous message (includes pic), huh?

Good night, hope to post results tomorrow MORN...

Thank you very much, way too much to test on one foot. I figure tom'w morning to start with the 'web-dev' stuff and in turn spare me having to validate/disable plugins etc, Funny though - looked at Adblock and couldn't find a version update checker or tool (!) P.S. I take it you're okay with the double-stuff in my previous message (includes pic), huh? Good night, hope to post results tomorrow MORN...
Was this helpful to you?
Quote

Question owner

Quick review:

1. Never had a problem before. (As a matter of fact, I'm running v. 64 in a VM to get this functionality 2. First time requesting the feature in 64.0.2 the bar showed (no flippin' idea why as I had authorized popups ALWAYS before). Having forgotten that the 'Always' choice should have been made, I supposedly clicked on the 'Show' this; but seems I must have clicked the 'Never show' by mistake 3. Ever since then, when I enter the 'Launch' page (see image) , a BLANK popup is generated - *** BEFORE I EVEN CLICK THE LAUNCH BUTTON! ***


So here I am with 2 simple questions. . How do I get back my info bar - even if I errantly chose to NEVER view a popup at this site? . Why, o' why, doesn't turning off the blocker resolve my issue?

Now that my case is hopefully clear, I'm going to try your recommendations of last night...

Quick review: 1. Never had a problem before. (As a matter of fact, I'm running v. 64 in a VM to get this functionality 2. First time requesting the feature in 64.0.2 the bar showed (no flippin' idea why as I had authorized popups ALWAYS before). Having forgotten that the 'Always' choice should have been made, I supposedly clicked on the 'Show' this; but seems I must have clicked the 'Never show' by mistake 3. Ever since then, when I enter the 'Launch' page (see image) , a BLANK popup is generated - *** BEFORE I EVEN CLICK THE LAUNCH BUTTON! *** ---- So here I am with 2 simple questions. . How do I get back my info bar - even if I errantly chose to NEVER view a popup at this site? . Why, o' why, doesn't turning off the blocker resolve my issue? Now that my case is hopefully clear, I'm going to try your recommendations of last night...
Was this helpful to you?
Quote

Question owner

Latest attempt ended in failure. Disabled EVERY extension (Adblock+, HTTPS Everywhere, WOT, YesScript2) in the hope it's an extension problem. No dice.

Would you have any other suggestions or ideas?

Latest attempt ended in failure. Disabled EVERY extension (Adblock+, HTTPS Everywhere, WOT, YesScript2) in the hope it's an extension problem. No dice. Would you have any other suggestions or ideas?
Was this helpful to you?
Quote

Question owner

Seems no solution to my problem(s)? Not gonna 'refresh', I'd rather do a FULL uninstall and reinstall. Goes against fanboi mentality, but I'm a realist. I can save bookmarks, but history? About:config exceptions? Extension? Gimme a break - they couldn't make it harder if they tried!

So I'm here to inform anyone interested that v. 65 did not resolve the issue - and eagerly await a solution over the next 24 hours...

Seems no solution to my problem(s)? Not gonna 'refresh', I'd rather do a FULL uninstall and reinstall. Goes against fanboi mentality, but I'm a realist. I can save bookmarks, but history? About:config exceptions? Extension? Gimme a break - they couldn't make it harder if they tried! So I'm here to inform anyone interested that v. 65 did not resolve the issue - and eagerly await a solution over the next 24 hours...
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.