X
Tap here to go to the mobile version of the site.

Support Forum

Cannot turn off Paragraph Format in newest update

Posted

Just updated to Thunderbird 60.4.0 It is defaulting to using the Paragraph format when composing emails. I have no idea why anyone would want double spacing between lines every time you press enter in an email but that is beside the point. I have read other postings of people with this same problem and none of them appear to have it solved either. FYI, I am using Windows 8.1 with all the most recent updates.

1. Went into Option / Options / Composition. Unchecked "Use Paragraph Format". Exited and re-started TB. Setting goes back to being checked. 2. Went into Advanced and opened the Config Editor. Changed mail.compose.default_to_paragraph to FALSE. Exited config editor, exited TB, re-started TB. Setting goes back to TRUE.

I also tried running TB (and config editor) as administrator and it does the same thing. Always goes back to Paragraph format.

I read a posting that talked about editing json files (question #1244949) but I have not bothered to mess with that since that person said it did not fix the problem... On top of that, users should not have to edit json & ini files if the Option settings would work properly in the first place. I am happy to provide any assistance or system information to help resolve the issue. Thank you.

Just updated to Thunderbird 60.4.0 It is defaulting to using the Paragraph format when composing emails. I have no idea why anyone would want double spacing between lines every time you press enter in an email but that is beside the point. I have read other postings of people with this same problem and none of them appear to have it solved either. FYI, I am using Windows 8.1 with all the most recent updates. 1. Went into Option / Options / Composition. Unchecked "Use Paragraph Format". Exited and re-started TB. Setting goes back to being checked. 2. Went into Advanced and opened the Config Editor. Changed mail.compose.default_to_paragraph to FALSE. Exited config editor, exited TB, re-started TB. Setting goes back to TRUE. I also tried running TB (and config editor) as administrator and it does the same thing. Always goes back to Paragraph format. I read a posting that talked about editing json files (question #1244949) but I have not bothered to mess with that since that person said it did not fix the problem... On top of that, users should not have to edit json & ini files if the Option settings would work properly in the first place. I am happy to provide any assistance or system information to help resolve the issue. Thank you.

Chosen solution

SOLVED... So here is what I have found and done to resolve this problem. In folder: c:/Users/{myusername}/AppData/Roaming/Thunderbird/Profiles/{some obscure folder id} There is a file named prefs.js where the preferences are stored. The preference that is being a problem here is: user_pref("mail.compose.default_to_paragraph", false); HOWEVER.... this setting is NOT in my pref.js file. And if I put it in manually then start TB then the setting gets removed from the .js file. Best guess is this is a UAC issue. So, since my setup is fairly simple, I deleted this entire folder: c:/Users/{myusername}/AppData/Roaming/Thunderbird Which forced TB to create all new setting files. I needed to put in all my account information again as if it were a new install. But now, the Paragraph setting IS in the .js file. And when the setting is changed in Options it now behaves properly.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

Matt
  • Top 10 Contributor
  • Moderator
3138 solutions 21365 answers

I open the options and check the setting. Go to the write button and click. Write window opens with paragraph selected. go back turn the option of click write. Body text is selected.

Does this not work for you? If not I suggest you try starting Thunderbird with add-ons disabled from the help menu and see if it is still an issue. Often setting that do not stay set are caused by add-ons that do not work well. Or did not cope with a program update and need to be updated for a new version.

I open the options and check the setting. Go to the write button and click. Write window opens with paragraph selected. go back turn the option of click write. Body text is selected. Does this not work for you? If not I suggest you try starting Thunderbird with add-ons disabled from the help menu and see if it is still an issue. Often setting that do not stay set are caused by add-ons that do not work well. Or did not cope with a program update and need to be updated for a new version.
Was this helpful to you?
Quote

Question owner

I realize that I can change from Paragraph mode to BodyText mode once I have opened a new email. That is not the issue. It is the "Use Paragraph Format" setting in the options that is not behaving properly. Once the box is unchecked, it will not STAY unchecked. The box is "magically" checked again the next time you start TB.

I do not have any add-ons installed and never have.

I realize that I can change from Paragraph mode to BodyText mode once I have opened a new email. That is not the issue. It is the "Use Paragraph Format" setting in the options that is not behaving properly. Once the box is unchecked, it will not STAY unchecked. The box is "magically" checked again the next time you start TB. I do not have any add-ons installed and never have.
Was this helpful to you?
Quote

Chosen Solution

SOLVED... So here is what I have found and done to resolve this problem. In folder: c:/Users/{myusername}/AppData/Roaming/Thunderbird/Profiles/{some obscure folder id} There is a file named prefs.js where the preferences are stored. The preference that is being a problem here is: user_pref("mail.compose.default_to_paragraph", false); HOWEVER.... this setting is NOT in my pref.js file. And if I put it in manually then start TB then the setting gets removed from the .js file. Best guess is this is a UAC issue. So, since my setup is fairly simple, I deleted this entire folder: c:/Users/{myusername}/AppData/Roaming/Thunderbird Which forced TB to create all new setting files. I needed to put in all my account information again as if it were a new install. But now, the Paragraph setting IS in the .js file. And when the setting is changed in Options it now behaves properly.

SOLVED... So here is what I have found and done to resolve this problem. In folder: c:/Users/{myusername}/AppData/Roaming/Thunderbird/Profiles/{some obscure folder id} There is a file named prefs.js where the preferences are stored. The preference that is being a problem here is: user_pref("mail.compose.default_to_paragraph", false); HOWEVER.... this setting is NOT in my pref.js file. And if I put it in manually then start TB then the setting gets removed from the .js file. Best guess is this is a UAC issue. So, since my setup is fairly simple, I deleted this entire folder: c:/Users/{myusername}/AppData/Roaming/Thunderbird Which forced TB to create all new setting files. I needed to put in all my account information again as if it were a new install. But now, the Paragraph setting IS in the .js file. And when the setting is changed in Options it now behaves properly.
Was this helpful to you? 1
Quote
j-and-d 0 solutions 5 answers

I entered a user pref for mail.compose.default_to_paragraph: user_pref("mail.compose.default_to_paragraph", false); and it has no effect. Restarting Thunderbird still resets the default. I am reluctant to delete the settings files! Running 60.6.1 on MacOS

I entered a user pref for mail.compose.default_to_paragraph: user_pref("mail.compose.default_to_paragraph", false); and it has no effect. Restarting Thunderbird still resets the default. I am reluctant to delete the settings files! Running 60.6.1 on MacOS
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.