Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

At least once a week, Firefox changes my default search engine and my default homepage. How can I prevent this from happening. I am not changing these.

  • 7 replies
  • 1 has this problem
  • 71 views
  • Last reply by jbszumow

more options

When this happens, I must go into preferences and change these back to what I want. I am using the "remove" search engine button but obviously it is not a permanent change. I manually type in the homepage, but it is not a permanent change either.

Chosen solution

Hello jbszumow,

It's browser hijacking malware.

To fix this issue you:

Read this answer in context 👍 1

All Replies (7)

more options

What is the default search engine and default homepage getting changed to?

more options

The default homepage was changed to: https://goto-searchitnow.global.ssl.fastly.net/

and the default search engine was changed to: https://www.bing.com/

more options

This happened again today, same as the post on 1/14/19

more options

Chosen Solution

Hello jbszumow,

It's browser hijacking malware.

To fix this issue you:

Modified by Mick

more options

Thank you! I completed the above steps and will see if it happens again.

more options

If this turns out to have fixed your problem please mark the reply that solved your problem as the solution :)

Modified by Mick

more options

Thanks again, the steps I followed that you gave me solved the problem. It has not happened again in 2 weeks time!