X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How to stop right shift from opening a new window when searching in url/address/omnibar?

Posted

I tend to accidentally hit right shift when I hit enter when searching in the url/address/omnibar. Right Shift + Enter to open a new window wasn't a problem in the past and a new window was opened only if Left + Shift was pressed if I remember correctly. How does one disable the Right Shift + Enter key combination to open a new window when searching in the url/address/omnibar and where and when was the source code changed to allow it?

I tend to accidentally hit right shift when I hit enter when searching in the url/address/omnibar. Right Shift + Enter to open a new window wasn't a problem in the past and a new window was opened only if Left + Shift was pressed if I remember correctly. How does one disable the Right Shift + Enter key combination to open a new window when searching in the url/address/omnibar and where and when was the source code changed to allow it?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

Noah_SUMO
  • Moderator
98 solutions 606 answers

Helpful Reply

I think this change was caused by the fix for this bug: Bug 237027 - Use ctrl-enter for URL canonization on all platform, and offer an opt-out for Windows/Linux users where it interferes with opening URLs in (background) tabs

If you read the last few comments, it should explain why the behavior was changed. As far as locking down that keyboard combo, I'll see if there's a way to disable it.

I think this change was caused by the fix for this bug: [https://bugzilla.mozilla.org/show_bug.cgi?id=237027 Bug 237027 - Use ctrl-enter for URL canonization on all platform, and offer an opt-out for Windows/Linux users where it interferes with opening URLs in (background) tabs] If you read the last few comments, it should explain why the behavior was changed. As far as locking down that keyboard combo, I'll see if there's a way to disable it.
Was this helpful to you? 2
Quote

Question owner

Thank you for directing me there. However, I am failing to find the piece code that directly states that shift + enter is causing a new window to open in the latest patch assuming the functionality isn't implicit via somewhere else. I created https://bugzilla.mozilla.org/show_bug.cgi?id=1516883 in the meantime.

Thank you for directing me there. However, I am failing to find the piece code that directly states that shift + enter is causing a new window to open in the latest patch assuming the functionality isn't implicit via somewhere else. I created https://bugzilla.mozilla.org/show_bug.cgi?id=1516883 in the meantime.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17087 solutions 154328 answers

Helpful Reply

See also: _whereToOpen: https://dxr.mozilla.org/mozilla-release/source/browser/components/urlbar/UrlbarController.jsm#356 _whereToOpen: https://dxr.mozilla.org/mozilla-release/source/browser/base/content/urlbarBindings.xml#598
Was this helpful to you? 1
Quote

Question owner

I have created a patch to resolve this issue and have appended to https://bugzilla.mozilla.org/show_bug.cgi?id=1516883.

I have created a patch to resolve this issue and have appended to https://bugzilla.mozilla.org/show_bug.cgi?id=1516883.
Was this helpful to you?
Quote
David Spector 1 solutions 24 answers

There are many postings here and elsewhere about this new bug.

I have tried to drag the orphan tab back to the window it came from, and it snaps back to remain an orphan. This is the usual "solution" by the experts.

Note that the addon to fix this bug also does not work.

If it is impossible to fix this bug, please provide an option for preventing tabs from being detached to form new windows. This is NOT the same as the existing option to prevent opening new tabs in windows.

Thank you for fixing bugs promptly! This is more important than adding new features!

There are '''many '''postings here and elsewhere about this '''new bug'''. I have tried to drag the orphan tab back to the window it came from, and it snaps back to remain an orphan. This is the usual "solution" by the experts. Note that the addon to fix this bug also '''does not work'''. If it is impossible to fix this bug, please provide an option for preventing tabs from being detached to form new windows. This is '''NOT '''the same as the '''existing''' option to prevent opening new tabs in windows. Thank you for fixing bugs promptly! '''This is more important than adding new features!'''
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.