X
Tap here to go to the mobile version of the site.

Support Forum

Thunderbird not sending emails

Posted

I am using IMAP. AT&T (Yahoo) is my ISP. I just recently changed my password, not sure if that is causing problems. I am using Windows 7.

After composing an email, I try to send it. What I get is a popup saying Login to Server failed. See the uploaded image. The popup has three choices: Retry, Enter New Password, Cancel. When I click either Retry or Enter New Password, the popup just reappears, no matter how many times I click on Retry or Enter New Password. If I click on Cancel, the sendmail completes by making a copy of the email and putting it in my Sent folder.

Suggestions?

I am using IMAP. AT&T (Yahoo) is my ISP. I just recently changed my password, not sure if that is causing problems. I am using Windows 7. After composing an email, I try to send it. What I get is a popup saying Login to Server failed. See the uploaded image. The popup has three choices: Retry, Enter New Password, Cancel. When I click either Retry or Enter New Password, the popup just reappears, no matter how many times I click on Retry or Enter New Password. If I click on Cancel, the sendmail completes by making a copy of the email and putting it in my Sent folder. Suggestions?
Attached screenshots

Chosen solution

Hi Matt,

I changed my server names from yahoo.com to att.net and that seems to have fixed the problem.

Thanks for the head's up on passwords in the future.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

Toad-Hall
  • Top 10 Contributor
1739 solutions 11617 answers

Did you update Thunderbird with the new password?

  • Menu icon > Options > Security > 'Passwords' tab
  • click on 'Saved Passwords' button
  • click on 'Show passwords' button

Are passwords correct ? You will see an smtp line for the mail account. right click on that line and select 'Edit Password' Completely clear what is entered and retype the correct password - it is case sensitive. click on all OKs'

Restart Thunderbird

Did you update Thunderbird with the new password? * Menu icon > Options > Security > 'Passwords' tab * click on 'Saved Passwords' button * click on 'Show passwords' button Are passwords correct ? You will see an smtp line for the mail account. right click on that line and select 'Edit Password' Completely clear what is entered and retype the correct password - it is case sensitive. click on all OKs' Restart Thunderbird

Modified by Toad-Hall

Question owner

I don't use the Saved Passwords function in Thunderbird. Whenever I start Thunderbird, I enter the password from memory and it starts just fine.

I don't use the Saved Passwords function in Thunderbird. Whenever I start Thunderbird, I enter the password from memory and it starts just fine.
sfhowes
  • Top 10 Contributor
1498 solutions 7088 answers

It might work better if you use a secure mail key, but in that case you would probably want to store the password in Options.

https://support.mozilla.org/en-US/questions/1225036

It might work better if you use a secure mail key, but in that case you would probably want to store the password in Options. https://support.mozilla.org/en-US/questions/1225036

Question owner

So here's the deal. When I try to send an email from Thunderbird, the popup appears giving me the three choices: Retry, Enter New Password, and Cancel. When I click on Enter New Password, the popup goes away then instantaneously comes back. I am not given the option to enter my password. That has got to be a Thunderbird bug, right?

When I click on Retry, the same thing happens - the popup disappears and instantaneously re-appears, as if it thinks my password is bad. Why does TB think my password is bad?

When I click on Cancel, it does not cancel!! TB proceeds to write the email to my Sent folder when it did not send it! That has got to be a Thunderbird bug, right?

So here's the deal. When I try to send an email from Thunderbird, the popup appears giving me the three choices: Retry, Enter New Password, and Cancel. When I click on Enter New Password, the popup goes away then instantaneously comes back. I am not given the option to enter my password. That has got to be a Thunderbird bug, right? When I click on Retry, the same thing happens - the popup disappears and instantaneously re-appears, as if it thinks my password is bad. Why does TB think my password is bad? When I click on Cancel, it does not cancel!! TB proceeds to write the email to my Sent folder when it did not send it! That has got to be a Thunderbird bug, right?
Matt
  • Top 10 Contributor
  • Moderator
3234 solutions 22201 answers

Helpful Reply

Your mail provider says you should be using a different outgoing server name. https://www.att.com/esupport/article.html#!/dsl-high-speed/KM1010523?gsi=U3S7gJ0

However using the server you are, you can use oAuth authentication with the SMTP server and I suggest you try that first.

Note this part very very well. Your provider ATT/Yahoo is forcing the local storage of passwords into the future with either oAuth or their mail key. Neither has a password you can actually remember to enter (Unless you have an eidetic memory). oAuth uses tokens like cookies and the mail key uses an auto generated key of about 12 digits.

Your mail provider says you should be using a different outgoing server name. https://www.att.com/esupport/article.html#!/dsl-high-speed/KM1010523?gsi=U3S7gJ0 However using the server you are, you can use oAuth authentication with the SMTP server and I suggest you try that first. Note this part very very well. Your provider ATT/Yahoo is forcing the local storage of passwords into the future with either oAuth or their mail key. Neither has a password you can actually remember to enter (Unless you have an eidetic memory). oAuth uses tokens like cookies and the mail key uses an auto generated key of about 12 digits.

Modified by Matt

Chosen Solution

Hi Matt,

I changed my server names from yahoo.com to att.net and that seems to have fixed the problem.

Thanks for the head's up on passwords in the future.

Hi Matt, I changed my server names from yahoo.com to att.net and that seems to have fixed the problem. Thanks for the head's up on passwords in the future.