Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open two firefox windows and it tries to open links from external programs in new window.

  • 9 replies
  • 1 has this problem
  • 777 views
  • Last reply by FO0BAR

more options

So every time I try to open a new firefox window i get this error message: Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window.

This wouldn't be that big of a deal by itself but the browser opens links from programs like Slack etc. in a new window, which means I have to close my current window in order to view the link.

I tried reinstalling with Revo uninstaller but is't still the same. I used FF in the past and didn't have this problem.

Chosen solution

If you simply left-click a link then browser.link.open_newwindow.override.external should apply and determine what is happening.

Are you running Firefox in Private Browsing mode?

Check the target field in the Firefox desktop shortcut and make sure you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables). If you have a MOZ_NO_REMOTE environment variable then remove this variable and do not change its value to 0 because that doesn't work (Firefox checks for its existence and not the value).

Read this answer in context 👍 1

All Replies (9)

more options

Hi FO0BAR, when you launch a new Firefox window, what should happen is that Firefox opens the window in that same running session. There may be a problem with either the setting for handling external URLs or external HTML files, or with the shortcut you use to start Firefox.

What method are you using to open a new window? I'm assuming either double-clicking a desktop shortcut, or using some feature of a Windows Taskbar icon??

Is the shortcut you use to start Firefox customized? You can check that here:

First, open the shortcut properties as follows:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On Windows, that usually is no more and no less than one of the following (depending on 32-bit/64-bit):

"C:\Program Files\Mozilla Firefox\firefox.exe"
"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If anything follows after that, do you recall entering that there?

If yes: What is the customization?

If no:" If not, try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that the Firefox shortcut now launches only your desired home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox

Success?

more options

There are other things that need attention.

The System Details list shows that you have an outdated Flash plugin, current is 32.0.0.101 (32.0 r0).

  • Shockwave Flash 22.0 r0

You can find the installation path of a plugin on the about:plugins page.

You can download the latest NPAPI Flash plugin for Firefox on this page.

Make sure to remove checkmarks for including unwanted additional software.

more options

See also this pref on the about:config page.

  • browser.link.open_newwindow.override.external (default = -1 -> browser.link.open_newwindow)

See this article about the value of this pref:

more options

jscher2000 said

What method are you using to open a new window? I'm assuming either double-clicking a desktop shortcut, or using some feature of a Windows Taskbar icon??


I tried to open from start menu, taskbar, desktop, makes no difference. jscher2000 said

Is the shortcut you use to start Firefox customized?

No, it was all clean.

Modified by FO0BAR

more options

cor-el said

See also this pref on the about:config page.
  • browser.link.open_newwindow.override.external (default = -1 -> browser.link.open_newwindow)
See this article about the value of this pref:

I changed the values multiple times but it had no effect.

more options

How are you opening the links?

Are you double-clicking a link in an external application or dragging links to a Firefox shortcut or Firefox window or different?

more options

cor-el said

How are you opening the links? Are you double-clicking a link in an external application or dragging links to a Firefox shortcut or Firefox window or different?

Just single clicking.

more options

Chosen Solution

If you simply left-click a link then browser.link.open_newwindow.override.external should apply and determine what is happening.

Are you running Firefox in Private Browsing mode?

Check the target field in the Firefox desktop shortcut and make sure you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables). If you have a MOZ_NO_REMOTE environment variable then remove this variable and do not change its value to 0 because that doesn't work (Firefox checks for its existence and not the value).

more options

cor-el said

If you simply left-click a link then browser.link.open_newwindow.override.external should apply and determine what is happening. Are you running Firefox in Private Browsing mode? Check the target field in the Firefox desktop shortcut and make sure you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables). If you have a MOZ_NO_REMOTE environment variable then remove this variable and do not change its value to 0 because that doesn't work (Firefox checks for its existence and not the value).

Thanks so much, it fixed both issues and now everything works perfectly.