X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 61/64 cannot find shared library libatomic.so.1

Posted

I am running Ubuntu 15.10 on a 12 year olf DELL laptop and use Firefox 61. With the latest update or if I install Firefox 64 it stops working with the error message /home/smoehler/firefox/firefox: error while loading shared libraries: libatomic.so.1: cannot open shared object file: No such file or directory

Can I fix this and if so, how?

I am running Ubuntu 15.10 on a 12 year olf DELL laptop and use Firefox 61. With the latest update or if I install Firefox 64 it stops working with the error message /home/smoehler/firefox/firefox: error while loading shared libraries: libatomic.so.1: cannot open shared object file: No such file or directory Can I fix this and if so, how?

Chosen solution

I think that Firefox 63 and later require libatomic. Maybe try the support website of your distribution to see if they can help you with this. Otherwise you would have to upgrade to newer Linux version or possibly stay with Firefox 60 ESR to use a Firefox version that is still supported with updates.

Read this answer in context 1

Additional System Details

Application

  • Firefox 61.0.1
  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:61.0) Gecko/20100101 Firefox/61.0
  • Support URL: https://support.mozilla.org/1/firefox/61.0.1/Linux/en-US/

Extensions

  • Google Analytics Opt-out Add-on (by Google) 1.0.7 ({6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65})
  • Ubuntu Modifications 3.2 (ubufox@ubuntu.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) 945GM x86/MMX/SSE2
  • adapterDeviceID: Mesa DRI Intel(R) 945GM x86/MMX/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • contentUsesTiling: False
  • crashGuards: []
  • driverDate:
  • driverVersion: 1.4 Mesa 11.0.2
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'disabled', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: FEATURE_FAILURE_OPENGL_1 * Exhausted GL driver options.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OPENGL_1
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers
From 61 to 64 did you update to the 64bit version of Firefox? https://askubuntu.com/questions/409310/error-while-loading-shared-libraries-cannot-open-shared-object-file-no-such-fi may help.

Question owner

Good question - I did not change consciously to 64-bit but this might be the default. Is there a way to avoid that change but still update firefox? My case seems to be the opposite of the link you mention - as far as I can tell I have a 32-bit operating system but firefox expects 64-bit.

Good question - I did not change consciously to 64-bit but this might be the default. Is there a way to avoid that change but still update firefox? My case seems to be the opposite of the link you mention - as far as I can tell I have a 32-bit operating system but firefox expects 64-bit.
cor-el
  • Top 10 Contributor
  • Moderator
17410 solutions 157269 answers

Helpful Reply

Did you check in Ubuntu software management whether you have the libatomic package (library) installed?

Current Firefox releases are linked to this library.

Did you check in Ubuntu software management whether you have the libatomic package (library) installed? Current Firefox releases are linked to this library.
guigs 1072 solutions 11697 answers

Helpful Reply

Corel makes a very good point and I think you found the issue. Since the library is a missmatch on 32/64 library type, you need the 64 bit version of libaio (I am not an expert on how to do that with Ububutu 32) or you find the 32 bit version of Firefox for your operating system. I am not sure if that is available?

Did you use this to install all the Firefox packages? https://help.ubuntu.com/community/FirefoxNewVersion

Library paths I found: https://packages.ubuntu.com/trusty/amd64/libatomic1/filelist is what they look like.

Corel makes a very good point and I think you found the issue. Since the library is a missmatch on 32/64 library type, you need the 64 bit version of libaio (I am not an expert on how to do that with Ububutu 32) or you find the 32 bit version of Firefox for your operating system. I am not sure if that is available? Did you use this to install all the Firefox packages? https://help.ubuntu.com/community/FirefoxNewVersion Library paths I found: https://packages.ubuntu.com/trusty/amd64/libatomic1/filelist is what they look like.
James
  • Moderator
1594 solutions 11229 answers

SabineMoehler said

Good question - I did not change consciously to 64-bit but this might be the default. Is there a way to avoid that change but still update firefox? My case seems to be the opposite of the link you mention - as far as I can tell I have a 32-bit operating system but firefox expects 64-bit.

Are you using the Ubuntu supplied Firefox package or the Firefox tarbal from www.mozilla.org/firefox/all as 32-bit Linux is listed there.

If you use the build from Mozilla just create a Firefox folder in /Home/ and extract the archive in said folder. Then you can create a desktop and or panel shortcut to the firefox script.

''SabineMoehler [[#answer-1182681|said]]'' <blockquote> Good question - I did not change consciously to 64-bit but this might be the default. Is there a way to avoid that change but still update firefox? My case seems to be the opposite of the link you mention - as far as I can tell I have a 32-bit operating system but firefox expects 64-bit. </blockquote> Are you using the Ubuntu supplied Firefox package or the Firefox tarbal from www.mozilla.org/firefox/all as 32-bit Linux is listed there. If you use the build from Mozilla just create a Firefox folder in /Home/ and extract the archive in said folder. Then you can create a desktop and or panel shortcut to the firefox script.

Question owner

Wow - I am feeling a bit (positively) overwhelmed by that much attention to my problem. Let me try to answer:

I do not have libatomic installed and I could not install it with apt-get --fix-missing install libatomic1 WARNING: The following packages cannot be authenticated!

 libatomic1

Install these packages without verification? [y/N] y Err http://us.archive.ubuntu.com/ubuntu/ wily/main libatomic1 i386 5.2.1-22ubuntu2

 404  Not Found [IP: 2001:67c:1562::19 80]

E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/g/gcc-5/libatomic1_5.2.1-22ubuntu2_i386.deb 404 Not Found [IP: 2001:67c:1562::19 80]

E: Internal Error, ordering was unable to handle the media swap Then I downloaded the 32-bit version of firefox-64 but that gives me the same error cocnerning libatomic. So the crucial point seems really to be that missing library, which apparently was not needed in older version of firefox-61, but which I cannot install (at least not as libatomic1, libatomic-ops-dev.

My apologies if my questions are on an extremely basic level and if I may be missing some point you made.

Wow - I am feeling a bit (positively) overwhelmed by that much attention to my problem. Let me try to answer: I do not have libatomic installed and I could not install it with ''apt-get --fix-missing install libatomic1 WARNING: The following packages cannot be authenticated! libatomic1 Install these packages without verification? [y/N] y Err http://us.archive.ubuntu.com/ubuntu/ wily/main libatomic1 i386 5.2.1-22ubuntu2 404 Not Found [IP: 2001:67c:1562::19 80] E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/g/gcc-5/libatomic1_5.2.1-22ubuntu2_i386.deb 404 Not Found [IP: 2001:67c:1562::19 80] E: Internal Error, ordering was unable to handle the media swap '' Then I downloaded the 32-bit version of firefox-64 but that gives me the same error cocnerning libatomic. So the crucial point seems really to be that missing library, which apparently was not needed in older version of firefox-61, but which I cannot install (at least not as libatomic1, libatomic-ops-dev. My apologies if my questions are on an extremely basic level and if I may be missing some point you made.
cor-el
  • Top 10 Contributor
  • Moderator
17410 solutions 157269 answers

Chosen Solution

I think that Firefox 63 and later require libatomic. Maybe try the support website of your distribution to see if they can help you with this. Otherwise you would have to upgrade to newer Linux version or possibly stay with Firefox 60 ESR to use a Firefox version that is still supported with updates.

I think that Firefox 63 and later require libatomic. Maybe try the support website of your distribution to see if they can help you with this. Otherwise you would have to upgrade to newer Linux version or possibly stay with Firefox 60 ESR to use a Firefox version that is still supported with updates. *https://www.mozilla.org/en-US/firefox/organizations/all/
James
  • Moderator
1594 solutions 11229 answers

SabineMoehler said

I am running Ubuntu 15.10...

Support for Ubuntu 15.10 ended July 28 2016. http://fridge.ubuntu.com/2016/07/28/ubuntu-15-10-wily-werewolf-end-of-life-reached-on-july-28-2016/

''SabineMoehler [[#question-1243962|said]]'' <blockquote> I am running Ubuntu 15.10... </blockquote> Support for Ubuntu 15.10 ended July 28 201'''6'''. http://fridge.ubuntu.com/2016/07/28/ubuntu-15-10-wily-werewolf-end-of-life-reached-on-july-28-2016/

Question owner

Thank you for all the help and information. Now I have at least a clear idea of my options and can decide how to proceed.

Thank you for all the help and information. Now I have at least a clear idea of my options and can decide how to proceed.