Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to i remove the "X" button on a tab when i only have one tab open?

  • 2 replies
  • 1 has this problem
  • Last reply by cor-el

more options

I want the remove the "X" button when i have a single tab open. not when i have multiple tabs open. i constantly close Firefox when i mean to open a 2nd tab.

It isnt a problem if i close a tab if i have other tabs open because i can just use "CTL+SHIFT+T" to reopen the tab, but if i close a single tab, all of firefox closes. there used to be add-ons which gave me the options, but not anymore.

All Replies (2)

more options


I don't believe Firefox has a built-in option to do this (although you could possibly do it using a userChrome.css file). However, there are a couple of other things you could try:

1. There's a setting to keep the window open even after you close the last tab, which would allow you to press ctrl+shift+t to restore the tab you closed. To enable this, go to about:config in the addressbar, click the "I accept the risk button", and type "browser.tabs.closeWindowWithLastTab" in the search box. Double-click on the item that appears to change the value to "false", and restart Firefox. 2. Alternatively, you could move the new tab button into the toolbar so that it's harder to click the close button by accident. To do this, click on the menu button in the upper-right corner, and choose "customize". From there, you can drag the new tab button to wherever in the toolbar you want to place it.

Hope that helps!

more options

You can consider to remove the close X on all tabs with code in userChrome.css and middle-click the tab with the mouse wheel to close the tab or possibly use the Tab bar context menu.

Add code to the userChrome.css file below the default @namespace line.

@namespace url(""); /* only needed once */

#tabbrowser-tabs .tabbrowser-tab .tab-close-button {display:none!important}