Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not play sound from Youtube.

  • 3 replies
  • 2 have this problem
  • 5357 views
  • Last reply by guigs

more options

From today, Firefox will not play sound from Youtube. It will play sound from other websites. Other browsers on my computer will play sound from Youtube. I have tried all solutions I can think of: I have gone back two recovery points, to before recent Windows updates. I have disabled hardware acceleration on Firefox, as I found a recommendation to do. I have reinstalled Firefox. I have gone back to Windows High Definition Audio (from Realtek). Nothing works.

Chosen solution

Hi there,

I am sorry to hear that there is trouble with audio on youtube.com on your installation of Firefox. From your question it sounds like you already tried: What to do if Firefox won't play any sounds and Fix common audio and video issues

I wonder if there is a setting we are missing. Can you please check if there is a red icon in the url bar when you are visiting youtube. There is a way to allow audio permissions from the lock icon. You can first try clearing the cookies and data from the site by clicking on the lock icon in the url bar the next time you visit Youtube.

I would next check if your driver version has a pending update. I looked at this reference and it may also be helpful: https://www.drivereasy.com/knowledge/no-sound-on-youtube-in-firefox-chrome-ie-solved/

I look forward to your reply.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi there,

I am sorry to hear that there is trouble with audio on youtube.com on your installation of Firefox. From your question it sounds like you already tried: What to do if Firefox won't play any sounds and Fix common audio and video issues

I wonder if there is a setting we are missing. Can you please check if there is a red icon in the url bar when you are visiting youtube. There is a way to allow audio permissions from the lock icon. You can first try clearing the cookies and data from the site by clicking on the lock icon in the url bar the next time you visit Youtube.

I would next check if your driver version has a pending update. I looked at this reference and it may also be helpful: https://www.drivereasy.com/knowledge/no-sound-on-youtube-in-firefox-chrome-ie-solved/

I look forward to your reply.

more options

I do appreciate your help and advice. Thank you. However, before I heard from you I had discovered 'Refresh Firefox'. It took me back to factory settings, which removed the problem. So in the end I did not need to try out your suggestions. I am very grateful to you nonetheless.

more options

No problem, happy to help.