X
Tap here to go to the mobile version of the site.

Support Forum

What IDIOT removed Autofill from Firefox 63.0.3

Posted

Firefox was working fine until I let it install the latest update. Now it no longer autofills forms and there isn't even a setting for it in this version! Not having autofill makes Firefox ALMOST as good as IE12.

Firefox was working fine until I let it install the latest update. Now it no longer autofills forms and there isn't even a setting for it in this version! Not having autofill makes Firefox ALMOST as good as IE12.

Chosen solution

You can check this pref on the about:config page and try to change its value to "on" in case the default isn't working.

  • extensions.formautofill.available = "on"

Note that this is a builtin extension that is installed by default in the browser/features folder in the Firefox program folder (i.e. not in the profile folder). If this feature isn't working then this extension might be missing.

You can consider to download the full version of Firefox 64 (currently a release candidate) once it becomes available in one of the next days and use a USB stick to transfer this file to the laptop.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157414 answers

Did you look in Options/Preferences?

To see all History and Cookie settings, choose:

See also:

Did you look in Options/Preferences? To see all History and Cookie settings, choose: *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history"<br>"Remember search and form history" *https://support.mozilla.org/en-US/kb/firefox-options-preferences-and-settings See also: *https://support.mozilla.org/en-US/kb/automatically-fill-address-and-credit-cards

Question owner

Yes, I looked in Options.

Now let me make this a bit more complicated. I have two computers, a desktop and a laptop. Both running Windows 7, both running Firefox synced. On both computers, Firefox is set to check for updates but to ask before installing them (mostly because I find the Firefox default of automatically installing updates when I am trying to start the browser to be outrageously annoying). The desktop has a wired high speed Internet connection, so I update it right away unless I am really in a big hurry to do something online, in which case I still update it as soon as I can. I mostly use the laptop while I am out, which means using Wi-Fi and often a poor connection, so sometimes it doesn't get updated the first few times I'm using it after an update becomes available because I have to wait until I have a decent connection before I let it do an update.

For the last several days Firefox as been asking me to let it install the latest update on my laptop. I happened to have a good Wi-Fi connection at work and I wasn't in any hurry so I let Firefox install the update.

Autofill has worked fine on both my desktop and laptop for at least a year or more.

Today I was at work using my laptop and I finally got around to letting it install the most recent update. Once it installed the update, there was no autofill. Not just that Autofill stopped working -- it completely disappeared!

Let me explain that I don't drill down to get to the Autofill settings -- I go to Options and just type Autofill in the search box. This immediately brings up "Forms and Passwords" "Autofill Addresses" -- at least that is what it always did bring up until today but as soon as I let Firefox install the latest update on my laptop there was no more Autofill.

Going to Options and typing Autofill in the search box doesn't find anything at all. THAT was when I entered the original question.

To make things just a little more confusing, I am now home and using my desktop computer. As I mentioned already, the desktop and laptop are both running Windows 7 and they are both running Firefox 63.0.3 -- but Autofill still works exactly as it always did on the desktop and Options then search for "Autofill" still finds Autofill Addresses just like it always did - on the desktop -- but not on the laptop.

I didn't change any settings on either computer. ALL that changed was that I let it install its update.

Once the update was installed, no more Autofill on the laptop.

Yes, I looked in Options. Now let me make this a bit more complicated. I have two computers, a desktop and a laptop. Both running Windows 7, both running Firefox synced. On both computers, Firefox is set to check for updates but to ask before installing them (mostly because I find the Firefox default of automatically installing updates when I am trying to start the browser to be outrageously annoying). The desktop has a wired high speed Internet connection, so I update it right away unless I am ''really'' in a big hurry to do something online, in which case I still update it as soon as I can. I mostly use the laptop while I am out, which means using Wi-Fi and often a poor connection, so sometimes it doesn't get updated the first few times I'm using it after an update becomes available because I have to wait until I have a decent connection before I let it do an update. For the last several days Firefox as been asking me to let it install the latest update on my laptop. I happened to have a good Wi-Fi connection at work and I wasn't in any hurry so I let Firefox install the update. Autofill has worked fine on both my desktop and laptop for at least a year or more. Today I was at work using my laptop and I finally got around to letting it install the most recent update. Once it installed the update, there was no autofill. Not just that Autofill stopped working -- it completely disappeared! Let me explain that I don't drill down to get to the Autofill settings -- I go to Options and just type Autofill in the search box. This immediately brings up "'''Forms and Passwords'''" "Autofill Addresses" -- at least that is what it always ''did'' bring up until today ''but'' as soon as I let Firefox install the latest update on my laptop there was no more Autofill. Going to Options and typing Autofill in the search box doesn't find anything at all. THAT was when I entered the original question. To make things just a little more confusing, I am now home and using my desktop computer. As I mentioned already, the desktop and laptop are both running Windows 7 and they are both running Firefox 63.0.3 -- but Autofill still works exactly as it always did on the desktop and Options then search for "Autofill" still finds Autofill Addresses just like it always did - on the desktop -- but not on the laptop. I didn't change any settings on either computer. ALL that changed was that I let it install its update. Once the update was installed, no more Autofill on the laptop.

Modified by curriet

cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157414 answers

Chosen Solution

You can check this pref on the about:config page and try to change its value to "on" in case the default isn't working.

  • extensions.formautofill.available = "on"

Note that this is a builtin extension that is installed by default in the browser/features folder in the Firefox program folder (i.e. not in the profile folder). If this feature isn't working then this extension might be missing.

You can consider to download the full version of Firefox 64 (currently a release candidate) once it becomes available in one of the next days and use a USB stick to transfer this file to the laptop.

You can check this pref on the <b>about:config</b> page and try to change its value to "on" in case the default isn't working. *extensions.formautofill.available = "on" Note that this is a builtin extension that is installed by default in the browser/features folder in the Firefox program folder (i.e. not in the profile folder). If this feature isn't working then this extension might be missing. You can consider to download the full version of Firefox 64 (currently a release candidate) once it becomes available in one of the next days and use a USB stick to transfer this file to the laptop. *https://www.mozilla.org/en-US/firefox/all/

Question owner

cor-el said

You can check this pref on the about:config page and try to change its value to "on" in case the default isn't working.
  • extensions.formautofill.available = "on"

Changing the setting from "detect" to "on" solved the problem.

Strange that the default is supposed to be "on" but last week's update changed it to "detect" -- and miraculously there is a new update this week to 64.0 that doesn't have last week's problem.

''cor-el [[#answer-1180108|said]]'' <blockquote> You can check this pref on the <b>about:config</b> page and try to change its value to "on" in case the default isn't working. *extensions.formautofill.available = "on" </blockquote> Changing the setting from "detect" to "on" solved the problem. Strange that the default is supposed to be "on" but last week's update changed it to "detect" -- and miraculously there is a new update this week to 64.0 that doesn't have last week's problem.

Helpful Reply

Exactly the same problem recurred with 66.0.1

Again, the update changed the existing setting

Again, the update disabled autofill and removed all references to autofill from the settings page

Again, manually going to about:config and manually changing extensions.formautofill.available to on fixed the problem.

This isn't an insurmountable obstacle now that I know what causes the problem (Stupid Firefox Updates) and know how to fix it, but it remains annoying and ridiculous that certain updates would be written to change existing settings unnecessarily and without any warning.

Exactly the same problem recurred with 66.0.1 Again, the update changed the existing setting Again, the update disabled autofill and removed all references to autofill from the settings page Again, manually going to '''about:config''' and manually changing '''extensions.formautofill.available''' to '''on''' fixed the problem. This isn't an insurmountable obstacle now that I know what causes the problem (Stupid Firefox Updates) and know how to fix it, but it remains annoying and ridiculous that certain updates would be written to change existing settings unnecessarily and without any warning.

Modified by curriet

jscher2000
  • Top 10 Contributor
8638 solutions 70676 answers

Hmm, detect works for me. I wonder what Firefox sees on your laptop that makes it not enable the feature?

Address Autofill is a "system" extension Mozilla bundles with Firefox, so this could be a problem related to enabling the extension, but it may be difficult to figure out whether or why that is happening.

??

Hmm, detect works for me. I wonder what Firefox sees on your laptop that makes it not enable the feature? Address Autofill is a "system" extension Mozilla bundles with Firefox, so this could be a problem related to enabling the extension, but it may be difficult to figure out whether or why that is happening. ??

Question owner

The weird thing is that autofill itself works fine on both my computers -- except that occasionally updates simply turn it off.

I first encountered the problem when 63.0.3 loaded, then one time a while after that which I fixed using the procedure here, now again with 66.0.1

I don't know why some updates change the setting and others don't -- and to be ruthlessly technical, I can't even 100% say that the update changing the setting causes the problem -- all that I can say with complete certainty is that each time autofill magically disappears I go to about:config and I find that extensions.formautofill.available has been set to detect at which point I manually change it to on and autofill magically works again.

I never had this problem before 63.0.3 although I have been running Firefox ever since some version back around 46 or so. I don't recall what version Firefox introduced autofill, but I know that I have been using it for quite a while. I don't have a problem with every update - but the only times I do have the problem are immediately after an update.

---

A little more information to add to this puzzle...

The problem only occurs on my desktop (a Lenovo with a G620 processor at 2.60GHz with 8GB RAM running 64-bit Windows 7). I have never had this problem on my laptop (a Dell Inspirion 15, with an i3-5005 at 2.00GHz, with 4GB RAM running 64-bit Windows 7).

Because the problem only occurs on the desktop I had not looked closely at the same settings on the laptop - until now.

I just checked the laptop and I found that on the laptop extensions.formautofill.available is set to on and I know that I have never changed that setting so I must assume that the default Firefox install had it on and that none of the updates have changed that setting on my laptop.

So to return to your thought about why detect doesn't work on my desktop, the question really seems to be why certain updates change the setting from on to detect on my desktop but don't change the same setting on my laptop.

The weird thing is that autofill itself works fine on both my computers -- except that occasionally updates simply turn it off. I first encountered the problem when 63.0.3 loaded, then one time a while after that which I fixed using the procedure here, now again with 66.0.1 I don't know why some updates change the setting and others don't -- and to be ruthlessly technical, I can't even 100% say that the update changing the setting ''causes'' the problem -- all that I can say with complete certainty is that each time autofill magically disappears I go to '''about:config''' and I find that '''extensions.formautofill.available''' has been set to '''detect''' at which point I manually change it to '''on''' and autofill magically works again. I never had this problem before 63.0.3 although I have been running Firefox ever since some version back around 46 or so. I don't recall what version Firefox introduced autofill, but I know that I have been using it for quite a while. I don't have a problem with every update - but the only times I do have the problem are immediately after an update. --- A little more information to add to this puzzle... The problem only occurs on my desktop (a Lenovo with a G620 processor at 2.60GHz with 8GB RAM running 64-bit Windows 7). I have never had this problem on my laptop (a Dell Inspirion 15, with an i3-5005 at 2.00GHz, with 4GB RAM running 64-bit Windows 7). Because the problem only occurs on the desktop I had not looked closely at the same settings on the laptop - until now. I just checked the laptop and I found that on the laptop '''extensions.formautofill.available''' is set to '''on''' and I know that I have never changed that setting so I must assume that the default Firefox install had it '''on''' and that none of the updates have changed that setting on my laptop. So to return to your thought about why '''detect''' doesn't work on my desktop, the question really seems to be why certain updates change the setting from '''on''' to '''detect''' on my desktop but don't change the same setting on my laptop.

Modified by curriet

jscher2000
  • Top 10 Contributor
8638 solutions 70676 answers

Helpful Reply

What I see on the source code site is:

Default value of the extensions.formautofill.available preference:

  • Firefox Nightly => on
  • Firefox regular release, Beta, Developer => detect

As for what detect means:

// "detect" means it's enabled if conditions defined in the extension are met.

Okay, when I check the api.js file, it appears that in order for the extension to be enabled with detect, you need all three of these:

(A) On the Troubleshooting Information page AKA about:support (near the bottom):

Requested Locales = ["en-US"]

(B) On the about:config page:

(i) extensions.formautofill.supportedCountries = US

(ii) browser.search.region = US

If you are running the U.S. English version of Firefox, I would expect all of that to line up, but sometimes strange things happen.

What I see on the source code site is: Default value of the '''extensions.formautofill.available''' preference: * Firefox Nightly => on * Firefox regular release, Beta, Developer => detect As for what detect means: <code>// "detect" means it's enabled if conditions defined in the extension are met.</code> Okay, when I check the [https://dxr.mozilla.org/mozilla-release/source/browser/extensions/formautofill/api.js#55 api.js] file, it appears that in order for the extension to be enabled with detect, you need all three of these: (A) On the Troubleshooting Information page AKA '''about:support''' (near the bottom): '''Requested Locales''' = ["en-US"] (B) On the '''about:config''' page: (i) '''extensions.formautofill.supportedCountries''' = US (ii) '''browser.search.region''' = US If you are running the U.S. English version of Firefox, I would expect all of that to line up, but sometimes strange things happen.

Question owner

Thanks, that's almost Greek to me but I think I can follow up on those to see what I find -- I really would like to drive a stake through the heart of this problem.

What I still don't understand is: Why the same update acts differently on my two computers -- on the laptop the update leaves extensions.formautofill.available = on but on my desktop the same update changes the setting from on to detect

It sounds like the difference must be related to what you found as Default value of the extensions.formautofill.available preference:

Firefox Nightly => on
Firefox regular release, Beta, Developer => detect 

But I don't see HOW

Thanks, that's ''almost'' Greek to me but I think I can follow up on those to see what I find -- I really would like to drive a stake through the heart of this problem. What I still don't understand is: Why the same update acts differently on my two computers -- on the laptop the update leaves '''extensions.formautofill.available = on''' but on my desktop the same update changes the setting from '''on''' to '''detect''' It sounds like the difference must be related to what you found as Default value of the extensions.formautofill.available preference: Firefox Nightly => on Firefox regular release, Beta, Developer => detect But I don't see HOW
islander1 0 solutions 8 answers

Hi, I had the same issue (on my Inspirion btw.) I forgot about this fix!

Hi, I had the same issue (on my Inspirion btw.) I forgot about this fix!