X
Tap here to go to the mobile version of the site.

Support Forum

Foxfire only works on the background, all found fixes does not work

Posted

Just of a sudden Firefox does not work anymore. On the background it is active but does not start visualy. Have downloaded several times again after removing all the files. Also stopped my virus scan (kaspersky), but nothing helps.

Just of a sudden Firefox does not work anymore. On the background it is active but does not start visualy. Have downloaded several times again after removing all the files. Also stopped my virus scan (kaspersky), but nothing helps.

Chosen solution

If the above did not help,

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf files.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/17.17134

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17168 solutions 155184 answers

It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process.

See:

It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/en-US/kb/server-not-found-connection-problem *https://support.mozilla.org/en-US/kb/Firewalls *https://support.mozilla.org/en-US/kb/fix-problems-connecting-websites-after-updating
FredMcD
  • Top 10 Contributor
4113 solutions 57443 answers

Chosen Solution

If the above did not help,

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf files.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox

If the above did not help, https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' files. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete them. Restart Firefox

Question owner

Thanks for the help, it seemed that my profile was corrupted. It only helpt by removing it completely (not only xulstore.json) and creating a complete new profile. Thanks again, it was a strange thing, not getting anything at all. Maybe this possibility should be mentioned in the Firefox help on the internet, most people will not take the trouble to go to the Support Forum and just start using Edge or Chrome

Problem Solved

Thanks for the help, it seemed that my profile was corrupted. It only helpt by removing it completely (not only xulstore.json) and creating a complete new profile. Thanks again, it was a strange thing, not getting anything at all. Maybe this possibility should be mentioned in the Firefox help on the internet, most people will not take the trouble to go to the Support Forum and just start using Edge or Chrome Problem Solved

Modified by AartVark

FredMcD
  • Top 10 Contributor
4113 solutions 57443 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.