X
Tap here to go to the mobile version of the site.

Support Forum

How to disable site title to left of URL

Posted

Note that I'm NOT asking about address-bar suggestions, but the address bar itself. There's a little info icon with a green lock followed by the url. Some websites (ex. the Washington Post) display a title (also in green) next to the lock and before the URL. It can be quite long, and makes the address bar inaccessible --- even for not-so-narrow windows. When this happens, there is no typeable area or visible text area to select. The only way to enter a new URL is to first navigate away using the back button (or open a new tab/window). I assume this either is very obnoxious marketing or bad configuration on the website's part. Is there a way to disable the display of anything but the lock itself? Again, to be clear, I am speaking solely of the address bar itself --- not the drop down suggestions or any other part of the browser window.

I tried disabling favicons and site icons (I figured it could be some sort of big icon), but that didn't work. Disabling extensions had no effect either --- so it's clearly firefox proper. FF 57.0.1.

Any help would be appreciated!

Cheers, Ken

Note that I'm NOT asking about address-bar suggestions, but the address bar itself. There's a little info icon with a green lock followed by the url. Some websites (ex. the Washington Post) display a title (also in green) next to the lock and before the URL. It can be quite long, and makes the address bar inaccessible --- even for not-so-narrow windows. When this happens, there is no typeable area or visible text area to select. The only way to enter a new URL is to first navigate away using the back button (or open a new tab/window). I assume this either is very obnoxious marketing or bad configuration on the website's part. Is there a way to disable the display of anything but the lock itself? Again, to be clear, I am speaking solely of the address bar itself --- not the drop down suggestions or any other part of the browser window. I tried disabling favicons and site icons (I figured it could be some sort of big icon), but that didn't work. Disabling extensions had no effect either --- so it's clearly firefox proper. FF 57.0.1. Any help would be appreciated! Cheers, Ken

Chosen solution

You need to place userChrome.css in the chrome folder in the Firefox profile folder.

  • ~/.mozilla/firefox/<profile>/chrome/userChrome.css

This variant shows the label when you hover the Control Center 'i' icon. You can add this code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* Site Identity Button, EV: hide label */
#identity-box #identity-icon-labels {display:none !important}
#identity-box:hover #identity-icon-labels {display:-moz-box !important}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

You need to close and restart Firefox when you create or modify the userChrome.css file.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

AlexBlackfox 0 solutions 3 answers

Helpful Reply

[https://support.mozilla.org/ru/questions/1061161 this way]

Question owner

Thanks for the suggestion, but it doesn't seem to work for me. I think the site in question (and others like it) may be displaying something different. I put the following in my ~/.mozilla/userChrome.css file as described on the page linked to:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

#identity-box *:not(#page-proxy-favicon) {
display: none !important;
}

and restarted the browser, but it appears to have no effect.

Cheers, Ken

Thanks for the suggestion, but it doesn't seem to work for me. I think the site in question (and others like it) may be displaying something different. I put the following in my ~/.mozilla/userChrome.css file as described on the page linked to: <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); #identity-box *:not(#page-proxy-favicon) { display: none !important; }</nowiki></pre> and restarted the browser, but it appears to have no effect. Cheers, Ken

Modified by cor-el

Question owner

Hmmm... it seems to have messed up the formatting of the code in the file when I posted it.

Not sure why the Mozilla support forum doesn't have a "verbatim" formatting option for its posts, but hey.

Anyway:

Number-sign-without-a-space-after-it identity-box ...

Hmmm... it seems to have messed up the formatting of the code in the file when I posted it. Not sure why the Mozilla support forum doesn't have a "verbatim" formatting option for its posts, but hey. Anyway: Number-sign-without-a-space-after-it identity-box ...
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157874 answers

Chosen Solution

You need to place userChrome.css in the chrome folder in the Firefox profile folder.

  • ~/.mozilla/firefox/<profile>/chrome/userChrome.css

This variant shows the label when you hover the Control Center 'i' icon. You can add this code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* Site Identity Button, EV: hide label */
#identity-box #identity-icon-labels {display:none !important}
#identity-box:hover #identity-icon-labels {display:-moz-box !important}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

You need to close and restart Firefox when you create or modify the userChrome.css file.

You need to place userChrome.css in the chrome folder in the Firefox profile folder. *~/.mozilla/firefox/<profile>/chrome/userChrome.css This variant shows the label when you hover the Control Center 'i' icon. You can add this code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* Site Identity Button, EV: hide label */ #identity-box #identity-icon-labels {display:none !important} #identity-box:hover #identity-icon-labels {display:-moz-box !important} </nowiki></pre> ---- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. You need to close and restart Firefox when you create or modify the userChrome.css file.

Modified by cor-el

Question owner

Thanks, this did the trick. My thanks to both of you! For the record (and anyone who comes across this in future), the original linked suggestion did remove the title but also removed the lock icon and ability to see any security info --- even by clicking. The 2 lines above in cor-el's post removed the annoying bit but left the lock and ability to inspect security info in place.

Cheers, Ken

Thanks, this did the trick. My thanks to both of you! For the record (and anyone who comes across this in future), the original linked suggestion did remove the title but also removed the lock icon and ability to see any security info --- even by clicking. The 2 lines above in cor-el's post removed the annoying bit but left the lock and ability to inspect security info in place. Cheers, Ken
wjm263 0 solutions 8 answers

This seemingly has no effect on my system. On the theory that perhaps I put the userChrome.css file in the wrong place, I will note it's in the same subdirectory with prefs.js, logins.json, etc. So far as I can tell it's properly placed, but...

I'm using Firefox 65.0.1 (64-bit) for Windows.

This seemingly has no effect on my system. On the theory that perhaps I put the userChrome.css file in the wrong place, I will note it's in the same subdirectory with prefs.js, logins.json, etc. So far as I can tell it's properly placed, but... I'm using Firefox 65.0.1 (64-bit) for Windows.
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157874 answers

The userChrome.css file needs to be in the chrome folder in the main profile folder. You need to create this chrome folder if it doesn't exist.

The userChrome.css file needs to be in the chrome folder in the main profile folder. You need to create this chrome folder if it doesn't exist. *http://kb.mozillazine.org/userChrome.css
wjm263 0 solutions 8 answers

Yes, I did create it following the instructions originally given.

So what's the "main profile folder"? I have three different profiles on the machine, so I presume the file goes in the folder with the name of the profile I'm using. And that is indeed the folder that FF's Menu>Help>Troubleshooting button identifies as the Profile. Since that didn't work however, I also tried it in the directory above that to no avail.

Also tried disabling all extensions which did not help.

Thanks.

Yes, I did create it following the instructions originally given. So what's the "main profile folder"? I have three different profiles on the machine, so I presume the file goes in the folder with the name of the profile I'm using. And that is indeed the folder that FF's Menu>Help>Troubleshooting button identifies as the Profile. Since that didn't work however, I also tried it in the directory above that to no avail. Also tried disabling all extensions which did not help. Thanks.

Modified by wjm263

cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157874 answers

Is userChrome.css in the chrome folder?

What is the full path to the userChrome.css (you may obfuscate your Windows user name)?

Also make sure it is a plain text file and doesn't have formatting code like RTF or have a hidden .txt or .css file extension appended.

Is userChrome.css in the chrome folder? What is the full path to the userChrome.css (you may obfuscate your Windows user name)? Also make sure it is a plain text file and doesn't have formatting code like RTF or have a hidden .txt or .css file extension appended.
wjm263 0 solutions 8 answers

No, it was in the Profile subdirectory. No Chrome subdir existed, so I created one, put the file there, and it works now.

Thanks.

No, it was in the Profile subdirectory. No Chrome subdir existed, so I created one, put the file there, and it works now. Thanks.