Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SSL_ERROR_NO_CYPHER_OVERLAP. Unable to bypass because 'Advanced' button not appearing

  • 12 replies
  • 5 have this problem
  • 28384 views
  • Last reply by McMom

more options

When trying to access 2 links, that I work with on a daily basis and have done so for the last 2 years, facing the SSL_ERROR_NO_CYPHER_OVERLAP error and not able to access the pages because of Secure Connection Failure.

Have had this issue in the past, but was able to bypass it by clicking on 'Advanced' button in order to add Exception.

Problem is that since 2 days ago, error started coming up but 'Advanced' button is no longer appearing as an option. So, not able to bypass it in order to connect with the pages.

Thx for the help!

Chosen solution

Since all browsers are affected, could it be a "man in the middle" such as your security software? They make two secure connections, one with Firefox and one with the site, so they can read your browsing. This article describes some of the common ones and how to disable them from filtering secure connections in Firefox: How to troubleshoot security error codes on secure websites.

Read this answer in context 👍 1

All Replies (12)

more options

I don't think there is a bypass for that particular error code -- SSL_ERROR_NO_CYPHER_OVERLAP -- because Firefox and the server need to agree on the encryption cipher in order to form a connection.

Is this a public website? You could share the URL with us, or test it using the following page and see whether their Firefox test machines can connect:

https://www.ssllabs.com/ssltest/

If these are internal servers in your company, does your IT have any explanation for the problem?

more options

Tried testing them on the link but it indicates that IP addresses are not allowed.

These are the links I´m trying to access: https://74.201.159.110/EZrate/index.php https://74.201.159.25/gcszzdasaro/index.php

more options

I guess you must have already made an exception for the other problems before you got the cipher error:

74.201.159.110 uses an invalid security certificate.
The certificate is not trusted because it is self-signed.
The certificate is only valid for .
The certificate expired on Wednesday, July 10, 2013, 3:55:43 PM. The current time is November 13, 2018, 2:25 PM.
Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

I don't think I'm going to make an exception to see what happens next, sorry.

Do your other browsers work with the site?

more options

No, having the same issue over Chrome & Edge. But, this only happens from my laptop. Able to access from ipad / iphone.

Even worse, only I started having these issues. Other users working remotely are able to access with no issue.

more options

Chosen Solution

Since all browsers are affected, could it be a "man in the middle" such as your security software? They make two secure connections, one with Firefox and one with the site, so they can read your browsing. This article describes some of the common ones and how to disable them from filtering secure connections in Firefox: How to troubleshoot security error codes on secure websites.

more options

Indeed it was Bitdefender Security Software. Already had Exceptions configured for both IPs but for some reason, on last update from the software, they stopped being considered; although are still detailed as such. Turned off Scan SSL, which is now named Encrypted Web Scan, and all is finally back to normal!

Thank you for the help!!!

more options

I have this problem, also. This is the website I want to access: https://mychart.sclhealth.org/MyChart/ It works in Explorer. I tried to add it as an exception to no avail.

more options

Hi McMom, that address doesn't work for me, either.

In case they changed it, could you go through the link on the upper right of the home page and see whether you end up in the same place or somewhere new?

https://www.sclhealth.org/

If the problem continues, please contact them for assistance. I don't suggest messing with the security of your connection to sites that handle sensitive information.

See next post

Modified by jscher2000

more options

Hi McMom, I ran the address through a tester and none of their Firefoxes can connect either:

https://www.ssllabs.com/ssltest/analyze.html?d=mychart.sclhealth.org

It seems to be an issue with the site's cipher suites not being compatible with Firefox. So you'll need to use a different browser for the time being. If you prefer Firefox, please point them to that page and ask them to make the site compatible.

more options

Thank you SO MUCH, jscher2000!

more options

If I run the test at this time then the result indicates that the mychart.sclhealth.org site works and I currently have no problems.

TLS 1.2 and TLS_RSA_WITH_AES_256_CBC_SHA

more options

Interesting. Thanks!