Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is really slow on connecting to websites

  • 4 replies
  • 2 have this problem
  • 715 views
  • Last reply by td47

more options

on startup firefox works fine and fast, but once i type in a website it takes a long time to connect ! I tried safe mode and refreshing firefox didn't work out !

Chosen solution

Hi SaraAdam please make sure that you have the latest firefox version

Type about:preferences <Enter> in the address bar. Under Performance. Look for and turn off Use Hardware Acceleration.

also maybe this article help you Firefox takes a long time to start up

Read this answer in context 👍 1

All Replies (4)

more options

hi, please try to go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser, as this can prevent 3rd party tools from hooking into firefox and causing lags.

you might also want to try updating to the latest version of firefox (that's 63.0.1 at the moment): Update Firefox to the latest release

more options

Chosen Solution

Hi SaraAdam please make sure that you have the latest firefox version

Type about:preferences <Enter> in the address bar. Under Performance. Look for and turn off Use Hardware Acceleration.

also maybe this article help you Firefox takes a long time to start up

more options

philipp said

hi, please try to go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser, as this can prevent 3rd party tools from hooking into firefox and causing lags. you might also want to try updating to the latest version of firefox (that's 63.0.1 at the moment): Update Firefox to the latest release

Done that still the same problem :(

more options

SaraAdam said

Done that still the same problem :(

FYI: you might want to try disabling any add-ins that you have, in case one of those is affecting the FF browser active tab that you are waiting on. I found that a Tab Session Manager add-in was slowing mine down a lot. Disable all of them, then recheck. If it DOES go back to normal, then enable each in turn until the issue re-appears, if it does, you found your culprit. Otherwise, try starting the browser in safe-mode.