X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How to set font for plain text messages incoming.

Posted

The new version has changed the display font for incoming plain text messages to Ariel, which I do not like. How do I set it back to Times New Roman?

The new version has changed the display font for incoming plain text messages to Ariel, which I do not like. How do I set it back to Times New Roman?

Chosen solution

Brilliant, thank you!! The "Fonts for" setting was probably the only one I didn't play with and it turns out to be the solution. I'm absolutely delighted. You're a genius and you've made me VERY happy this morning!

While I have your attention, I'm a little curious about the Text Encoding settings at the bottom of the Fonts & Encodings box. Outgoing is set to Unicode (UTF-8) and Incoming is set to Western (ISO 8859-1). Can you tell me (in simple terms) why they are different for Incoming and Outgoing? I'm not having a problem, just trying to learn something.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

sfhowes
  • Top 10 Contributor
1320 solutions 6235 answers

Display fonts are a complex matter in TB. I suggest you open Tools/Options/Display/Formatting and adjust the Default font, then click the Advanced button and select Times New Roman in (one or all of) the font selection drop-downs, and also check the box for 'Used fixed width font for plain text messages' and uncheck 'Allow messages to use other fonts'.

The details of these settings are described here:

http://kb.mozillazine.org/Font_settings_in_Thunderbird

Display fonts are a complex matter in TB. I suggest you open Tools/Options/Display/Formatting and adjust the Default font, then click the Advanced button and select Times New Roman in (one or all of) the font selection drop-downs, and also check the box for 'Used fixed width font for plain text messages' and uncheck 'Allow messages to use other fonts'. The details of these settings are described here: http://kb.mozillazine.org/Font_settings_in_Thunderbird

Question owner

Thank you for your reply, but I already tried all that and it had no effect. I tried resettin everything to default, closed TB, reopened it and put in the setting I want. No success.

Plain text messages will display in Times when I'm composing them, but are received in Ariel only. Plus when I open a plain text message that I've previously sent, it's turned into Ariel!

On the upside, HTML messages are behaving as they should. I guess I should be grateful for that.

Thank you for your reply, but I already tried all that and it had no effect. I tried resettin everything to default, closed TB, reopened it and put in the setting I want. No success. Plain text messages will display in Times when I'm composing them, but are received in Ariel only. Plus when I open a plain text message that I've previously sent, it's turned into Ariel! On the upside, HTML messages are behaving as they should. I guess I should be grateful for that.

Question owner

Apologies for the typos - one of the cats walked across the keyboard just as I clicked on Post Reply. Somehow they always manage to step on the Backspace and/or Delete keys, haha.

Apologies for the typos - one of the cats walked across the keyboard just as I clicked on Post Reply. Somehow they always manage to step on the Backspace and/or Delete keys, haha.
sfhowes
  • Top 10 Contributor
1320 solutions 6235 answers

Helpful Reply

OK, I tried a few things to see the font change in plain text mail. In the Advanced Fonts & Encodings options, the Fonts for: box defaults to Latin. But if I change that to Other Writing Systems and set the Monospace (fixed width) font to Times New Roman, and check 'Used fixed width font for plain text messages', (also set the Size and Min. Size), plain text messages composed in monospace display in Times New Roman. If Proportional: is set to Sans Serif, set Sans-serif: to Times New Roman, similarly if Proportional:is Serif, set Serif: to TNR.

This seems to work with all plain text messages.

OK, I tried a few things to see the font change in plain text mail. In the Advanced Fonts & Encodings options, the Fonts for: box defaults to Latin. But if I change that to Other Writing Systems and set the Monospace (fixed width) font to Times New Roman, and check 'Used fixed width font for plain text messages', (also set the Size and Min. Size), plain text messages composed in monospace display in Times New Roman. If Proportional: is set to Sans Serif, set Sans-serif: to Times New Roman, similarly if Proportional:is Serif, set Serif: to TNR. This seems to work with all plain text messages.

Modified by sfhowes

Chosen Solution

Brilliant, thank you!! The "Fonts for" setting was probably the only one I didn't play with and it turns out to be the solution. I'm absolutely delighted. You're a genius and you've made me VERY happy this morning!

While I have your attention, I'm a little curious about the Text Encoding settings at the bottom of the Fonts & Encodings box. Outgoing is set to Unicode (UTF-8) and Incoming is set to Western (ISO 8859-1). Can you tell me (in simple terms) why they are different for Incoming and Outgoing? I'm not having a problem, just trying to learn something.

Brilliant, thank you!! The "Fonts for" setting was probably the only one I didn't play with and it turns out to be the solution. I'm absolutely delighted. You're a genius and you've made me VERY happy this morning! While I have your attention, I'm a little curious about the Text Encoding settings at the bottom of the Fonts & Encodings box. Outgoing is set to Unicode (UTF-8) and Incoming is set to Western (ISO 8859-1). Can you tell me (in simple terms) why they are different for Incoming and Outgoing? I'm not having a problem, just trying to learn something.
sfhowes
  • Top 10 Contributor
1320 solutions 6235 answers

Helpful Reply

Character encoding is explained in the kb article cited above (which is down at the moment). It states:

"Outgoing Mail" pulldown menu: although this is listed in the "Display" dialog, it's actually not a message display setting. Instead, it applies to messages that you send (see the "Message sending" section below).

"Incoming Mail" pulldown menu: Thunderbird will normally use each message's stored character encoding, or auto-detect it, but you can set a default character encoding for message display by using this pulldown.

"Apply the default character encoding to all incoming messages": For normal use, do not check this box. It forces the selected character encoding on all messages, even if it is the wrong character encoding, making some messages unreadable.

"Use the default character encoding in replies": For normal use, do not check this box. It is sometimes useful if you often receive messages in one language but you reply in a different language, but it might mean that the person you reply to cannot read your reply.

Character encoding is explained in the kb article cited above (which is down at the moment). It states: "Outgoing Mail" pulldown menu: although this is listed in the "Display" dialog, it's actually not a message display setting. Instead, it applies to messages that you send (see the "Message sending" section below). "Incoming Mail" pulldown menu: Thunderbird will normally use each message's stored character encoding, or auto-detect it, but you can set a default character encoding for message display by using this pulldown. "Apply the default character encoding to all incoming messages": For normal use, do not check this box. It forces the selected character encoding on all messages, even if it is the wrong character encoding, making some messages unreadable. "Use the default character encoding in replies": For normal use, do not check this box. It is sometimes useful if you often receive messages in one language but you reply in a different language, but it might mean that the person you reply to cannot read your reply.

Question owner

Thanks again, all for now!

Thanks again, all for now!