Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I view a picture bigger than my resolution, it appears full sized, and when I try to unzoom to fit the screen with the magnifying glass, nothing happens.

  • 6 replies
  • 1 has this problem
  • 91 views
  • Last reply by Pj

more options

It's been like that for a couple of updates.

Chosen solution

Can you zoom the image in and out with the zoom control or the keyboard shortcuts (Ctrl and +/-)?

You can try to modify these prefs on the about:config page to see if that has effect.

  • browser.enable_automatic_image_resizing
  • browser.enable_click_image_resizing

if this didn't work then undo/reverse the change and reset via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 1

All Replies (6)

more options

Hello fasderrally,

You mention "magnifying glass" - are you talking about this add-on :

https://addons.mozilla.org/en-US/firefox/addon/magnifying-glass-hover-zoom/  ?

If so : if it doesn't work, would you please contact the developer  ?

This may not be one of my brightest moments, but I wonder why you don't use the Ctrl key plus the minus key (-) to zoom out, and the Ctrl key and plus key (+) to zoom in  ?

more options

No, I mean the fit to screen abilty, like in any brower

more options

And i don't use the zoom in and out because it should fit to screen automaticly, and zoom in and out with M1. It's much more comfortable.

more options

Chosen Solution

Can you zoom the image in and out with the zoom control or the keyboard shortcuts (Ctrl and +/-)?

You can try to modify these prefs on the about:config page to see if that has effect.

  • browser.enable_automatic_image_resizing
  • browser.enable_click_image_resizing

if this didn't work then undo/reverse the change and reset via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

You are a Genius! Thank you very much

more options

fasderrally said

And I don't use the zoom in and out because it should fit to screen automatically, and zoom in and out with M1. It's much more comfortable.

I use the browser's click on image = Full Size, click again to Fit the Browser Window. That was 'broken' for you?


~Pj