X
Tap here to go to the mobile version of the site.

Support Forum

Can't associate pdf files with Firefox

Posted

Firefox does not show up as an option for pdf files under Control Panel's "Choose default apps by file type".

The problem is on my wife's laptop, (a Dell Inspiron 5759). (Her Windows 10 is up-to-date.) She got a red screen phishing page on Firefox last week. (It claimed to be from Microsoft, and told her to call a certain number -- we did not call.) It essentially locked up her computer -- the mouse wouldn't move, even the power button didn't respond most of the time. I eventually had to unplug her power supply, and remove the battery. When it came back up from that, it responded; so, I uninstalled Firefox and deleted her cache folders.

I've reinstalled Firefox; but, now I can't associate pdf files with Firefox on her machine. Only Microsoft Edge is shown as available in "Choose default apps by file type".

Firefox does not show up as an option for pdf files under Control Panel's "Choose default apps by file type". The problem is on my wife's laptop, (a Dell Inspiron 5759). (Her Windows 10 is up-to-date.) She got a red screen phishing page on Firefox last week. (It claimed to be from Microsoft, and told her to call a certain number -- we did not call.) It essentially locked up her computer -- the mouse wouldn't move, even the power button didn't respond most of the time. I eventually had to unplug her power supply, and remove the battery. When it came back up from that, it responded; so, I uninstalled Firefox and deleted her cache folders. I've reinstalled Firefox; but, now I can't associate pdf files with Firefox on her machine. Only Microsoft Edge is shown as available in "Choose default apps by file type".

Chosen solution

I deleted registry keys that showed "firefox.exe" in "Program Files (x86)".

Then I could right click a pdf file, select "Open with", "Choose another app", "More apps", "Look for another app on this PC", "Program Files\Mozilla Firefox\firefox.exe". With that, Firefox opened the pdf file. Hurray!

But, even after checking "Always use this app to open .pdf files", Windows would use Edge to open them if I didn't go through the "Open with" procedure.

I eventually restored Windows to a restore point from before the red screen phishing page. Firefox now opens .pdf files as it should, as the default app, by just left clicking the file. Problem fixed.

I appreciate I Am letting me think of restoring to a pre-problem restore point -- nothing else was working.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

WestEnd 60 solutions 5387 answers

pdf are Adobe file extensions so unless you have acrobat or the likes installed those other software won't by natively open pdf.

pdf are Adobe file extensions so unless you have acrobat or the likes installed those other software won't by natively open pdf.

Question owner

WestEnd, thanks for taking the time to answer. However, current versions of Firefox handle pdf natively, without Adobe or any other viewer.

Firefox was doing so on my wife's machine before I uninstalled Firefox in response to the hoax page she had. It is currently displaying pdf on my machine, and I don't have Adobe anymore.

WestEnd, thanks for taking the time to answer. However, current versions of Firefox handle pdf natively, without Adobe or any other viewer. Firefox was doing so on my wife's machine before I uninstalled Firefox in response to the hoax page she had. It is currently displaying pdf on my machine, and I don't have Adobe anymore.

Question owner

One thing that may help, which I didn't mention before, is that Control Panel's "Associate a file type or protocol with a program" > "Set defaults by app" lists Firefox four times. That is, like four different apps in a row, (well, one below the other). The first two are represented by just solid blue boxes; the last two by blue boxes with the usual fox symbol inside.

One thing that may help, which I didn't mention before, is that Control Panel's "Associate a file type or protocol with a program" > "Set defaults by app" lists Firefox four times. That is, like four different apps in a row, (well, one below the other). The first two are represented by just solid blue boxes; the last two by blue boxes with the usual fox symbol inside.

Question owner

I think I know more of what's wrong: I think Windows has stored "Program Files (x86)" as the folder in which it should look for Firefox for pdf files. Maybe in a registry? But, I don't know how to fix it.

My wife's machine is a 64 bit machine. I had mistakenly installed the 64 bit Firefox in "Program Files (x86)". (See [[64 bit Firefox version 63.0 installs in Program Files folder instead of Program Files (x86) folder|https://support.mozilla.org/en-US/questions/1238772]] .) While it was there, I successfully associated .pdf files with Firefox. I have since uninstalled Firefox from there, and reinstalled it in "Program Files". But, I think Windows retains that "Program Files (x86)" association somewhere.

How do I find and remove that incorrect association?

I think I know more of what's wrong: I think Windows has stored "Program Files (x86)" as the folder in which it should look for Firefox for pdf files. Maybe in a registry? But, I don't know how to fix it. My wife's machine is a 64 bit machine. I had mistakenly installed the 64 bit Firefox in "Program Files (x86)". (See [[64 bit Firefox version 63.0 installs in Program Files folder instead of Program Files (x86) folder|https://support.mozilla.org/en-US/questions/1238772]] .) While it was there, I successfully associated .pdf files with Firefox. I have since uninstalled Firefox from there, and reinstalled it in "Program Files". But, I think Windows retains that "Program Files (x86)" association somewhere. How do I find and remove that incorrect association?

Chosen Solution

I deleted registry keys that showed "firefox.exe" in "Program Files (x86)".

Then I could right click a pdf file, select "Open with", "Choose another app", "More apps", "Look for another app on this PC", "Program Files\Mozilla Firefox\firefox.exe". With that, Firefox opened the pdf file. Hurray!

But, even after checking "Always use this app to open .pdf files", Windows would use Edge to open them if I didn't go through the "Open with" procedure.

I eventually restored Windows to a restore point from before the red screen phishing page. Firefox now opens .pdf files as it should, as the default app, by just left clicking the file. Problem fixed.

I appreciate I Am letting me think of restoring to a pre-problem restore point -- nothing else was working.

I deleted registry keys that showed "firefox.exe" in "Program Files (x86)". Then I could right click a pdf file, select "Open with", "Choose another app", "More apps", "Look for another app on this PC", "Program Files\Mozilla Firefox\firefox.exe". With that, Firefox opened the pdf file. Hurray! But, even after checking "Always use this app to open .pdf files", Windows would use Edge to open them if I didn't go through the "Open with" procedure. I eventually restored Windows to a restore point from before the red screen phishing page. Firefox now opens .pdf files as it should, as the default app, by just left clicking the file. Problem fixed. I appreciate I Am letting me think of restoring to a pre-problem restore point -- nothing else was working.

Modified by Barry