X
Tap here to go to the mobile version of the site.

Support Forum

Does Extended Support Release of Firefox 60 32 Bit /64 Bit Support Quicktime ?

Posted

Does Extended Support Release of Firefox 60 32 Bit /64 Bit Support Quicktime ?

Does Extended Support Release of Firefox 60 32 Bit /64 Bit Support Quicktime ?
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11287 answers

Firefox 52.0 and later only allows the Flash Player Plugin from Adobe to run.

The old legacy Firefox 52.9.0esr which was officially made EOL with no more updates as of Sept 5th did allow other Plugins to run. Though with Windows you needed 32-bit Firefox.

Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? - https://support.mozilla.org/en-US/kb/npapi-plugins

Firefox 52.0 and later only allows the Flash Player Plugin from Adobe to run. The old legacy Firefox 52.9.0esr which was officially made EOL with no more updates as of Sept 5th did allow other Plugins to run. Though with Windows you needed 32-bit Firefox. Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? - https://support.mozilla.org/en-US/kb/npapi-plugins