X
Tap here to go to the mobile version of the site.

Support Forum

Firefox updated and now video autoplays even though I turned it off in about:config, why?!

Posted

I turned off autoplay in about:config but after today's update to 63.0 all videos are autoplaying. Has Firefox been paid by advertisers to force autoplay videos down our throat no matter what? Why is this browser so awful now?

I turned off autoplay in about:config but after today's update to 63.0 all videos are autoplaying. Has Firefox been paid by advertisers to force autoplay videos down our throat no matter what? Why is this browser so awful now?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Helpful Reply

Hi, the settings have evolved.

The old media.autoplay.enabled preference has been replaced by several new ones. Let's give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.

Hi, the settings have evolved. The old '''media.autoplay.enabled''' preference has been replaced by several new ones. Let's give this a try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' => ''Does that work for you?'' '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.
cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157388 answers

See also:

When these two prefs are true (or at least user-gestures-needed) then there is also a setting available in "Options/Preferences -> Privacy & Security -> Permissions" and you can inspect and modify the exceptions.

  • media.autoplay.ask-permission = true
  • media.autoplay.enabled.user-gestures-needed = true
See also: *https://support.mozilla.org/en-US/kb/block-autoplay When these two prefs are true (or at least user-gestures-needed) then there is also a setting available in "Options/Preferences -> Privacy & Security -> Permissions" and you can inspect and modify the exceptions. *media.autoplay.ask-permission = true *media.autoplay.enabled.user-gestures-needed = true