X
Tap here to go to the mobile version of the site.

Support Forum

comments not displaying on Foxnews.com

Posted

Comments on Foxnews webpages not displaying. All addons are disabled. Comments do display on Edge and Chrome browsers. I also cleared history and cache. Comments still do not display, or more accurately, they display for a microsecond and then disappear, as they did before clearing history and cache. I am signed in to the website.

https://www.foxnews.com/politics/dems-wage-war-on-kavanaugh-court-new-battles-over-legitimacy-impeachment-recusal

Comments on Foxnews webpages not displaying. All addons are disabled. Comments do display on Edge and Chrome browsers. I also cleared history and cache. Comments still do not display, or more accurately, they display for a microsecond and then disappear, as they did before clearing history and cache. I am signed in to the website. https://www.foxnews.com/politics/dems-wage-war-on-kavanaugh-court-new-battles-over-legitimacy-impeachment-recusal
cor-el
  • Top 10 Contributor
  • Moderator
17785 solutions 160874 answers

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection. *click the shield icon for more detail and possibly disable the protection *You can check the Web Console by Tracking Protection *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection-firefox If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

Nice try. Disabled in shield. Only difference is then I did not see the comments at all. With enabled, they display for a micro second.

I had already tried with addons disabled. No difference. Rebooted, reloaded. There is something distinctly different, a recent change as this was not a problem a week ago. Can't say exactly when it started.

Still not working, and only on Firefox.

Nice try. Disabled in shield. Only difference is then I did not see the comments at all. With enabled, they display for a micro second. I had already tried with addons disabled. No difference. Rebooted, reloaded. There is something distinctly different, a recent change as this was not a problem a week ago. Can't say exactly when it started. Still not working, and only on Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17785 solutions 160874 answers

Try to enable third-party cookies temporarily to see if that makes a difference.

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.


Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Try to enable third-party cookies temporarily to see if that makes a difference. You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content. *https://developer.mozilla.org/en/Tools/Web_Console You can check the Network Monitor to see if content is blocked or otherwise fails to load. *https://developer.mozilla.org/en/Tools/Network_Monitor If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log. ---- Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
jscher2000
  • Top 10 Contributor
8899 solutions 72797 answers

The site uses Facebook for its comments system, in case that sounds like it could be a factor. It's odd that they appear briefly and then... does that section go blank or does it close up/disappear?

The site uses Facebook for its comments system, in case that sounds like it could be a factor. It's odd that they appear briefly and then... does that section go blank or does it close up/disappear?

Question owner

They use facebook maybe for Foxinsider or FoxEntertainment but not Foxnews. The space closes.

They use facebook maybe for Foxinsider or FoxEntertainment but not Foxnews. The space closes.
McCoy
  • Top 10 Contributor
592 solutions 5678 answers

More people are reporting the same issue - maybe you could contact Fox News Comments :

http://foxnewscomments.com/contact/

More people are reporting the same issue - maybe you could contact Fox News Comments : http://foxnewscomments.com/contact/
cor-el
  • Top 10 Contributor
  • Moderator
17785 solutions 160874 answers

The comments should be in a #commenting container. but this container is empty in all cases I tried.

The comments should be in a #commenting container. but this container is empty in all cases I tried.

Modified by cor-el

McCoy
  • Top 10 Contributor
592 solutions 5678 answers

On another forum (about the same issue) somebody posted :

"Comments work for me at Fox News with Firefox, but only with Javascript enabled for the associated domains, of which there are a large number. So, if you are using the NoScript extension, try choosing "Allow all for this site". "

On another forum (about the same issue) somebody posted : "''Comments work for me at Fox News with Firefox, but only with Javascript enabled for the associated domains, of which there are a large number. ''So, if you are using the NoScript extension, try choosing "Allow all for this site".'' "
jscher2000
  • Top 10 Contributor
8899 solutions 72797 answers

cburch3 said

They use facebook maybe for Foxinsider or FoxEntertainment but not Foxnews. The space closes.

That's weird, the article comments look different today, and have the heading "Conversations". That section is embedded from an address on spot.im (screenshot attached). At least as of this viewing.

McCoy said

So, if you are using the NoScript extension, try choosing "Allow all for this site". "

I use NoScript so it took a few "Temporarily allow all" and reload cycles, and patience while the site loaded for 30-45 seconds each time, to see the Conversations section.

''cburch3 [[#answer-1162584|said]]'' <blockquote> They use facebook maybe for Foxinsider or FoxEntertainment but not Foxnews. The space closes. </blockquote> That's weird, the article comments look different today, and have the heading "Conversations". That section is embedded from an address on spot.im (screenshot attached). At least as of this viewing. ''McCoy [[#answer-1162619|said]]'' <blockquote> ''So, if you are using the NoScript extension, try choosing "Allow all for this site".'' " </blockquote> I use NoScript so it took a few "Temporarily allow all" and reload cycles, and patience while the site loaded for 30-45 seconds each time, to see the Conversations section.

Question owner

Don't see it as a Foxnews problem since everything works as expected when using Edge or Chrome.

Don't see it as a Foxnews problem since everything works as expected when using Edge or Chrome.

Question owner

I do not use Noscript extension. I use some extensions but disabled them all and it still failed to show comments.

I do not use Noscript extension. I use some extensions but disabled them all and it still failed to show comments.
jscher2000
  • Top 10 Contributor
8899 solutions 72797 answers

cburch3 said

Don't see it as a Foxnews problem since everything works as expected when using Edge or Chrome.

I don't know why you do not see the comments in your Firefox. Must be some setting or other factor we don't have in common.

FYI, Huffington Post also uses spot.im for "Conversations", and one of their readers reported a similar issue earlier today.

''cburch3 [[#answer-1162780|said]]'' <blockquote> Don't see it as a Foxnews problem since everything works as expected when using Edge or Chrome. </blockquote> I don't know why you do not see the comments in your Firefox. Must be some setting or other factor we don't have in common. FYI, Huffington Post also uses spot.im for "Conversations", and one of their readers reported a similar issue earlier today.