X
Tap here to go to the mobile version of the site.

Support Forum

Firefox shows Black Blank screen on start - Mac Mojave

Posted

I am using the latest public beta of Mac OS Mojave (10.14 b10/11) and the latest firefox (62). When I open firefox, it shows a completely black screen with only the red/yellow/green buttons at top. No text, but I can do some interactions with the browser blindly (cmd + L to type a URL, check "about", open preferences, etc.) NOTHING is visible except when I begin typing in the URL bar, but it stays completely blank otherwise.

I have: 1. Completely erased and reinstalled firefox using AppCleaner. 2. Tried firefox safemode - still black. 3. Tried beta and nightly versions 4. Installing the last working version I had (which was 60 on Mac beta 9).

  • 5. Used a guest account - This shows firefox completely normal.

6. Reinstalled with fresh DMGs multiple times, still all black on my primary account. 7. No extensions should be installed, as I have completely erased and installed firefox.

I am using the latest public beta of Mac OS Mojave (10.14 b10/11) and the latest firefox (62). When I open firefox, it shows a completely black screen with only the red/yellow/green buttons at top. No text, but I can do some interactions with the browser blindly (cmd + L to type a URL, check "about", open preferences, etc.) NOTHING is visible except when I begin typing in the URL bar, but it stays completely blank otherwise. I have: 1. Completely erased and reinstalled firefox using AppCleaner. 2. Tried firefox safemode - still black. 3. Tried beta and nightly versions 4. Installing the last working version I had (which was 60 on Mac beta 9). *5. Used a guest account - This shows firefox completely normal. 6. Reinstalled with fresh DMGs multiple times, still all black on my primary account. 7. No extensions should be installed, as I have completely erased and installed firefox.
Attached screenshots

Modified by unmeidesu

Chosen solution

A few updates on things that did not work:

1. Updating to Mojave 14.1 (public release and public beta as of today). 2. Reinstalling Mac OS while preserving user data. 3. Deleting user preferences folder, app cache data, etc. 4. Updating firefox to 63.0

The only solution that worked for me is to completely wipe my Mac OS partition and install all of my data manually (I don't use a time machine backup).

Before I tried this fix, MS office apps no longer had text visibility issues in boxes. After freshly installing, Chrome and other apps (app cleaner) do no have the visibility issue anymore. Perhaps it was likely leftover system junk from high sierra.

Anyways, I hope this helps someone else experiencing this.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157440 answers

I've seen another report about this issue, so there might be compatibility issues on Mojave.

Are you possibly using Mojave Dark mode?


I'm not seeing this reported on Bugzilla, so maybe file a bug report.

  • Bug 1466336 - (mojave) [meta][10.14] macOS "Mojave" tracking bug

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

I've seen another report about this issue, so there might be compatibility issues on Mojave. *[/questions/1234151] Firefox windows is all black nothing showing Are you possibly using Mojave Dark mode? ---- I'm not seeing this reported on Bugzilla, so maybe file a bug report. *[https://bugzilla.mozilla.org/show_bug.cgi?id=1466336 Bug 1466336] - (mojave) [meta][10.14] macOS "Mojave" tracking bug (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)

Question owner

Entering about:blank takes me to the page, but it is still totally black. Same for any other page I visit. I can tell by right-clicking the firefox icon.

  • I reset my PRAM and SMC, both changed nothing.
  • The black screen shows in both light/dark mode, but the guest account can show firefox without problems in either mode.
  • I rebooted without opening work on launch. I even tried deleting firefox, rebooting, and reinstalling.
  • I used Cocktail (12 b2) to clear caches, logs, and other misc stuff.
  • I also tried deleting cache with CCleaner for mac.

I'm pretty sure it's a bug at this point, so I'll just wait til the next update and report back when I get the chance.

Edit: As another person pointed out in a bug report, a terminal command is a workaround for fixing this issue. This command keeps the bar/dock as dark, but the rest of MacOS will be bright (finder, notification center, safari, etc. This is a TEMPORARY solution, so please do not mark this as closed until it is properly resolved.

Enter: defaults write -g NSRequiresAquaSystemAppearance -bool YES killall Dock killall Finder

Restart firefox and it will be visible. Change YES to NO to reverse changes (use killall or restart).

Entering about:blank takes me to the page, but it is still totally black. Same for any other page I visit. I can tell by right-clicking the firefox icon. * I reset my PRAM and SMC, both changed nothing. * The black screen shows in both light/dark mode, but the guest account can show firefox without problems in either mode. * I rebooted without opening work on launch. I even tried deleting firefox, rebooting, and reinstalling. * I used Cocktail (12 b2) to clear caches, logs, and other misc stuff. * I also tried deleting cache with CCleaner for mac. I'm pretty sure it's a bug at this point, so I'll just wait til the next update and report back when I get the chance. Edit: As another person pointed out in a bug report, a terminal command is a workaround for fixing this issue. This command keeps the bar/dock as dark, but the rest of MacOS will be bright (finder, notification center, safari, etc. This is a TEMPORARY solution, so please do not mark this as closed until it is properly resolved. Enter: defaults write -g NSRequiresAquaSystemAppearance -bool YES killall Dock killall Finder Restart firefox and it will be visible. Change YES to NO to reverse changes (use killall or restart).

Modified by unmeidesu

FFus3r 50 solutions 757 answers

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:


or see this page:

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] -------------------- '''or see this page: ''' * https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration

Question owner

To test the Hardware acceleration solution, I first disabled system-wide dark mode using the terminal command I posted above:

  • defaults write -g NSRequiresAquaSystemAppearance -bool YES

I then went into Firefox and disabled Hardware acceleration without changing any other settings, then quit. I opened again to confirm the changes were saved and quit.

I reset the terminal command back to its original value with:

  • defaults write -g NSRequiresAquaSystemAppearance -bool NO

I opened Firefox and it still shows up as all black. This is true in both dark/light mode. It is also worth mentioning: While system-wide dark mode is disabled (terminal command), *Firefox responds to the mac system preferences dark/light settings.

  • Firefox only turns completely black when system-wide darkness is enabled (default terminal command, dark finder, mail, notification center, etc.).
To test the Hardware acceleration solution, I first disabled system-wide dark mode using the terminal command I posted above: *defaults write -g NSRequiresAquaSystemAppearance -bool YES I then went into Firefox and disabled Hardware acceleration without changing any other settings, then quit. I opened again to confirm the changes were saved and quit. I reset the terminal command back to its original value with: *defaults write -g NSRequiresAquaSystemAppearance -bool NO I opened Firefox and it still shows up as all black. This is true in both dark/light mode. It is also worth mentioning: While system-wide dark mode is disabled (terminal command), *Firefox responds to the mac system preferences dark/light settings. *Firefox only turns completely black when system-wide darkness is enabled (default terminal command, dark finder, mail, notification center, etc.).

Modified by unmeidesu

cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157440 answers

More information:

  • Bug 1493330 - Firefox shows black window and no dialog text in macOS Mojave

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

More information: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1493330 Bug 1493330] - Firefox shows black window and no dialog text in macOS Mojave (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)

Chosen Solution

A few updates on things that did not work:

1. Updating to Mojave 14.1 (public release and public beta as of today). 2. Reinstalling Mac OS while preserving user data. 3. Deleting user preferences folder, app cache data, etc. 4. Updating firefox to 63.0

The only solution that worked for me is to completely wipe my Mac OS partition and install all of my data manually (I don't use a time machine backup).

Before I tried this fix, MS office apps no longer had text visibility issues in boxes. After freshly installing, Chrome and other apps (app cleaner) do no have the visibility issue anymore. Perhaps it was likely leftover system junk from high sierra.

Anyways, I hope this helps someone else experiencing this.

A few updates on things that did not work: 1. Updating to Mojave 14.1 (public release and public beta as of today). 2. Reinstalling Mac OS while preserving user data. 3. Deleting user preferences folder, app cache data, etc. 4. Updating firefox to 63.0 '''The only solution that worked for me''' is to completely wipe my Mac OS partition and install all of my data manually (I don't use a time machine backup). Before I tried this fix, MS office apps no longer had text visibility issues in boxes. After freshly installing, Chrome and other apps (app cleaner) do no have the visibility issue anymore. Perhaps it was likely leftover system junk from high sierra. Anyways, I hope this helps someone else experiencing this.