Search Support

Caching of download documents

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by Shadow110

more options

I write web applications for a living, and that means that part of the time I am creating on-the-fly Excel and PDF documents. Often I have to edit the document for some tiny formatting detail (e.g. the borders are too thin, a misspelling, the headers should be bold, etc), restart the application and re-download the new file to check whether it is correct. After I do this 4 or 5 times, Firefox starts caching the files and gives me old versions instead. I've deleted all of the past files from the temp folder manually, and still receive the old file. If I connect to the same program in Chrome, I get my new document, so I know that it's not the application. How to I get Firefox to stop caching download files, period? I don't want to click a button to clear out my whole cache every time I restart the application....

Thanks!

All Replies (1)

more options

Separate Security Issue, please update your Flash 27.0 r0 by removing it with this tool : If you use it Reinstall with Flash Player Version: 31.0.0.108 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Hi, this may work out better for you. Changing the cache would involve going into about:config to change it back and forth if wanted it to cache.

These instructions work for Firefox, SeaMonkey, and other related browsers.

On Windows and Linux, use one of the following:

  • Hold both the Ctrl and ⇧ Shift keys and then press R.
  • Hold the ⇧ Shift key and click the Reload button on the navigation toolbar.
  • Hold the Ctrl key and press the F5 key.

Or can get a button to do it for you : https://addons.mozilla.org/en-CA/firefox/addon/reload-skip-cache-button/

As for going into about:config and switching it on and off is that something you want to bother with. If so ask.