Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not show embedded youtube videos on a web page.

  • 2 replies
  • 2 have this problem
  • 10 views
  • Last reply by FireStormC

more options

I've cleared the cache and cookies, I've unchecked "hardware acceleration" and I've disabled the plugin's, deleted the cache and cookies, and I still can't see embedded Youtube videos on a website, all I get is a blank white box. I see them on Safari and Chrome. I've read many things on the web and still can't find out what is wrong. Why does Firefox make it so difficult to do basic things like view a video on a website that most people need to see? Most people will not go looking up how to fix it and I have to explain to a client that doesn't even know what to refresh a page how to fix this problem. I get so frustrated with Firefox that I don't use it for most things any longer. The default settings need to be for what most people need.

All Replies (2)

more options

I would suggest going to the 3 Bar Menu --> Help --> Submit Feedback Or email the same place  : https://qsurvey.mozilla.com/s3/FirefoxInput/ Do make your feelings and constructive thoughts known.

Firefox Volunteer Support Can not do such things.

Please try this : Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

Please let us know if this solved your issue or if need further assistance.

more options

Since I saw that other videos played on the site in Firefox, it must be the code itself, so this is the code that did not work:

<iframe width="640" height="480" src="https://youtu.be/YHfWrrtE024" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>

This is the code that did work:

<iframe width="640" height="480" src="//www.youtube.com/embed/YHfWrrtE024" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>

The code given in the "Share" button for the location of the video did not work, you have to have the embed in the code itself. Yes, this site is still transitional. Can't get the client to update it.