X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Quantum 62.0: Unblock Ports For Grammarly

Posted

Hi,

I need to unblock the following ports so that Grammarly will work again:

       capi.grammarly.com (ports 80 and 443)
       data.grammarly.com (ports 80 and 443)
       auth.grammarly.com (ports 80 and 443)

How do I do this please?

The above is from the following support page:

https://support.grammarly.com/hc/en-us/articles/115000090611-Error-Connecting-to-the-Grammarly-server-message-or-Not-connected-notification-pop-up-

Thx

James

Hi, I need to unblock the following ports so that Grammarly will work again: capi.grammarly.com (ports 80 and 443) data.grammarly.com (ports 80 and 443) auth.grammarly.com (ports 80 and 443) How do I do this please? The above is from the following support page: https://support.grammarly.com/hc/en-us/articles/115000090611-Error-Connecting-to-the-Grammarly-server-message-or-Not-connected-notification-pop-up- Thx James

Chosen solution

Hi James, it probably is a setting, but it could be difficult to track down which one it is.

Have you ruled out the Tracking Protection feature as a potential source of the problem? When Firefox blocking third party tracking servers in a tab, it displays a shield icon toward the left end of the address bar. Click that to turn it off and reload the page without blocking. More info: What happened to Tracking Protection?.


As a start at looking at possibly significant settings, in your regular profile, could you check:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste network. and pause while the list is filtered

(3) Click the Status column heading to group all the modified preferences together. If you like, you can restore the default value of any modified preferences using right-click>Reset, but if you have questions about what they do, you could post a little screenshot or a brief list.

Read this answer in context 0
FFus3r 50 solutions 757 answers
see this answer: * https://support.mozilla.org/en-US/questions/1083282#answer-780274

Question owner

Hi,

FFus3r said

see this answer:

Unfortunately, that hasn't really helped.

The solution provided appears to only allow me to unblock one port so I ended up with the following in about:config:

network.security.ports.banned.override;443

I was not able to add anything else and certainly wasn't able to add the specific things the Grammarly support article suggested.

Thanks

James

Hi, ''FFus3r [[#answer-1155613|said]]'' <blockquote> see this answer: * https://support.mozilla.org/en-US/questions/1083282#answer-780274 </blockquote> Unfortunately, that hasn't really helped. The solution provided appears to only allow me to unblock one port so I ended up with the following in about:config: network.security.ports.banned.override;443 I was not able to add anything else and certainly wasn't able to add the specific things the Grammarly support article suggested. Thanks James

Modified by Kekerusey

FFus3r 50 solutions 757 answers
see this page: * https://superuser.com/questions/1272036/firefox-quantum-i-want-to-access-restricted-port-but-network-security-ports-b

Question owner

Hi,

Unfortunately, the answer given at that link doesn't apply to my problem outlined above ... I'm not even convinced it answers the question originally listed at that site since it says the "'network.security.ports.banned.override' does not work" not that it doesn't exist. The listed configuration item DOES exist in my about:config but has no apparent effect on my ability to connect to Grammarly.

Even when I enter two ports it doesn't seem to have any effect e.g. network.security.ports.banned.override;80,443

This problem is happening on my desktop computer but there's a new dimension ... I was out today and took my laptop with me. That laptop has the same version of Firefox (64bit, Quantum 62) but doesn't have the problem at all. I even checked it when I got back home (hard network as well as wireless). The only difference is that about:config (on the laptop) doesn't have the 'network.security.ports.banned.override' key at all so why is it working and my desktop installation isn't?

Thx

James

Hi, Unfortunately, the answer given at that link doesn't apply to my problem outlined above ... I'm not even convinced it answers the question originally listed at that site since it says the "'network.security.ports.banned.override' does not work" not that it doesn't exist. The listed configuration item DOES exist in my about:config but has no apparent effect on my ability to connect to Grammarly. Even when I enter two ports it doesn't seem to have any effect e.g. network.security.ports.banned.override;80,443 This problem is happening on my desktop computer but there's a new dimension ... I was out today and took my laptop with me. That laptop has the same version of Firefox (64bit, Quantum 62) but doesn't have the problem at all. I even checked it when I got back home (hard network as well as wireless). The only difference is that about:config (on the laptop) doesn't have the 'network.security.ports.banned.override' key at all so why is it working and my desktop installation isn't? Thx James
FFus3r 50 solutions 757 answers

what firewall do you use?

what firewall do you use?

Question owner

Hi,

I have ClamWin AV, Spybot S&D and whatver Windows itself blocks howver, your comment led me to check port access to remote sites (using the PowerShell cmdlet Test-NetConnection) and Windows firewall. I found a rule that appears to let Firefox access all ports from the web at least inbound and added an outbound one but that made no difference. Whatever I did the sites responded (from PS commandline) on port 443 but didn't on port 80.

Eventually, in an effort to prove that the issue wasn't Windows itself I installed the Grammarly addon in Chrome browser and found it worked flawlessly. So I guess the issue must rest with Firefox but, for the life of me, I have no idea what it could be ... it used to work, something changed (during one of the Firefox upgrades I think but can't be absolutely sure) and then it didn't.

At least I can use Chrome but it's annoying because Firefox is my browser of choice and I really would prefer to use it.

Thx

James

Hi, I have ClamWin AV, Spybot S&D and whatver Windows itself blocks howver, your comment led me to check port access to remote sites (using the PowerShell cmdlet Test-NetConnection) and Windows firewall. I found a rule that appears to let Firefox access all ports from the web at least inbound and added an outbound one but that made no difference. Whatever I did the sites responded (from PS commandline) on port 443 but didn't on port 80. Eventually, in an effort to prove that the issue wasn't Windows itself I installed the Grammarly addon in Chrome browser and found it worked flawlessly. So I guess the issue must rest with Firefox but, for the life of me, I have no idea what it could be ... it used to work, something changed (during one of the Firefox upgrades I think but can't be absolutely sure) and then it didn't. At least I can use Chrome but it's annoying because Firefox is my browser of choice and I really would prefer to use it. Thx James
jscher2000
  • Top 10 Contributor
8838 solutions 72240 answers

Firefox doesn't ban the ports 80 (HTTP) or 443 (HTTPS) -- that would prevent all browsing!

The original article you linked to was for Microsoft Office application issues (e.g., in Word or Outlook). That might not be applicable to browser add-ons. Let's start from the beginning:

What error message are you getting, if any?

What are the symptoms of the problem?

''Firefox doesn't ban the ports 80 (HTTP) or 443 (HTTPS) -- that would prevent all browsing!'' The original article you linked to was for Microsoft Office application issues (e.g., in Word or Outlook). That might not be applicable to browser add-ons. Let's start from the beginning: What error message are you getting, if any? What are the symptoms of the problem?

Question owner

Hi,

Good catch ... I didn't realise that however it doesn't detract from the fact that on my laptop Grammarly add-on works (same version Firefox and Windows) but doesn't on my desktop yet Chrome does.

The symptom is it can't connect so doesn't do any grammar corrections (see attached jpg file).

Thx

James

Hi, Good catch ... I didn't realise that however it doesn't detract from the fact that on my laptop Grammarly add-on works (same version Firefox and Windows) but doesn't on my desktop yet Chrome does. The symptom is it can't connect so doesn't do any grammar corrections (see attached jpg file). Thx James
jscher2000
  • Top 10 Contributor
8838 solutions 72240 answers

Hi James, could you test Grammarly in a clean profile?

New Profile Test

This takes about 3 minutes, plus the time to install Grammarly and test relevant sites.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Sept2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system (other than Grammarly) so we can get a clean test.

You'll need to install Grammarly in the new profile, unless Firefox finds it in a shared location.

Does Grammarly work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

Hi James, could you test Grammarly in a clean profile? '''New Profile Test''' This takes about 3 minutes, plus the time to install Grammarly and test relevant sites. Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the Create a New Profile button, then click Next. Assign a name like Sept2018, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Set as default profile''' button below that profile, then scroll back up and click the '''Restart normally''' button. (There are some other buttons, but please ignore them.) Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system (other than Grammarly) so we can get a clean test. You'll need to install Grammarly in the new profile, unless Firefox finds it in a shared location. ''Does Grammarly work any better in the new profile?'' When you are done with the experiment, open the about:profiles page again, click the '''Set as default profile''' button for your normal profile, then click the '''Restart normally''' button to get back to it.

Question owner

OK,

That worked. I realise it was a clean profile but, given that I disabled addons, even reinstalled Firefox at one point (Grammarly worked for a short while then stopped) in my normal profile, can you explain why please?

Thx

James

OK, That worked. I realise it was a clean profile but, given that I disabled addons, even reinstalled Firefox at one point (Grammarly worked for a short while then stopped) in my normal profile, can you explain why please? Thx James
jscher2000
  • Top 10 Contributor
8838 solutions 72240 answers

Chosen Solution

Hi James, it probably is a setting, but it could be difficult to track down which one it is.

Have you ruled out the Tracking Protection feature as a potential source of the problem? When Firefox blocking third party tracking servers in a tab, it displays a shield icon toward the left end of the address bar. Click that to turn it off and reload the page without blocking. More info: What happened to Tracking Protection?.


As a start at looking at possibly significant settings, in your regular profile, could you check:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste network. and pause while the list is filtered

(3) Click the Status column heading to group all the modified preferences together. If you like, you can restore the default value of any modified preferences using right-click>Reset, but if you have questions about what they do, you could post a little screenshot or a brief list.

Hi James, it probably is a setting, but it could be difficult to track down which one it is. Have you ruled out the Tracking Protection feature as a potential source of the problem? When Firefox blocking third party tracking servers in a tab, it displays a shield icon toward the left end of the address bar. Click that to turn it off and reload the page without blocking. More info: [[Tracking Protection]]. ---- As a start at looking at possibly significant settings, in your regular profile, could you check: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''network.''' and pause while the list is filtered (3) Click the Status column heading to group all the '''modified''' preferences together. If you like, you can restore the default value of any modified preferences using right-click>Reset, but if you have questions about what they do, you could post a little screenshot or a brief list.

Question owner

Hi Jscher,

I've decided just to stick with a new profile and be careful with what I add so [maybe] I can figure out what causes it if happens again.

Thank you (and FFus3r) for your help ... I am very grateful as I really didn't want to abandon my favourite browser :)

James

Hi Jscher, I've decided just to stick with a new profile and be careful with what I add so [maybe] I can figure out what causes it if happens again. Thank you (and FFus3r) for your help ... I am very grateful as I really didn't want to abandon my favourite browser :) James